Wednesday, August 19th 2009

EVGA Precision v1.8.0 Released

EVGA rolled out an update to its Precision graphics card overclocking and monitoring software. Version 1.8.0 of EVGA Precision brings with it a number of important changes compared to its older version, including performance and stability fixes related to the application, conflict-resolution for game anti-cheat systems that see Precision's OSD as a positive (a false-positive actually), and a new set of UI skins.

DOWNLOAD: EVGA Precision 1.8.0 (for registered EVGA users)

Changes listed by EVGA are as follows:

  • All vendor specific hardware access code has been moved from the executable file to separate hardware abstraction layer library (RTHAL.dll) to simplify the process of supporting new hardware products in the future
  • Fixed GDI resource leak during monitoring window detachment / attachment.
  • EVGA On-Screen Display Server has been updated to version 3.4.0. New version adds pre-created On-Screen Display rendering profile for "The Chronicles of Riddick: Assault on Dark Athena" and introduces floating injection address hooking technology aimed to reduce the risk of On-Screen Display detection by third party applications (e.g. anti-cheat systems).
  • New skin format v1.2 gives new possibilities to skin developers and reduces skin file size and runtime skin engine memory footprint.
  • Reduced CPU usage for simultaneous GPU and PCB temperature readings, both sensors are being read in single pass now.
  • Added workaround for SLI mode switching related issues on ForceWare 190.xx series drivers. Now Precision is waiting for the end of SLI mode switching process before retrieving any data via NVIDIA driver API.
  • Includes new "Sleek Skins" by Jonttu.
Add your own comment

9 Comments on EVGA Precision v1.8.0 Released

#1
kylzer
New skins look really nice.
Posted on Reply
#2
OnBoard
by: kylzer
New skins look really nice.
They sure do, liking the red and my OC profiles remained.
Posted on Reply
#3
KieranD
sweet i think i will download this, i cant register tho as the card was registered by a previous owner:shadedshu
Posted on Reply
#5
Boneface
Mine doesnt show Temps, am i missing something?
Posted on Reply
#6
t77snapshot
The link on the Evga site gives me this (pic) instead of the install app:confused: and yes I am registered... has anyone had this problem?
Posted on Reply
#7
a_ump
hmmm i can't quite decyfer it but something is definitely wrong :p
Posted on Reply
#8
t77snapshot
by: a_ump
hmmm i can't quite decyfer it but something is definitely wrong :p
Fixed:D I don't know what happened but it works now.
Posted on Reply
#9
OnBoard
by: Boneface
Mine doesnt show Temps, am i missing something?
You can select what it shows (for main window) in the settings.
Posted on Reply