Wednesday, April 28th 2010

ATI Catalyst 10.4 WHQL Driver Suite Released

AMD released the final iteration of Catalyst 10.4 graphics driver suite. The WHQL-signed drivers keep up with the company's one month update cycle, and introduce a wide range of changes. To begin with, game-specific performance improvements in this release are confined to STALKER - Clear Sky, with up to 6% improvement in frame-rates for the Radeon HD 5970, and up to 3% for HD 5800 and HD 5700 series GPUs. There are changes to the video-decoding features, namely addition of H.264 Level 5.1 support, and a fix that reduces the "mosquito noise" seen in highly-compressed video.

Improvements to the video-transcoding capabilities are also a highlight of this release, with enhanced support for Windows 7 drag-and-drop video converter, namely performance increment, support for new H.264 formats such as MTS and WMV9 Complex profile interlaced content, and the ability to toggle GPU-acceleration from Catalyst Control Center. Support for the ATI Video converter is now available in the advanced view of the ATI Catalyst Control Center.

DOWNLOAD: ATI Catalyst 10.4 WHQL for Windows 7/Vista 64-bit, Windows 7/Vista 32-bit, Windows XP 32-bit, Windows XP 64-bit

A list of minor fixes follows.

  • Desktop mouse cursor will no longer intermittently appear enlarged
  • Pressing the "Page Down" button while configuring the last display in Eyefinity group will now properly switch to the next display instead of closing the bezel user interface
  • Shortcut keys to configure the bezel now functions properly
  • "Battlefield 2: Bad Company" maps no longer takes unusually long to load for ATI Radeon HD 5000 Series
  • Performance on 2D applications and benchmarks has now been fixed
  • Flashing no longer visible in "Shattered Horizon" game with CrossFireâ„¢ enabled
  • Changing in-game resolution in "Alien vs. Predator" no longer causes screen flickering under multi-GPU configuration
  • Tint setting under Catalyst Control Center - Basic Color now displays smooth transition when adjusted for Blu-ray playback
  • In-game anti-alias now functions properly when other in-game options like Volumetric Effects are enabled in "Empire: Total War" and "Napoleon: Total War"games
  • Flickering corruption and flashing textures are no longer visible in "Battlefield 2: Bad Company"
Add your own comment

51 Comments on ATI Catalyst 10.4 WHQL Driver Suite Released

#1
jmcslob
Don't bother with em..

I get a black screen in 4 games now AVOID EM
TOTAL GARBAGE

EDIT: I get a black screen with a mouse curser on everything that Involves 3D
HULU and all my Games I'll try to do a total driver reinstall and see if it helps
Posted on Reply
#2
brandonwh64
Addicted to Bacon and StarCrunches!!!
would this be worth upgrading to from the preview version?
Posted on Reply
#4
RejZoR
Makes me wonder if this long loading fix will affect Unreal 2 as well. It's taking so damn long to load on powerful system where it loaded instantly on my old system with half less memory, slower HDD, slower CPU and Radeon 9600 Pro and later x1950 Pro. But with HD5850, it's loading for ages.
Posted on Reply
#5
erocker
by: brandonwh64
would this be worth upgrading to from the preview version?
If what you are currently using works well and you don't see anything you need in the release notes with the new ones. Stick with what you have. That's the way I've been doing it. :toast:
Posted on Reply
#6
brandonwh64
Addicted to Bacon and StarCrunches!!!
by: erocker
If what you are currently using works well and you don't see anything you need in the release notes with the new ones. Stick with what you have. That's the way I've been doing it. :toast:
Thanks Erocker!
Posted on Reply
#7
jmcslob
OMG..
I was hoping these drivers would help loading times on few games..
Now I can't them to load at all....
I just uninstalled the drivers and removed all ATI downloads and I'm gonna try Driver sweeper and cCleaner and all that...If not I go back to 9-12 where at least my stuff loads
Posted on Reply
#8
naoan
by: crow1001
Stick with these http://support.amd.com/us/kbarticles/Pages/ATI-Catalyst-10-4-a-Hotfix.aspx better and newer than the officials and contain the BC2 loading time fix for owners of cards other than the 5000 series.
My question is, does that contain all the fix/change introduced in this whql releases? I'm interested in L5.1 dxva decoding and 2D performance fix but it looks like the whql also introduces some quirk. :confused:

btw, the changelog for those interested http://www2.ati.com/relnotes/Catalyst_104_release_notes.pdf

edit: nvm, tested it myself, seems 10.4a contain the 10.4 whql fix at least in video playback. It can play practically any h264 video in dxva mode, I can even play 720p with 16 reference frame. Just need to untick compatibility check, bravo ATi! this put them on par with Nvidia. :)
Posted on Reply
#9
jmcslob
well after running Driver sweeper and all that fun stuff games do load..but they take about 4 minutes and it seems like I now have Horrific LAG with any and all online games...even those with Known good servers with a 35 ping...WOW
NICE DRIVERS AMD..

I'm sure they fixed all the issues listed but it would seem they created a crap load more..
on a positive note all is fine with my 4830..it would seem they have fixed all my issues with that..now if they could just work on fixing this long load black screen with my 5750 I'd be happy

EDIT: Correction the lag is most likely caused from an update from Windows update for REALTEK GBE PCIe Family Controller
Posted on Reply
#10
DTV DRAGON
I think Iam useing the 10.3b previews and all working good .so do you think there is any benifit for me to try the 10.4a previews?
Posted on Reply
#11
buggalugs
by: jmcslob
Don't bother with em..

I get a black screen in 4 games now AVOID EM
TOTAL GARBAGE

EDIT: I get a black screen with a mouse curser on everything that Involves 3D
HULU and all my Games I'll try to do a total driver reinstall and see if it helps
LOL Drivers are fine for me.

by: jmcslob
well after running Driver sweeper and all that fun stuff games do load..but they take about 4 minutes and it seems like I now have Horrific LAG with any and all online games...even those with Known good servers with a 35 ping...WOW
NICE DRIVERS AMD..

I'm sure they fixed all the issues listed but it would seem they created a crap load more..
on a positive note all is fine with my 4830..it would seem they have fixed all my issues with that..now if they could just work on fixing this long load black screen with my 5750 I'd be happy

EDIT: Correction the lag is most likely caused from an update from Windows update for REALTEK GBE PCIe Family Controller
LOL, dude why not sort your stuff out before posting the drivers are broke and crap and then posting this is ok, its not ok, windows update broke it bla bla etc etc


The 2D fix seems to work well. My desktop feels much snappier.
Posted on Reply
#12
jmcslob
MW2 seemed OK and the desktop is fine as well..

Anyways I went back to 10-1 and all is better now except for COD WaW..
I guess I'll have to wait for the next release to see if that gets fixed..
I thought the release notes said it fixed the Black screen on most stuff..Which I only had 1 program b4 10-4 with that problem after I tried it, it was just about every program..Glad to hear it works for somebody..

Just wish they would fix this crap..
Posted on Reply
#13
ShRoOmAlIsTiC
is the x264 l 5.1 fix for all 2k and up cards or just the newer 5k series
Posted on Reply
#14
Marineborn
im gonna stay away from these drivers for now, i have 10.4a's installed and all works well except just cause 2 these drivers cause the game to not work. but im sacrificing that for the bc2 load times. so its a trade off, i might eventually go back to 10.3B's and deal with the load time and flickering textures so i can play just cause 2
Posted on Reply
#15
petepete
will i even notice a difference with my 4890? D:
Posted on Reply
#16
Gzero
These are dated:
DriverVer=04/06/2010, 8.723.0.0000

10.4a are:
DriverVer=04/19/2010, 8.723.5.0000

So these are obviously older, except 10.4a broke dvxa for me so going to give them a shot and if its still not working going back to opengl drivers 10.3
Posted on Reply
#17
JTS
by: Marineborn
im gonna stay away from these drivers for now, i have 10.4a's installed and all works well except just cause 2 these drivers cause the game to not work.
Really? I have the 10.4a installed and Just Cause 2 is fine on my 4890 :confused:
Posted on Reply
#18
naoan
by: Gzero
So these are obviously older, except 10.4a broke dvxa for me so going to give them a shot and if its still not working going back to opengl drivers 10.3
is it the lower resolution video (less than 720p) as it seems that it broke here too but imo 720p and above is where DXVA counts, so no big deal for me.

please do share your finding though. :toast:
Posted on Reply
#19
Gzero
Just cycled through 10.3ogl4, 10.4, 10.4a.
Strange, one file that is LS3.1 works on 10.3, but on 10.4 it doesn't :(
However an older file that is encoded with LS5.1 isn't working on 10.4
BUT, I'm pretty sure when I watched that file, I was using 10.3ogl and it was fine then too. :S

So confused, switching through the driver sets is annoying lol.

Dumping info:
10.4
code:
Working (it seems)
General
Complete name : D:file1.mkv
Format : Matroska
File size : 349 MiB
Duration : 24mn 0s
Overall bit rate : 2 030 Kbps
Movie name : Cough
Encoded date : UTC 2010-01-13 16:27:49
Writing application : mkvmerge v3.0.0 ('Hang up your Hang-Ups') built on Dec 12 2009 15:20:35
Writing library : libebml v0.7.9 + libmatroska v0.8.1
Cover : Yes

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Muxing mode : Container profile=Unknown@4.1
Codec ID : V_MPEG4/ISO/AVC
Duration : 23mn 59s
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 fps
Original frame rate : 29.970 fps
Resolution : 8 bits
Colorimetry : 4:2:0
Scan type : Progressive
Title : AVC (720p)
Writing library : x264 core 80 r1376 3feaec2
Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=10 / psy=1 / psy_rd=0.5:0.0 / mixed_ref=1 / me_range=32 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / mbaff=0 / constrained_intra=0 / bframes=2 / b_pyramid=0 / b_adapt=2 / b_bias=0 / direct=3 / wpredb=1 / wpredp=2 / keyint=250 / keyint_min=1 / scenecut=60 / rc_lookahead=60 / rc=crf / mbtree=1 / crf=18.0 / qcomp=0.60 / qpmin=5 / qpmax=51 / qpstep=30 / ip_ratio=1.40 / aq=1:1.25
Language : Japanese


code:
Not Working:
Format : Matroska
File size : 30.7 MiB
Duration : 1mn 11s
Overall bit rate : 3 580 Kbps
Movie name : The Melancholy of Haruhi Suzumiya: Special Ending
Encoded date : UTC 2007-05-09 12:50:35
Writing application : mkvmerge v2.0.0 ('After The Rain Has Fallen') built on Jan 13 2007 19:58:56
Writing library : libebml v0.7.7 + libmatroska v0.8.0
Cover : Yes / Yes

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.1
Format settings, CABAC : Yes
Format settings, ReFrames : 11 frames
Muxing mode : Container profile=Unknown@5.1
Codec ID : V_MPEG4/ISO/AVC
Duration : 1mn 11s
Bit rate : 3 349 Kbps
Nominal bit rate : 3 400 Kbps
Width : 704 pixels
Height : 480 pixels
Display aspect ratio : 16:9
Original display aspect ratio : 3:2
Frame rate : 23.976 fps
Original frame rate : 29.970 fps
Resolution : 8 bits
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.413
Stream size : 28.7 MiB (94%)
Title : The Melancholy of Haruhi Suzumiya: Special Ending
Writing library : x264 core 54 svn-614M
Encoding settings : cabac=1 / ref=8 / deblock=1:0:0 / analyse=0x3:0x133 / me=esa / subme=7 / brdo=1 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=0 / threads=1 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / bime=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=3400 / ratetol=1.0 / rceq='blurCplx^(1-qComp)' / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.0:15.0
Language : Japanese

General
Complete name : D:File2.mkv
Format : Matroska
File size : 147 MiB
Duration : 23mn 24s
Overall bit rate : 878 Kbps
Encoded date : UTC 2010-04-03 16:36:21
Writing application : mkvmerge v3.0.0 ('Hang up your Hang-Ups') built on Dec 12 2009 15:20:35
Writing library : libebml v0.7.9 + libmatroska v0.8.1
Cover : Yes

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.1
Format settings, CABAC : Yes
Format settings, ReFrames : 8 frames
Muxing mode : Container profile=Unknown@3.1
Codec ID : V_MPEG4/ISO/AVC
Duration : 23mn 24s
Nominal bit rate : 750 Kbps
Width : 864 pixels
Height : 480 pixels
Display aspect ratio : 16:9
Frame rate mode : Variable
Frame rate : 23.976 fps
Resolution : 8 bits
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.075
Writing library : x264 core 65
Encoding settings : cabac=1 / ref=8 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=7 / psy_rd=1.1:0.0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=1 / nr=0 / decimate=1 / mbaff=0 / bframes=6 / b_pyramid=1 / b_adapt=2 / b_bias=0 / direct=3 / wpredb=1 / keyint=240 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=750 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=1927 / vbv_bufsize=1927 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:0.50


General
Complete name : D:file3.mkv
Format : Matroska
File size : 171 MiB
Duration : 27mn 37s
Overall bit rate : 867 Kbps
Encoded date : UTC 2007-06-06 11:53:18
Writing application : mkvmerge v2.0.2 ('You're My Flame') built on Feb 21 2007 23:40:55
Writing library : libebml v0.7.7 + libmatroska v0.8.1
Cover : Yes / Yes / Yes

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.1
Format settings, CABAC : Yes
Format settings, ReFrames : 8 frames
Muxing mode : Container profile=Unknown@5.1
Codec ID : V_MPEG4/ISO/AVC
Duration : 27mn 37s
Nominal bit rate : 683 Kbps
Width : 848 pixels
Height : 480 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 fps
Resolution : 8 bits
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.070
Writing library : x264 core 54 svn-654
Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=7 / brdo=1 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=0 / threads=2 / nr=0 / decimate=0 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / bime=1 / keyint=250 / keyint_min=25 / scenecut=40(pre) / rc=2pass / bitrate=683 / ratetol=1.0 / rceq='blurCplx^(1-qComp)' / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30
Language : English



Edit: Well some of my filters aren't passing it through to decode on the gpu for certain codecs eg avc->mpeg2.
Going to sweep and try 10.3 again just to double check.
Posted on Reply
#20
saikamaldoss
Mosquito noise removal will apply for all but not for 5400Series which is not mentioned hmmmm just like Auto Tune Support is not supported for 5970

but that can be fixed :)
Posted on Reply
#21
naoan
I've tried all sort of videos and it seems that :

- All video above certain resolution (720p it seems) will work with DXVA, regardless of profiles though kinda unsure with 1080p @ L5.1 (I only have L4.1)
- 1024x576 High@L4.2 15ref frames works, need more samples
- All video below certain resolution (848x480 and below) will have blocking artifact, regardless of profiles but I also have an odd case where it works

The odd video format :
code:
Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Main@L3.1
Format settings, CABAC : Yes
Format settings, ReFrames : 3 frames
Muxing mode : Container profile=Unknown@3.1
Codec ID : V_MPEG4/ISO/AVC
Duration : 2mn 37s
Width : 848 pixels
Height : 480 pixels
Display aspect ratio : 16:9
Frame rate : 29.970 fps
Resolution : 8 bits
Colorimetry : 4:2:0
Scan type : Progressive
Writing library : x264 core 65 r1051M 549cc55
Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x1:0x131 / me=umh / subme=6 / psy_rd=1.0:0.0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=0 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=4 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40(pre) / rc=crf / crf=19.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / ip_ratio=1.40 / pb_ratio=1.30 / aq=0

Posted on Reply
#22
alexsubri
I will try the 10.4 when I get home ... I have the 10.4a but is it me, or does BFBC2 "Join Game" not "Map Loading" seem to be longer? I don't know if it's a BFBC2 bug or ATI bug because this happen after BFBC2 updated it's game ... anybody else have this problem?


In case you don't understand me, when you die you respawn, after like 10 seconds, I will hit "Join Game" and it freezes (brings my FPS down to 1 FPS) and then it loads back up and I have to press "Join Game like 10 times until I am finally available to respawn ...?:banghead:
Posted on Reply
#23
Gzero
After a sweep and clean, 10.3ogl4 working fine for all of the above files I used before.
Posting another thread as I need helping getting dxva accel on a file that isn't playing nice.
Posted on Reply
#24
ACEkombatkiwi
These drivers are awesome went from 16secs load times to 4secs CFX HD5870s Windows 7 64bit :rockout: :roll:
Posted on Reply
#25
Mussels
Moderprator
well thats crap, these dont even include the 10.4a fixes?


edit: links in first post are screwy, 7x64 takes you to XP64 driver
Posted on Reply
Add your own comment