Wednesday, April 27th 2011

AMD Catalyst 11.4 WHQL Software Suite Released

AMD today released this month's timely release of its Catalyst software suite, a unified software package that installs the latest drivers for AMD Radeon graphics processors, AMD HDMI audio device, 7-series and 8-series chipsets, and related system software. This particular release has been touted by its makers within the community to provide significant performance improvements, some of which have been demonstrated by a "preview" version of Catalyst 11.4 released last month. A partial list of those games can be found here. Apart from performance enhancements, Catalyst 11.4 WHQL includes new features such as task based display management controls, an improved Eyefinity setup group, and a new Catalyst update notifier that lets your know if a newer version of AMD Catalyst is available online. There are some OpenCL GPU compute enhancements, and a list of bugs fixed, as listed in the Release Notes document.

DOWNLOAD:AMD Catalyst 11.4 WHQL for Windows 7/Vista 64-bit, Windows 7/Vista 32-bit, Windows XP 32-bit, Windows XP 64-bit
Add your own comment

96 Comments on AMD Catalyst 11.4 WHQL Software Suite Released

#1
devguy
I've been using the Catalyst 11.4 drivers on Windows since the second preview. They are the best drivers I've used so far for both the HD 5850 I had, and the HD 6950 I have now. I believe these are those same drivers, but WHQL signed.

Edit: actually, it does indeed look like the Linux Catalyst 11.4 supports Xorg 1.10, so it is compatible with Natty!
Posted on Reply
#2
t_ski
Former Staff
Just in time for my 6970 that should be arriving today!
Posted on Reply
#3
mybestfriendskip
why is it that NONE of the 11.4 drivers have worked for me in 6950 crossfire? W7 x64 Ultimate...I am dumbfounded why 11.2 work fine, 11.3 work fine but NONE of the 11.4 work including Official 11.4.

????????
Posted on Reply
#4
SetsunaFZero
does this fix the flickering in crysis 2 with crossfire?

cant test it myselft my 2nd card died on me :(
Posted on Reply
#5
trickson
OH, I have such a headache
One thing I have found out the hard way is that for me I have to do a custom install making sure that the ATI drivers do not install the HD audio , If I do a regular install I get a BSOD ! What is with ATI putting HD audio drivers in the video drivers any way ? I have a video card and if I need an Audio driver I will go to my MB manufacture for that . I just do not get this at all . Sure puts a huge cramp in my butt when I install these updated drivers and have a BSOD ! But I did figure it out finally ! Hey ATI how about drivers that do not have these BSOD drivers in them ???
Posted on Reply
#6
SetsunaFZero
by: trickson
One thing I have found out the hard way is that for me I have to do a custom install making sure that the ATI drivers do not install the HD audio , If I do a regular install I get a BSOD ! What is with ATI putting HD audio drivers in the video drivers any way ? I have a video card and if I need an Audio driver I will go to my MB manufacture for that . I just do not get this at all . Sure puts a huge cramp in my butt when I install these updated drivers and have a BSOD ! But I did figure it out finally ! Hey ATI how about drivers that do not have these BSOD drivers in them ???
the hd audio driver is used for the hdmi out
would be kind stupid if u cant output any sound on ur hdmi out and u wonder than wtf isn't there any sound on my tv xD
Posted on Reply
#7
trickson
OH, I have such a headache
by: SetsunaFZero
the hd audio driver is used for the hdmi out
would be kind stupid if u cant output any sound on ur hdmi out and u wonder than wtf isn't there any sound on my tv xD
Well for some reason every time I install the ATI drivers " Normally " I get a BSOD but once I install them in custom form and take out that HD audio driver ( Or prevent it from installing ) It works just fine . So I guess I do not have HDMI Audio and when installing them drivers the result is a BSOD . I have had this happen ever since the 10.11 drivers .
Posted on Reply
#8
bogie
Are the Cat 11.5 preview drivers out yet? Does anyone have a link if they are please?
Posted on Reply
#9
SetsunaFZero
by: trickson
Well for some reason every time I install the ATI drivers " Normally " I get a BSOD but once I install them in custom form and take out that HD audio driver ( Or prevent it from installing ) It works just fine . So I guess I do not have HDMI Audio and when installing them drivers the result is a BSOD . I have had this happen ever since the 10.11 drivers .
try to deinstall and than delete all the leftover drivers on ur pc with driver sweeper than install 11.4 again
this takes srsly some time :/
Posted on Reply
#10
trickson
OH, I have such a headache
by: SetsunaFZero
try to deinstall and than delete all the leftover drivers on ur pc with driver sweeper than install 11.4 again
this takes srsly some time :/
I did this and with out the HD audio drivers every thing goes just fine . Installs with out the BSOD . It sucks when I get that BSOD I tell you what .
Posted on Reply
#11
erocker
by: mybestfriendskip
why is it that NONE of the 11.4 drivers have worked for me in 6950 crossfire? W7 x64 Ultimate...I am dumbfounded why 11.2 work fine, 11.3 work fine but NONE of the 11.4 work including Official 11.4.

????????
Don't know. I'm using 6950s in Crossfire and 11.3s 11.4s are working fine. Must be something with your configuration.
Posted on Reply
#12
mybestfriendskip
by: erocker
Don't know. I'm using 6950s in Crossfire and 11.3s 11.4s are working fine. Must be something with your configuration.
Hi erocker.

Here is my config:

Asus R2E
i7 970
Kingston 6GB
2x XFX 6950 unlocked shaders
W7 x64 Ult.

I am EXTREMELY frustrated and dissapointed with 11.4. I honestly am at my wits end as to why I cannot get these drivers to work. I have never been the one that had problems with my PC, but this problem has been going on for over a month (since 11.4 dated 3/7) and I cannot figure it out.

Last month, I did TWO fresh installs of W7 x64. I installed 11.4 preview on each install with NEITHER install getting crossfire to work....11.2 and 11.3 work just fine once 11.4 was removed.

It was recommended to me to install 11.4 with one card and then install the second one after - still didn't work.

So, with the Official drivers out, I just knew the problem I was having would be fixed....I JUST installed a fresh copy of W7 x64 with 11.4 Official...crossfire still doesn't f*cking work!!! So I uninstall and reinstall, still doesn't work!!

When I install 11.4, the screen goes black and the display never recovers. My monitor light indicates that it is still receiving signal from the graphics card, but no actual display. So, I have to force a shutdown by pressing in the power button....

I've even tried installing 11.4 over top of each other when the first attempt seemed to have failed; I get a BSOD each and every single time.

I'm simply lost for words other than curse words. 11.2 work, 11.3 work, 11.4 are FAIL.

Edit: I've been doing a custom install and removing the audio drivers....they always fail to install anyway.

I'll give anyone $25 via Paypal that can get 11.4 working for me.
BL
Posted on Reply
#13
trickson
OH, I have such a headache
by: mybestfriendskip
Hi erocker.

Here is my config:

Asus R2E
i7 970
Kingston 6GB
2x XFX 6950 unlocked shaders
W7 x64 Ult.

I am EXTREMELY frustrated and dissapointed with 11.4. I honestly am at my wits end as to why I cannot get these drivers to work. I have never been the one that had problems with my PC, but this problem has been going on for over a month (since 11.4 dated 3/7) and I cannot figure it out.

Last month, I did TWO fresh installs of W7 x64. I installed 11.4 preview on each install with NEITHER install getting crossfire to work....11.2 and 11.3 work just fine once 11.4 was removed.

It was recommended to me to install 11.4 with one card and then install the second one after - still didn't work.

So, with the Official drivers out, I just knew the problem I was having would be fixed....I JUST installed a fresh copy of W7 x64 with 11.4 Official...crossfire still doesn't f*cking work!!! So I uninstall and reinstall, still doesn't work!!

When I install 11.4, the screen goes black and the display never recovers. My monitor light indicates that it is still receiving signal from the graphics card, but no actual display. So, I have to force a shutdown by pressing in the power button....

I've even tried installing 11.4 over top of each other when the first attempt seemed to have failed; I get a BSOD each and every single time.

I'm simply lost for words other than curse words. 11.2 work, 11.3 work, 11.4 are FAIL.

I'll give anyone $25 via Paypal that can get 11.4 working for me.
BL
Try installing the drivers in custom mode take out the HD audio drivers and see if that works . I have been having BSOD every time I tried to install them in express mode every time ! Then I used custom and took out ( Not installed ) the audio ones and every thing is fine . Try it out and see . :toast:
Posted on Reply
#14
mybestfriendskip
by: trickson
Try installing the drivers in custom mode take out the HD audio drivers and see if that works . I have been having BSOD every time I tried to install them in express mode every time ! Then I used custom and took out ( Not installed ) the audio ones and every thing is fine . Try it out and see . :toast:
I've been doing this for awhile....

Any other ideas?
Posted on Reply
#15
trickson
OH, I have such a headache
by: mybestfriendskip
I've been doing this for awhile....

Any other ideas?
Try it out with out CCC Just the main drivers ?
Posted on Reply
#16
erocker
by: mybestfriendskip
I've been doing this for awhile....

Any other ideas?
Try the guide I made.
Posted on Reply
#18
mybestfriendskip
by: trickson
Try it out with out CCC Just the main drivers ?
Hi.

I just removed CCC and did a system restart, crossfire still doesn't work....
Posted on Reply
#19
trickson
OH, I have such a headache
by: mybestfriendskip
Hi.

I just removed CCC and did a system restart, crossfire still doesn't work....
Try taking one card out restarting your system then after that turn it back off and reinstall the other card this time put the crossfire ribbon in the other way . Maybe that will wake it up ? Try also put the cards in the other slots ( switch them around ) .
Posted on Reply
#20
dir_d
I would try putting everything back to stock. When i mean everything im talking about CPU, GPU and RAM all back to factory settings and install. Reoverclock and find your stable settings for each one at a time. I had this problem before with my 5870 and it was a user error not a driver error.
Posted on Reply
#21
random
by: trickson
One thing I have found out the hard way is that for me I have to do a custom install making sure that the ATI drivers do not install the HD audio , If I do a regular install I get a BSOD ! What is with ATI putting HD audio drivers in the video drivers any way ? I have a video card and if I need an Audio driver I will go to my MB manufacture for that . I just do not get this at all . Sure puts a huge cramp in my butt when I install these updated drivers and have a BSOD ! But I did figure it out finally ! Hey ATI how about drivers that do not have these BSOD drivers in them ???
Have you tried disabling crossfire before updating drivers? That is what I do and have never experienced BSOD's when upgrading.
Posted on Reply
#22
trickson
OH, I have such a headache
by: random
Have you tried disabling crossfire before updating drivers? That is what I do and have never experienced BSOD's when upgrading.
Yes I have . Thing is it happens every time it start to install them HD audio drivers once it starts it BSOD on me .
Posted on Reply
#24
dark2099
by: SetsunaFZero
does this fix the flickering in crysis 2 with crossfire?

cant test it myselft my 2nd card died on me :(
I think it was solved with the Catalyst Application Profiles, in one of the previous updates, if you download the latest, it will include that fix. Check out my thread here for more info.
Posted on Reply
#25
trickson
OH, I have such a headache
by: erocker
I was on my phone in the hospital. :slap:
I feel like a schmuck ! I am sorry you are in the hospital I hope you get well soon .
Posted on Reply
Add your own comment