Wednesday, February 6th 2013

AMD Rushes Out Catalyst 13.2 Beta 5 Driver to Correct 3DMark CrossFire Scaling Issue

AMD rushed out a new beta version of its Catalyst driver suite, which addresses the issue of improper performance scaling on the new 3DMark, on CrossFire multi-GPU setups. The new Catalyst 13.2 Beta 5 adds a CrossFire profile for 3DMark v1.00 launched on Monday (04/02). Along the way, it also introduced a couple of performance improvements in some highly specific scenarios. For systems running Far Cry 3 at 2560 x 1600 pixels, with 8x AA, performance could go up by 10 percent. With a refined profile, the driver could dole out up to 40 percent higher performance in Crysis 3, on CrossFire setups.

DOWNLOAD: AMD Catalyst 13.2 Beta 5
Add your own comment

32 Comments on AMD Rushes Out Catalyst 13.2 Beta 5 Driver to Correct 3DMark CrossFire Scaling Issue

#1
TheMailMan78
Banstick Dummy
Good to see AMD is now addressing problems instead of denying their existence. Kudos.
Posted on Reply
#2
MAXLD
That makes sense, I was getting a ridiculous 4986 (Fire Strike) with the 7950s. :wtf:
Posted on Reply
#3
brandonwh64
Addicted to Bacon and StarCrunches!!!
I do not believe that this driver will be needed for everyone. I am still on the earlier betas and will most likely stay cause of the performance in arma II.
Posted on Reply
#4
Phusius
by: brandonwh64
I do not believe that this driver will be needed for everyone. I am still on the earlier betas and will most likely stay cause of the performance in arma II.
Yeah, beta 3 is really the only one worth upgrading to. Unless your playing the Crysis 3 demo.
Posted on Reply
#5
Prima.Vera
by: MAXLD
That makes sense, I was getting a ridiculous 4986 (Fire Strike) with the 7950s. :wtf:
Same. I was getting lower scores on crossfire than on normal with 5870/5850.
Posted on Reply
#6
Rahmat Sofyan
rebench the ASUS ROG ARES II 6144 MB with this catalyst please

still curious with CCC 13.1 performance.

Assassin's Creed 3 and etc so very low fps.
Posted on Reply
#7
spectatorx
by: Rahmat Sofyan
rebench the ASUS ROG ARES II 6144 MB with this catalyst please

still curious with CCC 13.1 performance.

Assassin's Creed 3 and etc so very low fps.
Do not bother with assassin's creed 3 game, this was released in pre-alpha stage as final product and ubisoft did not announce anything about fixing the game, they only said "devs are aware" and they said it 3 months ago.

In Boston harbor even top hardware (i7-3770k, 16GB, geforce 690, ssd) can reach... 20fps xD
Posted on Reply
#8
Phusius
by: spectatorx
Do not bother with assassin's creed 3 game, this was released in pre-alpha stage as final product and ubisoft did not announce anything about fixing the game, they only said "devs are aware" and they said it 3 months ago.

In Boston harbor even top hardware (i7-3770k, 16GB, geforce 690, ssd) can reach... 20fps xD
Yep, I am never buying another AC game ever, AC Revelations was very well optimized for PC... really sad AC 3 failed so bad on PC
Posted on Reply
#9
MAXLD
Checks. Just re-tested with these beta5, now I'm having 9654. :)

by: MAXLD
was getting a ridiculous 4986 (Fire Strike) with the 7950s. :wtf:
Posted on Reply
#10
Phusius
BLACK OPS 2 is not working for me with the beta 5 drivers, i can still load the game and play it, but my gun and is all pixelated looking, odd... going back to beta 4, never had an issue with them.
Posted on Reply
#11
RCoon
Forum Gypsy
by: spectatorx
Do not bother with assassin's creed 3 game, this was released in pre-alpha stage as final product and ubisoft did not announce anything about fixing the game, they only said "devs are aware" and they said it 3 months ago.

In Boston harbor even top hardware (i7-3770k, 16GB, geforce 690, ssd) can reach... 20fps xD
When a C2D and a 560 get more frames in a game than a top end chip and gpu, everyone caught on at how badly the game was made :D
Posted on Reply
#12
Prima.Vera
by: RCoon
When a C2D and a 560 get more frames in a game than a top end chip and gpu, everyone caught on at how badly the game was made :D
Console port is bad port. And they will sell Titanium crap card for 900 bucks!! LOL. The irony!
Posted on Reply
#13
Rahmat Sofyan
really?
WTH, I'm not playing it yet, but just little bit weird for the fps.

so both AMD and nVidia not optimize for AC3 if we use SLI or CF?
Posted on Reply
#14
spectatorx
by: Rahmat Sofyan
really?
WTH, I'm not playing it yet, but just little bit weird for the fps.

so both AMD and nVidia not optimize for AC3 if we use SLI or CF?
Problem with ac3 is not on driver side (nvidia nor amd) but on game's side. This is just, as i said before, pre-alpha version software released as final product with no further support.
Posted on Reply
#15
Akrian
Sooo yeah Beta 5 = Far Cry 3 CTD upon startup
3d mark - still locks up the video, drivers go bonkers and the system locks up
3d mark 11 and Heaven 3.0 still run like champs

that's on tri-fire of 7970s and x79 system ( at least it doesn't lock up in half of eyefinity games anymore lol)
Posted on Reply
#16
TheGuruStud
by: spectatorx
Do not bother with assassin's creed 3 game, this was released in pre-alpha stage as final product and ubisoft did not announce anything about fixing the game, they only said "devs are aware" and they said it 3 months ago.

In Boston harbor even top hardware (i7-3770k, 16GB, geforce 690, ssd) can reach... 20fps xD
It's almost mind boggling. The game even uses multiple threads. It was eating 70% of my 8350 @ 4.7 GHZ and I'm still getting only 29-30 fps at worst, usually low 30s, in boston harbor!!!!! :banghead: :nutkick:
Posted on Reply
#17
erocker
by: Akrian
Sooo yeah Beta 5 = Far Cry 3 CTD upon startup
3d mark - still locks up the video, drivers go bonkers and the system locks up
3d mark 11 and Heaven 3.0 still run like champs

that's on tri-fire of 7970s and x79 system ( at least it doesn't lock up in half of eyefinity games anymore lol)
You might want to try some sort of driver clean-up software. I think the issue is going beyond just the driver you have installed.

Or, you system isn't stable somewhere for other reasons.
Posted on Reply
#18
Akrian
Prime stable. OCCT stable. Heaven + 3d mark 11 stable

Used the AMD cleaning utility.

I might try to use ATIman stuff ?
Posted on Reply
#19
erocker
by: Akrian
I might try to use ATIman stuff ?
I wouldn't normally recommend it, but there is one version I used that doesn't screw things up and worked quite well...

Here is the version I used: http://www.mediafire.com/?0jdko53gk5npzo0

(You're running an Intel system, so I wouldn't worry about it messing things up) :)
Posted on Reply
#20
TheGuruStud
by: Akrian
Prime stable. OCCT stable. Heaven + 3d mark 11 stable

Used the AMD cleaning utility.

I might try to use ATIman stuff ?
Lately, I just use driver fusion and only install the driver. Forget CCC and that other useless stuff.
I use radeon pro (get latest beta) for my in game settings. It's a nifty little tool. I can even use dynamic vsync :P
Posted on Reply
#21
Akrian
Ok. Cleaned everything with ATIman.

Reinstalled.

No dice.

Guess they've messed up somewhere. FC3 still no go, 3d mark still locks up the system. I get the feeling that they've messed up the portion regarding x79 and cross/tri/quad fire with 79xx series. ( which produces lockups in tons of games, then they actually acknowledged the problem, and fixed it in 13.1 I believe, maybe something needs tweaking again).
Posted on Reply
#22
cadaveca
My name is Dave
by: Akrian
Ok. Cleaned everything with ATIman.

Reinstalled.

No dice.

Guess they've messed up somewhere. FC3 still no go, 3d mark still locks up the system. I get the feeling that they've messed up the portion regarding x79 and cross/tri/quad fire with 79xx series. ( which produces lockups in tons of games, then they actually acknowledged the problem, and fixed it in 13.1 I believe, maybe something needs tweaking again).
X79 and dual 7-series here, no issue to report. I don't have FC3 installed, however. You can find a tonne of my benchmarks in 3DMark in the pertinent thread, both single and dual card. I suspect some other issue, either hardware or software, might be afoot here.
Posted on Reply
#23
Akrian
Ok. Did some digging.
FC3 still won't work. Buuut I found the reason for 3d mark's behavior: HPET was off via bios. And apparently unlike 11, this one relies heavily on it.
Posted on Reply
#24
Slacker
by: Akrian
Ok. Did some digging.
FC3 still won't work. Buuut I found the reason for 3d mark's behavior: HPET was off via bios. And apparently unlike 11, this one relies heavily on it.
How old is your psu? Because i could see that your psu is more than capable of handling all of that load but maybe your psu is giving up. have you tried running prime95 and furmark at the same time? see if it crashes?
Posted on Reply
#25
Akrian
by: Slacker
How old is your psu? Because i could see that your psu is more than capable of handling all of that load but maybe your psu is giving up. have you tried running prime95 and furmark at the same time? see if it crashes?
Couple of years old. Now it's only FC3 =) every other game and test runs fine ( I've found my issue with 3d mark too). FC3 just errors out after the logo. I've reverted back to 13.1 it works there, so it's a driver issue
Posted on Reply
Add your own comment