Tuesday, May 13th 2008

NVIDIA ForceWare 175.16 WHQL Released

Today NVIDIA has released a new ForceWare driver which supports all cards available today in one driver package.

The driver is available for Windows XP and Vista, both 32-bit and 64-bit Editions.

Download: XP 32 | XP 64 | Vista 32 | Vista 64
Add your own comment

25 Comments on NVIDIA ForceWare 175.16 WHQL Released

#1
Wile E
Power User
Effin finally!!!!!!!!! Downloading now.
Posted on Reply
#2
lepra24
blue screen after 5-min GRID demo :shadedshu,175.12 working for me
Posted on Reply
#3
Psychoholic
Sweet, they're working great for me, performance seems to be about the same.
Posted on Reply
#4
PVTCaboose1337
Graphical Hacker
I see not change... they have not cared about the 7 series for a while. Too bad.
Posted on Reply
#5
farlex85
Blast, I'm locked out of rivatuner again now, and I forgot what to do in the first place to get it to work, shouldn't have gone for it.......
Posted on Reply
#7

WHQL = Windows Hardware Quality Labs (testing) So they are set to Windows and tested on their programs, id assume they are good :)
Posted on Edit | Reply
#8
Wile E
Power User
by: farlex85
Blast, I'm locked out of rivatuner again now, and I forgot what to do in the first place to get it to work, shouldn't have gone for it.......
Run rivatuner with the build switch.
Posted on Reply
#9
farlex85
by: Wile E
Run rivatuner with the build switch.
Actually I just downloaded the latest version and it fixed it, I had an older one that didn't recognize the drivers, had to do config alterations when I initially got it. Its all good now though. :)
Posted on Reply
#10
qwerty_lesh
can anyone tell me if these now have support to get the geforce 8 series cards to overscan through the dvi? is their a like to a changelog or something for 175? :)
Posted on Reply
#11
Black Panther
Senior Moderatorâ„¢
You mean also the 8800GT? Sounds too good to be true! I'll be trying them out tomorrow (now it's past 2:00AM :eek: and I should be in bed!)

Edit: how did it go for you Wile_E?
Posted on Reply
#13
warhammer
Have tried these drivers 4 days ago had problem with them.

While in game at random it would lock up then screen would slowly start to fade to black and back to normal.
Posted on Reply
#14
Solaris17
Creator Solaris Utility DVD
damn still cqnt get sli to work in vista x64 :mad:
Posted on Reply
#15
Wile E
Power User
by: Black Panther
You mean also the 8800GT? Sounds too good to be true! I'll be trying them out tomorrow (now it's past 2:00AM :eek: and I should be in bed!)

Edit: how did it go for you Wile_E?
Well, they don't seem to be playing nice with RivaTuner so far, but that could just be the extremely ridiculous clocks I'm going for. lol. Trying to get it to bench at 1GHz core. :D Haven't tested normal settings yet. I'll do that and get back to this thread.
Posted on Reply
#16
qwerty_lesh
changelog wasnt too helpful but thanks are still in order :)
guess one way for me to find out is to fun these and hook up my lcd tv to my 8800gts again. which reminds me i gotta change my sig again :laugh: :roll:
Posted on Reply
#17
Selene
DV does not work with Vista64, i herd that you can set it, when you first install them, but if you inable SLI it does not work after that.
Posted on Reply
#18
evil bill
by: PVTCaboose1337
I see not change... they have not cared about the 7 series for a while. Too bad.
I wouldn't hold your breath for any drivers that will do anything with 7 series perfomance. If you input the 7 series into the driver search on Nvidias website, it brings up 169.21 as the recommended driver. As far as they are concerned, the 7 series is obselete and nothing after169.21 is going to make any difference to it, unless its by conicidence.
Posted on Reply
#19
Selene
by: Selene
DV does not work with Vista64, i herd that you can set it, when you first install them, but if you inable SLI it does not work after that.
ok i tested this even with SLI off, you can changed DV but it has no effect, so blah i went back to 175.12 works well for me.
Posted on Reply
#20
Ombracol
system lockup

Has anyone been locking up I have since I updated the drivers
Posted on Reply
#21
erocker
by: Wile E
Well, they don't seem to be playing nice with RivaTuner so far, but that could just be the extremely ridiculous clocks I'm going for. lol. Trying to get it to bench at 1GHz core. :D Haven't tested normal settings yet. I'll do that and get back to this thread.
I think I already smell burning...:laugh:
Posted on Reply
#22
mab1376
by: Wile E
Well, they don't seem to be playing nice with RivaTuner so far, but that could just be the extremely ridiculous clocks I'm going for. lol. Trying to get it to bench at 1GHz core. :D Haven't tested normal settings yet. I'll do that and get back to this thread.
thats effin ridiculous!!

i wish i could voltmod my 8800GTS (G80) to get it up to 750MHz or so.
Posted on Reply
#23
Wile E
Power User
by: erocker
I think I already smell burning...:laugh:
Well, considering they just sent me 3 more to try to achieve my goal, I'm gonna guess we will be smelling burnt mosfets at least a couple times in the next few days. lol.
Posted on Reply
#24
SK-1
Well, I had high hopes since the Driver download actually suggest this driver for my 512GTS.
But to my dismay, I have had problems with Madden08' and COD4 has locked up on me.:ohwell:
Time to go back to 169.21 unless someone can suggest a better driver for me.
Posted on Reply
#25
farlex85
Mine's been smooth as always w/ the 512. Might be something other than the drivers.
Posted on Reply
Add your own comment