Friday, December 19th 2008

ATI Catalyst 8.12 Hotfix Released - Corrects Radeon HD 4850 CrossFire X Mode in Vista

ATI programmers have released a hotfix that corrects the black screen and boot OS failure when Catalyst 8.12 is installed on Windows Vista, and two or more ATI Radeon HD 4850 video cards are working in CrossFire X mode. This issue only occurs when two or more ATI Radeon HD 4850 graphic cards are installed in the system with ATI CrossFireX technology. One single ATI Radeon HD 4850 card will not encounter this issue. To download the hotfix for both Windows Vista 32-bit and 64-bit, please click here.Source: AMD/ATI
Add your own comment

25 Comments on ATI Catalyst 8.12 Hotfix Released - Corrects Radeon HD 4850 CrossFire X Mode in Vista

#1
kenkickr
I guess I'll try and see if this also fixes the issue, Incompatible display driver, with my 3870X2's. I know I'm not the only one having this problem with the 8.12's. I'll get back to ya.
Posted on Reply
#2
miloshs
So.... 4870+4850 doesn't have this problem?
Posted on Reply
#3
ilpalmare
by: kenkickr
I guess I'll try and see if this also fixes the issue, Incompatible display driver, with my 3870X2's. I know I'm not the only one having this problem with the 8.12's. I'll get back to ya.
I have 2x 4870 and with this patch the problem is not resolved :banghead: 1 graphic card is incompatible... :banghead::banghead::banghead:
Posted on Reply
#4
kenkickr
Yep, same problem after installing them. Back to 8.11 I go!!:banghead:
Posted on Reply
#5
InnocentCriminal
Resident Grammar Amender
Come on ATi y'bawl bags!

I haven't been impressed with this driver set, they better sort the 9.1's or I'll piss and moan some more.
Posted on Reply
#6
truehighroller1
Well I will be honest here people. I did a fresh install of my OS and installed the 8.12 CCC and drivers and I have 2 4870 1gb cards in cross fire and I have no issues like what they are talking about. My guess is that they have other registry keys that driver cleaner doesn't know about "newly added" and this is left behind because it doesn't know where that key(s) is and this is causing all the issues for people. Has to be because with my fresh install, everything is fine for me. Or maybe it has to do with a certain chipsets or something.



What I really want fixed is these god damn memory leaks in GTA IV PLEASE!!
Posted on Reply
#7
kenkickr
by: ilpalmare
I have 2x 4870 and with this patch the problem is not resolved :banghead: 1 graphic card is incompatible... :banghead::banghead::banghead:
How much memory do you have in your system? I read on AMD forums the issue might be linked to 4+ Gbs in systems. I don't have time to test this right now but maybe tonight or tomorrow.
Posted on Reply
#8
ilpalmare
by: kenkickr
How much memory do you have in your system? I read on AMD forums the issue might be linked to 4+ Gbs in systems. I don't have time to test this right now but maybe tonight or tomorrow.
I have 3GB DDR3.. but the problem is that i have tried to install in VISTA64 in a fresh installation and same problem :banghead::banghead:

So if i put the 8.11 the card function very well and crossfire enable by default after installation
Posted on Reply
#9
kenkickr
I honestly have to say this is all on AMD/ATI. :cry: Hopefully they can get there shit together and get this resolved cause this 8.12 is the worst driver I remember to date...I'm going back from the Rage Fury!
Posted on Reply
#10
ilpalmare
I have opened a ticket to AMD and the response is: the enginnering work to find solution to this problem. Return to 8.11 catalyst at the moment
Posted on Reply
#11
js01
I haven't had any problems with the 8.12 drivers, I always clean out the old ones before installing new ones.
Posted on Reply
#12
EarlZ
LOL! another ATI driver related issue!
Posted on Reply
#13
Steevo
by: EarlZ
LOL! another ATI driver related issue!
Most worthless post evar.:slap:
Posted on Reply
#14
SuRGe
by: kenkickr
I guess I'll try and see if this also fixes the issue, Incompatible display driver, with my 3870X2's. I know I'm not the only one having this problem with the 8.12's. I'll get back to ya.
kenkickr
I have the same system spec's as you and i have my 2 - 3870x2 running in crossfirex on 8.12
I did get the incompatible display driver also at first but my problem was i downloaded the XP 64bit version of the driver instead of the Vista 64bit version.
Could be you have the wrong driver.
Posted on Reply
#15
kenkickr
I'm sure I clicked on the driver link for Vista x64 but before I came to work I downloaded the Vista x64 driver off Sapphiretech.com so tonight after my daughter goes to bed I'll screw around with it.
Posted on Reply
#16
viczulis
All I get is Catallyst Install Manager Has Stopped and wont install on computer. My daughter has 32 bit Vista and 4850 and it installed no problems. :banghead:
Posted on Reply
#17
SuRGe
by: kenkickr
I'm sure I clicked on the driver link for Vista x64 but before I came to work I downloaded the Vista x64 driver off Sapphiretech.com so tonight after my daughter goes to bed I'll screw around with it.
download the offical driver.
http://game.amd.com/us-en/drivers_catalyst.aspx
Posted on Reply
#18
Dixxhead
by: viczulis
All I get is Catallyst Install Manager Has Stopped and wont install on computer. My daughter has 32 bit Vista and 4850 and it installed no problems. :banghead:
Hugh... And here I thought the 8.12 was the best driver set released to date. Made my HD2600 Mobility rock solid and saves all settings on avivo. Not gonna change in a while. :ohwell:
Posted on Reply
#19
eidairaman1
Listen up, this maybe a Hotfix where you gotta Install it without installing ontop of the previous Driver, just use the CCC from that version unless if this Hotfix Driver has it already.

Remember Installing ontop of previous drivers causes more headaches.
Posted on Reply
#20
neomatrix
Still doesn't work,

by: kenkickr
Yep, same problem after installing them. Back to 8.11 I go!!:banghead:
This hotfix only fixes bsod. It doesn't fix the fact that no crossfire option appears since 8.10.

I have P6T Deluxe, latest 1003 BIOS. Crossfire doesn't work at all w/ these new drivers.
Posted on Reply
#21
eidairaman1
i suggest you ping Asus on the Motherboard.
Posted on Reply
#22
neomatrix
Asus or ATI?

If this bug is Asus's MB issue, then why would 8.10 work fine on the same MB, BIOS, and settings?

Some have contacted Asus also. ATI really needs to do better testing before releases. I do realize they can't test all configurations, but these issues should be owned by ATI, it's their product that'll take the hit.
Posted on Reply
#23
Nitro-Max
Wouldnt recomend this for 3870x2 users my games stutter like mad went back to old driver and its fine.

**EDIT**

Fixed somwhere along the lines i must have installed somthing that maybe corrupted the driver did a system restore reinstalled the driver and it seems to be working fine very smooth.
Posted on Reply
#24
eidairaman1
by: neomatrix
If this bug is Asus's MB issue, then why would 8.10 work fine on the same MB, BIOS, and settings?

Some have contacted Asus also. ATI really needs to do better testing before releases. I do realize they can't test all configurations, but these issues should be owned by ATI, it's their product that'll take the hit.
Well if your having such a problem, run the 8.10s then, Also depending on your Vid card, try to get the driver from the manufacturer, not ATI but whoever built your card.
Posted on Reply
#25
Hayder_Master
so first driver i install it is 8.12 , so guys say here 8.11 is better than 8.12
Posted on Reply
Add your own comment