1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

10.6 Causes LOW FPS in BFBC2 For Crossfire User's.

Discussion in 'AMD / ATI' started by alexsubri, Jun 18, 2010.

  1. alexsubri

    alexsubri New Member

    Joined:
    Feb 7, 2010
    Messages:
    1,391 (0.81/day)
    Thanks Received:
    199
    Yup guy's so it's official, BFBC2 doesn't play right and causes major FPS dropage (I would get 30-50 FPS vs 70-130 FPS) in users that have 5850, 5870 (as I've known as of 6/16/10) So, this concludes to me that their is a hot-fix in the works and we won't see it probably for another week. With that said, I think it's time to go back to 10.5 drivers :shadedshu Such ashame, I had high hopes for 10.6 due to the main reasons it improves Flash 10.1 and steaming HD videos. Check that out here

    If this profile update doesn't work I am heading back to 10.5 who's with me!? :rockout:
     
  2. douglatins

    douglatins

    Joined:
    May 15, 2008
    Messages:
    2,869 (1.22/day)
    Thanks Received:
    273
    Location:
    Brasil
    Trying this NOW.......

    :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:
    :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:
    :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:
    :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:

    I am with you but i am boing back to 10,4a... o wait this too:

    :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:
    :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:
    :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:
    :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:
    :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:
    :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:

    And:banghead:
     
    Last edited: Jun 18, 2010
  3. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,795 (13.19/day)
    Thanks Received:
    14,175
    Same here. Back on 10.4a's which are by far the best drivers for me. Stick with what is good and not get all :mad: about it I guess...
     
  4. Hockster

    Hockster

    Joined:
    Mar 30, 2010
    Messages:
    392 (0.24/day)
    Thanks Received:
    100
    Even on Rage3D, an ATi fanboi forum, these drivers suck worse than the 10.5's.
     
  5. Apocolypse007

    Apocolypse007 New Member

    Joined:
    Apr 12, 2006
    Messages:
    615 (0.20/day)
    Thanks Received:
    76
    Location:
    New Sewickley, PA
    Anyone with a 4800 series card try them? I haven't installed them yet, but I play a lot of BC2 and am not sure if the slowdown is just with the 5000 series cards.
     
  6. TRIPTEX_CAN

    TRIPTEX_CAN

    Joined:
    Feb 10, 2008
    Messages:
    3,305 (1.35/day)
    Thanks Received:
    723
    Location:
    BC.CAN
    Yeah.. I had the feeling these were broken for BC2. :shadedshu
    :toast:
     
  7. brandonwh64

    brandonwh64 Addicted to Bacon and StarCrunches!!!

    Joined:
    Sep 6, 2009
    Messages:
    18,677 (9.97/day)
    Thanks Received:
    6,153
    Location:
    Chatsworth, GA
    HMm i just installed yesterday and my 5850 isnt having any problems. i can do a fraps test for you guys but its playing as smooth as butter on high settings
     
    Crunching for Team TPU
  8. TRIPTEX_CAN

    TRIPTEX_CAN

    Joined:
    Feb 10, 2008
    Messages:
    3,305 (1.35/day)
    Thanks Received:
    723
    Location:
    BC.CAN
    For single cards the driver is great. And for crossfire in games other than BC2 the driver is great.... just not crossfire BC2.
     
  9. brandonwh64

    brandonwh64 Addicted to Bacon and StarCrunches!!!

    Joined:
    Sep 6, 2009
    Messages:
    18,677 (9.97/day)
    Thanks Received:
    6,153
    Location:
    Chatsworth, GA
    Yea i herd crossfire was issues! i almost bought another 5850 but herd horror stories about crossfire
     
    Crunching for Team TPU
  10. TRIPTEX_CAN

    TRIPTEX_CAN

    Joined:
    Feb 10, 2008
    Messages:
    3,305 (1.35/day)
    Thanks Received:
    723
    Location:
    BC.CAN
    It really depends, I've been using crossfire since Sept 2008 and it's been OK. You really have to monitor GPU usage and keep updated on drivers and application profiles to make sure things a popping the way they should.
     
  11. EastCoasthandle

    EastCoasthandle New Member

    Joined:
    Apr 21, 2005
    Messages:
    6,889 (1.98/day)
    Thanks Received:
    1,505
  12. Lionheart

    Lionheart

    Joined:
    Apr 30, 2008
    Messages:
    4,063 (1.72/day)
    Thanks Received:
    811
    Location:
    Milky Way Galaxy
    I got some weird dips in fps as well in BC2, but couldn't tell if it was a driver related issue or my mouse was having issues, could be a shitty server maybe, but meh, no problems for me so far except that one:toast:
     
    Last edited: Jun 18, 2010
  13. GotNoRice

    GotNoRice New Member

    Joined:
    Mar 19, 2010
    Messages:
    126 (0.08/day)
    Thanks Received:
    57
    Location:
    Pleasant Hill, CA
    Hmmm I just ran BC2 and confirmed that it's still using all four of my GPUs but performance does seem to be down a bit compared to before.
     
  14. TRIPTEX_CAN

    TRIPTEX_CAN

    Joined:
    Feb 10, 2008
    Messages:
    3,305 (1.35/day)
    Thanks Received:
    723
    Location:
    BC.CAN
    What usage are you getting on each GPU? I was getting 20-30% usage and my performance was about 40% of what I usually see. It's completely broken IMO.
     
  15. alexsubri

    alexsubri New Member

    Joined:
    Feb 7, 2010
    Messages:
    1,391 (0.81/day)
    Thanks Received:
    199
    I guess my other alternative is just to disable xfire while playing BFBC2 :-(
     
  16. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,795 (13.19/day)
    Thanks Received:
    14,175
    ...or install drivers that work. It's a misconception to many that just because new drivers are out it means you need to update. It doesn't. :)
     
  17. PesadeloNuclear New Member

    Joined:
    Jun 17, 2010
    Messages:
    6 (0.00/day)
    Thanks Received:
    0
    Disagree, Im using 5770 single
    with 10.5 my FPS wasnt great but was smooth
    with 10.6 my FPS remain the about the same, but I have some strange variations
    sometimes go from 80 fps to 10 for 5 secs or so, and back to normal :banghead:
     
  18. INSTG8R

    INSTG8R

    Joined:
    Nov 26, 2004
    Messages:
    2,910 (0.80/day)
    Thanks Received:
    470
    Location:
    Lost in Norway
    I'm a little interested in whether this effects 4800's as well. I just installed a 5870 today so I'm giving my old 4870 to my ex-wife to CF her up and she only plays BC2 these days. I don't wanna go over there set her all up and have her call me whining it sucks...
    Were there App Profiles for the 10.4's? or use the 10.5 App profiles with the 10.4a's perhaps?
    Maybe I will just wait until this is sorted out until I bother with it at all....

    OH and my brief test with the 5870 I was getting the same sorta thing as PesadeloNuclear. Odd drops. I just chocked it up to me cranking it in DX11 just to see how well it would run.
     
  19. TRIPTEX_CAN

    TRIPTEX_CAN

    Joined:
    Feb 10, 2008
    Messages:
    3,305 (1.35/day)
    Thanks Received:
    723
    Location:
    BC.CAN
    I see. I had run the game with cat Ai disabled and the game ran OK on only one GPU. I guess I was wrong thanks for the input. :toast:
     
  20. Rik55

    Rik55 New Member

    Joined:
    Nov 28, 2009
    Messages:
    54 (0.03/day)
    Thanks Received:
    15
    Location:
    Glasgow, UK
    INSTG8R, alexsubri and TRIPTEX_CAN say thanks.
  21. alexsubri

    alexsubri New Member

    Joined:
    Feb 7, 2010
    Messages:
    1,391 (0.81/day)
    Thanks Received:
    199
    wow thanks ! I am at work again, will try when I get home ....anybody can confirm this?
     
  22. TheMailMan78

    TheMailMan78 Big Member

    Joined:
    Jun 3, 2007
    Messages:
    21,130 (7.83/day)
    Thanks Received:
    7,657
    This only effects crossfire rigs not single card setups......right?
     
  23. random

    random

    Joined:
    Oct 19, 2008
    Messages:
    3,043 (1.39/day)
    Thanks Received:
    686
    Yeah my first card was 90-100% usage while my second card was 20-30% usage.. when trying these drivers out.. sigh ATI :(

    So @Mailman, its 100% ok for single card setups.
     
  24. TheMailMan78

    TheMailMan78 Big Member

    Joined:
    Jun 3, 2007
    Messages:
    21,130 (7.83/day)
    Thanks Received:
    7,657
    Well one good thing about 10.6 is it fixed the idle clocks
     
  25. alexsubri

    alexsubri New Member

    Joined:
    Feb 7, 2010
    Messages:
    1,391 (0.81/day)
    Thanks Received:
    199
    Crap still don't work, going back 10.4 tomorrow
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page