1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

2 x 4870 poor Vista 64 performance / "random" XP performance

Discussion in 'AMD / ATI' started by AriciU, Jul 13, 2008.

  1. AriciU New Member

    Joined:
    Jul 13, 2008
    Messages:
    13 (0.01/day)
    Thanks Received:
    1
    First problems... XP 32 bits, hotfix driver. I run Crysis bench @ 1680x1050 / noAA and i get 58FPS average. I run Crysis bench again, without changing anyting, and i get only ~45FPS average. WTF? Could the card be switching to 2d clocks while running the test? I ran the damn thing like 20 times already and it's like on and off... very random.

    Second... Vista 64, Vantage performance, hotfix driver. I get only ~9100 points with ~28 fps for the GPU tests when i saw other people with the same CPU clock (4ghz / e8500) getting ~13.5k with ~44fps in gpu tests. Crysis very high is only like 23FPS. It's acting like Crossfire is not working at all under Vista, even though CCC shows it's activated and GPU tool too.

    This is driving me crazy :banghead:
  2. nanohead New Member

    Joined:
    Dec 10, 2007
    Messages:
    122 (0.05/day)
    Thanks Received:
    18
    I have the same inconsistency with 2x4850 and vista 32. I also have massive crashing after lots of driver loads. I dunno either. I keep looking in the event viewer to see if I get any hints, but Vista thinks all is grand.
  3. Live OR Die

    Live OR Die

    Joined:
    May 19, 2007
    Messages:
    3,894 (1.47/day)
    Thanks Received:
    383
    I've told some many people they didn't hear me out, i had this problem with my 9800GX2 crysis would run fine then drop in performance,this problem is with sli-crossfire cards, and XP uses DX9 vista uses DX10 thats why your getting lower FPS, are you running them both in DX9?
  4. AriciU New Member

    Joined:
    Jul 13, 2008
    Messages:
    13 (0.01/day)
    Thanks Received:
    1
    Nah. I've fixed the XP probably. Apparently, if you set the Mipmaps in Catalist to High Performance, and Catalist AL to Standard it actually gives you 10-12FPS less then using Mipmaps to Performance and Cat AL to Advanced.

    Vista however is another story. I managed to run the Crysis bench @ 1680x1050, noAA, High, 64bit and got only ~39fps average. That's a huge drop to the 58 i'm getting in XP. Very high was not even worth running... 23 fps.
  5. AriciU New Member

    Joined:
    Jul 13, 2008
    Messages:
    13 (0.01/day)
    Thanks Received:
    1
    Is no one using this setup under Vista or what?

    This is what i'm talking about. Checkout this results on Q9450 @ 3600Mhz, 8.6 hotfix, Vista 64 vs my results on E8500 @ 4000Mhz, 8.6 hotfix, Vista64.

    [​IMG]

    [​IMG]

    vs

    [​IMG]

    22FPS for Crysys 1680x1050 Very High...didn't bother to take screenshot.


    So, as i see it, Crossfire is not working at all on my rig. It shows at activated in CCC but my results are so bad it can't be using both cards.

    Edit: i just noticed the difference in GPU-Z. 14.4GPixel's, 36GTexel's, 7.14.10.0603 drivers vs 8GPixel's, 20GTexel's, 7.14.10.0598 drivers on my setup :wtf:
  6. newconroer

    newconroer

    Joined:
    Jun 20, 2007
    Messages:
    2,974 (1.13/day)
    Thanks Received:
    294

    Ahh ;sniffs; smell that?

    Good old CF/SLi issues.

    The 'price' people pay for not doing their research.


    Anyways,

    I was just about to say, drivers?

    Then> Bingo >

    Edit: i just noticed the difference in GPU-Z. 14.4GPixel's, 36GTexel's, 7.14.10.0603 drivers vs 8GPixel's, 20GTexel's, 7.14.10.0598 drivers on my setup
  7. AriciU New Member

    Joined:
    Jul 13, 2008
    Messages:
    13 (0.01/day)
    Thanks Received:
    1
    Fixed it. The gpu clock was staying at 500Mhz all the time. I thought it was just for the 2D stuff and it would change to 750 when running 3D... i was wrong.

    Anyway, Catalyst 8.7 beta, fixed clocks to 750/900.

    Crysis very high, 1680x1050, NoAA, DX10, Vista 64

    [​IMG]

    3DMark Vantage Performance - the CPU + physics is really hurting my overall score here... the 3D score is good IMO.

    [​IMG]

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page