1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

2x HIS 4650 crossfire help 1st time doing crossfire

Discussion in 'AMD / ATI' started by nablis, Aug 27, 2010.

  1. nablis New Member

    Joined:
    Aug 27, 2010
    Messages:
    18 (0.01/day)
    Thanks Received:
    0
    hello everyone,
    new to the forums and would just like to say there is a ton of information here that has helped me in the past,glad to be here and keep up the great work.
    now on to my question(s): i recently completed my newest PC build and i'm quite happy with the results of my work,(not like the the pc's i have seen on this sites gallery but i'm getting there :D).i have 2 his 4650's in my rig,i know these are budget cards but that what i can afford at this time,i'm not completely sure if these cards are running in crossfire. i know that i don't need a bridge for these to work. i have downloaded CPUZ and GPUZ to see if both cards show up,which they do,but in the CCC it only appears to be running one of the 4650's. crossfire is enabled and all the drivers have been installed. should i remove both cards and drivers,then reinstall one card and its drivers one at a time? i have also heard the use of windows vista is the only way to have both cards get identified by the OS to make them useful.not sure if that is also true,if some one can enlighten me about this i would really appreciate it. ill will throw up my rigs spec's if that will help:

    asus m4a785td-v evo
    amd phenom 2 black edition 4core
    WD black 1tb hd
    2 HIS hd4650 radeon 1 gb each video cards
    3gb mushkin memory
    600w ultra psu
    windows xp
  2. Mindweaver

    Mindweaver Moderato®™ Staff Member

    Joined:
    Apr 16, 2009
    Messages:
    5,172 (2.63/day)
    Thanks Received:
    2,664
    Location:
    Statesville, NC
    If you have crossfire enabled in CCC then it should be working. Both cards will only show up as one card. If i were you i would download MSI Afterburner and just check the percentage of each card being used. They should be close to evenly used. if you have one card with 0% used then crossfire isn't working. Then and only then would i reinstall drivers. Well that's if you are using the newest 10.8 driver release. I would update to 10.8 if not, they seem to be pretty solid drivers. I just updated mine to 10.8 last night and they seem to be better! :toast:

    EDIT: You should join the crossfire club! there is a lot of good info there.
    nablis says thanks.
    Crunching for Team TPU
  3. nablis New Member

    Joined:
    Aug 27, 2010
    Messages:
    18 (0.01/day)
    Thanks Received:
    0
    thanks so much mindweaver!:respect: having that piece of mind with my abilities as being a 1st time crossfire user puts me in my happy place :p knowing i can this gives me more confidence. i do have the updated CCC and i DL'd the MSI afterburner u suggested and all appears to be working correctly.

    thanks again! :toast:

    EDIT: crossfire club? any links or specific area of this site were its located?
  4. JrRacinFan

    JrRacinFan Served 5k and counting ...

    Joined:
    Mar 17, 2007
    Messages:
    19,414 (7.12/day)
    Thanks Received:
    4,483
    Location:
    Youngstown, OH
    Mindweaver says thanks.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page