1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

A warning to anyone buying Auzentech products.

Discussion in 'General Hardware' started by catnipkiller, Jul 21, 2012.

  1. catnipkiller

    catnipkiller

    Joined:
    Apr 14, 2010
    Messages:
    1,493 (0.93/day)
    Thanks Received:
    502
    Location:
    canada
    I am having problems installing this card into my asrock mobo and have left the support team like 3 emails about 1 month ago with no replies. Even tried to rma it just to get a response and nothing. It looks like they dont support anything in canada or are just ignoring me but I cant install the drivers and the hot fix they have linked is a dead link so I guess I need to find a new card now. I wont be buying from them again.
  2. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,597 (13.37/day)
    Thanks Received:
    13,987
    What is the issue exactly? I'm using an Auzentech card in my AsRock mobo currently. Have you tried installing the driver through the device manager?
  3. pantherx12

    pantherx12 New Member

    Joined:
    Jan 2, 2009
    Messages:
    9,714 (4.71/day)
    Thanks Received:
    1,699
    Location:
    ENGLAND-LAND-LAND


    What the model number, I'll see if I can't hunt down the drivers else where :toast:
  4. catnipkiller

    catnipkiller

    Joined:
    Apr 14, 2010
    Messages:
    1,493 (0.93/day)
    Thanks Received:
    502
    Location:
    canada
    X-Fi Bravura Sound Card
    It keeps saying devices not found and yes I have tried the control panel thing and it tells me no drivers matching or something. The hot fix on the website is to a dead link so i have no idea what to do.
  5. pantherx12

    pantherx12 New Member

    Joined:
    Jan 2, 2009
    Messages:
    9,714 (4.71/day)
    Thanks Received:
    1,699
    Location:
    ENGLAND-LAND-LAND
    7.1 right?

    Can you not download the driver from their website? Or am I misunderstanding the problem.

    ( driver downloaded fine for me you see)

    Although I tend if something says device not found the card needs reseated or is faulty : [
  6. catnipkiller

    catnipkiller

    Joined:
    Apr 14, 2010
    Messages:
    1,493 (0.93/day)
    Thanks Received:
    502
    Location:
    canada
    they have a hot fix link for this card but the link is dead. i can dl the drivers fine but it saying device not found. it works in my other pc but not this rig.(is my main now) and don't want to buy another card for this rig.
  7. pantherx12

    pantherx12 New Member

    Joined:
    Jan 2, 2009
    Messages:
    9,714 (4.71/day)
    Thanks Received:
    1,699
    Location:
    ENGLAND-LAND-LAND
    I can't even find the hotfix :laugh:
  8. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,597 (13.37/day)
    Thanks Received:
    13,987
    When the card is installed is it listed in the device manager?
  9. catnipkiller

    catnipkiller

    Joined:
    Apr 14, 2010
    Messages:
    1,493 (0.93/day)
    Thanks Received:
    502
    Location:
    canada
    High Definition Audio Device. shows up as the same as onboard. i cant install the drives from this keeps telling me "better drivers are already installed".
  10. pantherx12

    pantherx12 New Member

    Joined:
    Jan 2, 2009
    Messages:
    9,714 (4.71/day)
    Thanks Received:
    1,699
    Location:
    ENGLAND-LAND-LAND
    What happens when you uninstall those drivers and then run the driver installation file? (seems like windows has downloaded wrong driver is all)
  11. puma99dk|

    puma99dk|

    Joined:
    Aug 29, 2005
    Messages:
    3,339 (1.02/day)
    Thanks Received:
    748
  12. Dent1

    Joined:
    May 18, 2010
    Messages:
    3,129 (2.00/day)
    Thanks Received:
    901

    Sounds like you shouldn't use an Creative product again. Auzentech make the card, but it's Creatives chipset and drivers that power it.

    Generally speaking Auzentech NON Creative soundcards are pretty much defect free.
  13. Arctucas

    Arctucas

    Joined:
    Jul 14, 2006
    Messages:
    1,764 (0.59/day)
    Thanks Received:
    290
    While I really like my Meridian 2G, I can attest to the non-existant tech support.

    I have an open ticket that I started May 11 that as of today has not been replied to.

    Regardless of how good the product is, I believe I will never again buy an Auzen card simply because they obviously do not care enough about their customers to answer their support tickets.
  14. INSTG8R

    INSTG8R

    Joined:
    Nov 26, 2004
    Messages:
    2,807 (0.79/day)
    Thanks Received:
    420
    Location:
    Lost in Norway
  15. Dent1

    Joined:
    May 18, 2010
    Messages:
    3,129 (2.00/day)
    Thanks Received:
    901
    I owned the Auzentech Meridian from its official release in 2005 and didn't have a single problem. I went through all there drivers over the years, even tried third party drivers and not one problem. Only when I traded it for an X-fi Auzentech Prelude I experienced problem after problem with Creative's buggy drivers. Although the soundcard sounded better admittedly it wasn't worth the headache of swapping cards.

    I can't say I have ever had to call up Auzentech or email them as I've had no negative issue with Auzentech. But yes, if you are saying they don't answer back, that isn't good.



    Edit: catnipkiller, this should fix your problem.


    http://www.auzentech.com/site/company/pressrelease_08082011_new_x-fi_b.php
    Last edited: Jul 21, 2012
  16. catnipkiller

    catnipkiller

    Joined:
    Apr 14, 2010
    Messages:
    1,493 (0.93/day)
    Thanks Received:
    502
    Location:
    canada
    That is the dead link im talking about lol i cant open it.
  17. INSTG8R

    INSTG8R

    Joined:
    Nov 26, 2004
    Messages:
    2,807 (0.79/day)
    Thanks Received:
    420
    Location:
    Lost in Norway
    Dent1 I have had the "Fully Loaded" X-Fi Fatality Pro(with breakout box and remote) since it was released and I NEVER had any serious issues with drivers. It's been across 3 different motherboards and chipsets and never given me any serious issues.
    Granted I have been using Daniel K.'s driver as long as they've been available because why not get the fixes.

    Edit: In fact I was gonna suggest catnipkiller try the Daniel K's but the Bravura seems to be the only one I don't see there for Auzentechs
    Last edited: Jul 21, 2012
    Dent1 says thanks.
  18. Arctucas

    Arctucas

    Joined:
    Jul 14, 2006
    Messages:
    1,764 (0.59/day)
    Thanks Received:
    290
    That is all I am saying, yes.

    But, the Prelude that I replaced with the Meridian 2G only lasted about ten days before it died. Fortunately, Microcenter gave me a cash refund.
    Dent1 says thanks.
  19. NinkobEi

    NinkobEi

    Joined:
    Nov 27, 2006
    Messages:
    2,045 (0.72/day)
    Thanks Received:
    340
    Auzentech Prelude for about 5 years now, still going strong. Maybe there is a PIBMAK
    INSTG8R says thanks.
  20. lindy New Member

    Joined:
    Jun 16, 2012
    Messages:
    81 (0.10/day)
    Thanks Received:
    24
    Location:
    45° 59' 55.57” N 86° 09' 20.10” W
    Just an off the wall idea, but do you have the onboard audio disabled in the BIO's?
  21. catnipkiller

    catnipkiller

    Joined:
    Apr 14, 2010
    Messages:
    1,493 (0.93/day)
    Thanks Received:
    502
    Location:
    canada
    yes. they have that hot fix link but its dead for me can anyone else see it?
  22. Fatal1ty39

    Joined:
    Jul 21, 2009
    Messages:
    90 (0.05/day)
    Thanks Received:
    24
    found it.

    Attached Files:

    pantherx12, 95Viper, INSTG8R and 2 others say thanks.
  23. INSTG8R

    INSTG8R

    Joined:
    Nov 26, 2004
    Messages:
    2,807 (0.79/day)
    Thanks Received:
    420
    Location:
    Lost in Norway
    Nope dead link for me as well.

    I wonder why the Bravura isn't covered under Daniel K's driver. The rest of the Auzentechs are there :confused:

    Would have been worth a shot installing them but I guess not
  24. Dent1

    Joined:
    May 18, 2010
    Messages:
    3,129 (2.00/day)
    Thanks Received:
    901
    One thing I can say about Auzentech (usually there isnt problems) but when there is issues they appear to acknowledge it and release firmware. Try getting Creative to admit to a fault on their end. Creative will blame Asrock or Gigabyte and would release firmware 1 day before the products end of line.
  25. INSTG8R

    INSTG8R

    Joined:
    Nov 26, 2004
    Messages:
    2,807 (0.79/day)
    Thanks Received:
    420
    Location:
    Lost in Norway
    Yes I won't deny that Creative will admit to no mistakes. Daniel K. to the rescue!:laugh:

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page