1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Advent Roma 2000 Laptop Screen trouble.

Discussion in 'General Hardware' started by Israar, Jul 14, 2014.

  1. Israar

    Israar

    Joined:
    Nov 5, 2005
    Messages:
    481 (0.14/day)
    Thanks Received:
    88
    Location:
    England, UK.
    Hey guys and gals! :)

    Been a while since I posted here concerning a problem I couldn't solve! I have a work mates laptop whose screen is completely white. My first initial thought was that the screen itself had gone, either way I tested to see if it worked on an external monitor and it did (with the laptop screen still completely white).

    I have a replacement here that is brand new, does the exact same thing as the screen originally inside the laptop, my concern is that the problem might be due to the cables inside? Although I'm not positive on that. I was certain that it was the screen itself, since I've never had a problem before where it wasn't the screen.

    I've yet to get in touch with the company I bought the replacement screen from, I'll more than likely get on to that after writing this, since the company is currently closed for today.

    The reason I am posting now is because I would like some peace of mind, is there anything else I could try to eliminate the problem my work mate is having (and me since I haven't be able to correct the problem!) or would the majority of you bet that it would be down to the cable since a replacement (brand new) is having the same effect?

    Hope all is well for everyone!

    --Lee
     
  2. Sasqui

    Sasqui

    Joined:
    Dec 6, 2005
    Messages:
    7,802 (2.36/day)
    Thanks Received:
    1,523
    Location:
    Manchester, NH
    Lee, did the replacement screen just include the LCD panel? There are some other items in the bezel (or the main unit) that can go bad, such as the CC inverter. And yes, cables can come loose or break.

    I dealt with a similar problem on someones HP (white screen). Sent it out to a flat rate repair shop on eBay (about $130) and got it back working like new, they said it was the screen.
     
    Israar says thanks.
  3. Batou1986

    Batou1986

    Joined:
    Oct 2, 2005
    Messages:
    2,511 (0.74/day)
    Thanks Received:
    377
    Location:
    Baltimore MD
    I'm willing to bet the screen cable is damaged somewhere, its highly unlikely that the new screen is defective and if its white and bright that means the inverter is working correctly but the screen is not getting proper signals.
     
    Israar says thanks.
  4. Israar

    Israar

    Joined:
    Nov 5, 2005
    Messages:
    481 (0.14/day)
    Thanks Received:
    88
    Location:
    England, UK.
    Thanks for the quick response guys!

    There is no inverter for this laptop Sasqui, which is why I believe it to be a cable fault since I highly doubt it is a faulty brand new screen (slim possibility at best for it to come damage).

    I'll be sending it back for a return, I have 7 days to get it returned as to which I have to specify a reason on my return also, never done it before but not a bad time to start haha! :D

    I'll have to see if I can get myself a cable and see how that goes, in the mean time, thanks for the replies and I'll get back to you on how I get on! :)

    --Lee
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page