1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

all my games crash

Discussion in 'Games' started by stuartb04, Nov 14, 2008.

  1. stuartb04

    stuartb04

    Joined:
    Oct 6, 2008
    Messages:
    583 (0.26/day)
    Thanks Received:
    87
    Location:
    Bristol-U.K
    all of my games either crash or wont load anymore

    been having a few probs with my pc lately(freezing,etc.)
    as posted in the general section

    updated to ati 8-11 driver yesterday.now they wont work
    went back to 8-9.still the same.back to 8-11 now

    hope this is the right section to post this

    thanks
     
  2. ShadowFold

    ShadowFold New Member

    Joined:
    Dec 23, 2007
    Messages:
    16,921 (6.77/day)
    Thanks Received:
    1,644
    Location:
    Omaha, NE
    Please post all of your system specs please.. I bet its your psu, might be a cheap-o.
     
  3. stuartb04

    stuartb04

    Joined:
    Oct 6, 2008
    Messages:
    583 (0.26/day)
    Thanks Received:
    87
    Location:
    Bristol-U.K
    amd 64 x2 dual core 4200+ 2.2ghz(oc to 2.6)
    radeon x1950 pro 512mb pci-e
    trust 570w dual fan pw-5500
    3gig of ram
    22" acer moniter p221w
    Hitachi HDT725032VLA 320gb hd

    had this pc about year now
     
  4. 95Viper

    95Viper

    Joined:
    Oct 12, 2008
    Messages:
    4,417 (2.00/day)
    Thanks Received:
    1,616
    Location:
    στο άλφα έως ωμέγα
    Hello and welcome!

    When did this start, was it with the install of ati 8.11 driver or before.

    Have you checked for any virus, trojan, rootkit, bots, etc?

    Does device manager show hardware problems?

    Have you dusted lately? Really... Check temps...heat is a killer.
     
  5. stuartb04

    stuartb04

    Joined:
    Oct 6, 2008
    Messages:
    583 (0.26/day)
    Thanks Received:
    87
    Location:
    Bristol-U.K
    all my temps are fine-gpu is showing 43c
    cpu-25c
    now hardware probs.no virus.

    it was after 8-11 install.used different drivers too
     
  6. ShadowFold

    ShadowFold New Member

    Joined:
    Dec 23, 2007
    Messages:
    16,921 (6.77/day)
    Thanks Received:
    1,644
    Location:
    Omaha, NE
  7. 95Viper

    95Viper

    Joined:
    Oct 12, 2008
    Messages:
    4,417 (2.00/day)
    Thanks Received:
    1,616
    Location:
    στο άλφα έως ωμέγα
  8. tzitzibp

    tzitzibp New Member

    Joined:
    Nov 17, 2007
    Messages:
    2,225 (0.88/day)
    Thanks Received:
    324
    Location:
    Larisa, Greece
    yes its an oem build in Greece for a couple of Greek pc chain market shops..... Not to be Trusted!:cool:

    try a different PSU.... But I also bet your drivers are all messed up... try erockers' driver removal guide and hopefully you 'll be OK!

    BTW Welcome to TPU!:toast:
     
  9. 95Viper

    95Viper

    Joined:
    Oct 12, 2008
    Messages:
    4,417 (2.00/day)
    Thanks Received:
    1,616
    Location:
    στο άλφα έως ωμέγα
    Checking the other threads that you have had recently, Shadowfold may be correct or you may have other failing hardware, hd, vid card, etc..

    It looks like you been having a torrent of troubles.

    I hope the driver re-install works,but you may want to look deeper, or maybe a complete OS rodo in in order.:)
     
  10. stuartb04

    stuartb04

    Joined:
    Oct 6, 2008
    Messages:
    583 (0.26/day)
    Thanks Received:
    87
    Location:
    Bristol-U.K
    thanks guys
    erockers guide worked.

    this has got to be one the best and most helpful forums
    around :)...
     
  11. 95Viper

    95Viper

    Joined:
    Oct 12, 2008
    Messages:
    4,417 (2.00/day)
    Thanks Received:
    1,616
    Location:
    στο άλφα έως ωμέγα
    COOL!:toast::rockout:
    I am glad... This is a good forum.

    Score another one for EROCKER!!!!
     
  12. tzitzibp

    tzitzibp New Member

    Joined:
    Nov 17, 2007
    Messages:
    2,225 (0.88/day)
    Thanks Received:
    324
    Location:
    Larisa, Greece
    No problem... glad to help!:toast:
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page