1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

AMD Releases the Catalyst 12.4 WHQL Driver

Discussion in 'News' started by Cristian_25H, Apr 25, 2012.

  1. LifeOnMars

    LifeOnMars New Member

    Joined:
    Jun 20, 2008
    Messages:
    2,566 (1.08/day)
    Thanks Received:
    396
    Location:
    Kettering,Northants. UK
    Oh dear, had issues with my new HD 7850 and CTD's/total freeze in games with weird pink vertical lines. 12.3 runs without issues in everything. Rest of the PC is 100% stable and stock.

    I'll wait to see if anyone has the same issues.
     
  2. Prima.Vera

    Prima.Vera

    Joined:
    Sep 15, 2011
    Messages:
    2,284 (1.91/day)
    Thanks Received:
    299
    Anyone test the quality of MLAA for 58xx cards yet?
     
  3. random

    random

    Joined:
    Oct 19, 2008
    Messages:
    3,043 (1.35/day)
    Thanks Received:
    686
    Ok these fixed the idle clocks on my 7970, happy enough.
     
  4. cedrac18

    Joined:
    Aug 14, 2010
    Messages:
    100 (0.06/day)
    Thanks Received:
    11
    Maybe its only fixed if you are not using a displayport adapter. We need more testing from others.
     
  5. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,466 (3.34/day)
    Thanks Received:
    2,205
    can I just install this driver over the 11.9 cat I'm still using?
     
  6. 2wicked

    2wicked

    Joined:
    Jul 13, 2008
    Messages:
    261 (0.11/day)
    Thanks Received:
    94
    Location:
    Directly above the center of the Earth
    AMD VISION Engine control center now controls audio and this sucks for htpc and hdmi audio users.
    My htpc is also my server and stays on 24/7 yet now if I turn off my tv it disables the hdmi audio and will not renable it when the tv is turned back on without repluging the hdmi cable or a reboot.
     
  7. Fatal

    Fatal

    Joined:
    Jan 21, 2009
    Messages:
    732 (0.34/day)
    Thanks Received:
    120
    Location:
    Golden, Colorado
    I have tearing with my Eyefinity 3x1 portrait but from what I saw was just with my browser will check when I get home. My daughter has been playing Assassins Creed 2 and has not said any thing yet.
     
  8. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    13,637 (5.00/day)
    Thanks Received:
    1,854
    read the known issues deal on the drivers, I installed them ontop of 11.12s on a 6770 and no issues here
     
  9. Prima.Vera

    Prima.Vera

    Joined:
    Sep 15, 2011
    Messages:
    2,284 (1.91/day)
    Thanks Received:
    299
    Still no MLAA and CrossFireX in games like SWTOR...:((
     
  10. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    13,637 (5.00/day)
    Thanks Received:
    1,854
    use catalyst feedback program for suggestions n what is and isnt working etc
     
  11. LifeOnMars

    LifeOnMars New Member

    Joined:
    Jun 20, 2008
    Messages:
    2,566 (1.08/day)
    Thanks Received:
    396
    Location:
    Kettering,Northants. UK
    Well, like I said, no issues on 12.3 whatsoever and everything running amazingly well so I'm not really bothered. Plus, I don't use MLAA so it's no loss to me. Just interested as to whether it's an issue with some 7850s.
     
  12. Prima.Vera

    Prima.Vera

    Joined:
    Sep 15, 2011
    Messages:
    2,284 (1.91/day)
    Thanks Received:
    299
    What's that? Do actually think they are monitoring those? Common. They must receive millions daily. I wrote them 2 emails already and no answer from the support. They don't care about their customers at all.
     
    L'Eliminateur says thanks.
  13. Fatal

    Fatal

    Joined:
    Jan 21, 2009
    Messages:
    732 (0.34/day)
    Thanks Received:
    120
    Location:
    Golden, Colorado
    Update: I am only getting the tearing on my browsers when I scroll up or down Eyefinity 3x1 portrait.
     
  14. cedrac18

    Joined:
    Aug 14, 2010
    Messages:
    100 (0.06/day)
    Thanks Received:
    11
    I used to get that to on 11.4 but that's now gone on 12.4. Are you using a displayport adapter?
     
  15. Fatal

    Fatal

    Joined:
    Jan 21, 2009
    Messages:
    732 (0.34/day)
    Thanks Received:
    120
    Location:
    Golden, Colorado
  16. cedrac18

    Joined:
    Aug 14, 2010
    Messages:
    100 (0.06/day)
    Thanks Received:
    11
  17. Mr McC

    Mr McC

    Joined:
    Apr 12, 2010
    Messages:
    1,248 (0.73/day)
    Thanks Received:
    323
    I have been letting CCC overwrite existing drivers for quite some time without issue. I have used and advocate erocker's driver install guide, but it seems that installing on a clean slate is no longer necessary, at least not for me.
     
  18. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,466 (3.34/day)
    Thanks Received:
    2,205
    Yeah been doing the same thing at times but this driver gave me some issues... back to good ol 11.9 :D
     
  19. Steevo

    Steevo

    Joined:
    Nov 4, 2005
    Messages:
    8,536 (2.56/day)
    Thanks Received:
    1,309
    MLAA is much better, audio over HDMi requires a unplug and replug of HDMI to work though.
     
    10 Million points folded for TPU
  20. L'Eliminateur

    L'Eliminateur

    Joined:
    May 22, 2010
    Messages:
    76 (0.05/day)
    Thanks Received:
    6
    it's a BUG of AMD/ATI, i've been trying with zero success for one of the large review sites to publish an article doing an indepth study of this complete and utter SHAM by amd...

    at least on 5870 and 4xxx it happens, i don't know if the 6xxx and 7xxx cards have the same "feature".

    the best you can do is to disable HW acceleration of flash, i know it's retarded but i can go so far to spread this news....
     
  21. cedrac18

    Joined:
    Aug 14, 2010
    Messages:
    100 (0.06/day)
    Thanks Received:
    11
    Yeah, have them same issue with my 5770, and now with the 12.4 drivers my card wont downclock to 157mhz anymore when not in use.
     
  22. Steevo

    Steevo

    Joined:
    Nov 4, 2005
    Messages:
    8,536 (2.56/day)
    Thanks Received:
    1,309
    Mine still downclocks fine, and flash videos as well as html5 and divx play fine with the new drivers. Its just the HDMI that i have issues with, ONLY since I decided to upgrade my drivers. AMD didnt coererce me or hold a gun to my hwad and force me, or anyone else for that matter.
     
    10 Million points folded for TPU
  23. L'Eliminateur

    L'Eliminateur

    Joined:
    May 22, 2010
    Messages:
    76 (0.05/day)
    Thanks Received:
    6
    that's a separate issue, if you overclock in software(ANY software), your 2D clock=UVD clocks which is 400MHz.
    it's another completely retarded "feature" that apparently fixed problems with multimonitor, yet it seems it's too hard for the AMD driver codemonkeys to actually implement.. you know.. a detection routing for when you have several monitor or not...
     
  24. LifeOnMars

    LifeOnMars New Member

    Joined:
    Jun 20, 2008
    Messages:
    2,566 (1.08/day)
    Thanks Received:
    396
    Location:
    Kettering,Northants. UK
    Going to try these again on a fresh install. I take it for a single card (7850) I should still install the latest cap as they also contain single card fixes?
     
  25. Steevo

    Steevo

    Joined:
    Nov 4, 2005
    Messages:
    8,536 (2.56/day)
    Thanks Received:
    1,309
    If you want to.


    Others have reported even better performance with 12.5 beta drivers. However, as always, installing a newer driver if you are happy with the one you have/had is a roll of the dice, as the card you have may lose/gain features/benefits/performance/stability/issues due to optimizations made for other series of cards.

    And lo, the casting of pearls before swine......
     
    10 Million points folded for TPU

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page