1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

AMD SATA Driver Issue

Discussion in 'Motherboards & Memory' started by Nviduum, Aug 21, 2014.

  1. Nviduum New Member

    Joined:
    Aug 16, 2014
    Messages:
    9 (0.03/day)
    Thanks Received:
    1
    Hi there,
    besides my radeon problems, I have another issue with my system.

    Specs:
    Gigabyte GA-MA770-UD3 Rev. 2.1 FKd Bios
    AMD770/SB710
    AMD Phenom II x4 965BE
    8 GBytes RAM DDR-II 800
    OCZ Vertex 2 SSD
    2x Samsung P2270 Monitors

    Problem: Bios is in AHCI mode, reinstalled Win7 64, works with the built in msahci driver.
    Installing the AMD SATA driver has two effects:
    -After the reboot the system gets stuck at the "Windows" start screen, the "activty" LED flashes repeatingly in a rhythmic pattern.

    Uninstalling the SATA driver has no effect on the first mentioned problem, windows is stuck at the boot screen.
    The only way to get the sys working back again is to switch in IDE Mode (thus loosing performance).
    I already tried another SSD and HDD, which doesn't make a difference.
    Any suggestions?

    KR
    Bene
     
  2. OneMoar

    OneMoar

    Joined:
    Apr 9, 2010
    Messages:
    5,013 (2.62/day)
    Thanks Received:
    1,999
    Location:
    Rochester area
    probly need to disable msachi service
    1. run "Regedit
    2. Open HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlset / Services
    3. Open msahci
    4. In the right field left click on "start" and go to Modify
    5. In the value field enter "0" and click "ok"
    6. quit "Regedit"
    installing the amd driver over the msachi driver won't net you any performance so long as ACHI is enabled in the bios
     
  3. Aquinus

    Aquinus Resident Wat-man

    Joined:
    Jan 28, 2012
    Messages:
    7,651 (6.10/day)
    Thanks Received:
    3,022
    Location:
    Concord, NH
    I found that enabling AHCI and installing AMD's AHCI driver for the SB7xx south bridge would cause Windows to BSOD on boot in Windows. A lot of people have said it has something to do with a power saving setting but I was never able to fix it and ended up sticking with Microsoft's default AHCI driver.
     
  4. OneMoar

    OneMoar

    Joined:
    Apr 9, 2010
    Messages:
    5,013 (2.62/day)
    Thanks Received:
    1,999
    Location:
    Rochester area
    the amd south bridge driver must be installed BEFORE you disable MSACHI Via registery
    1. install amd driver
    2. disable msachi in the registery
    3reboot to bios ENABLE achi
    4. profit ...
     
    Nviduum says thanks.
  5. Nviduum New Member

    Joined:
    Aug 16, 2014
    Messages:
    9 (0.03/day)
    Thanks Received:
    1
    Okay, so here's the result:

    Turned out to be an issue with the AMD 14.4 Chipset drivers.
    Msahci was already disabled in the registry, so I put a fresh installation of win 7 on the system.
    Then I installed the 13.4 drivers and voilà it works!

    Thanks for the support guys!!!

    I think this one can be closed :)
     
  6. TRWOV

    TRWOV

    Joined:
    Aug 11, 2011
    Messages:
    4,105 (2.88/day)
    Thanks Received:
    2,837
    Location:
    Mexico
    I love when people post back with the solution... not many newcomers do that. I salute you sir :toast:
     
    Crunching for Team TPU
  7. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    14,184 (4.85/day)
    Thanks Received:
    2,060
    Good to know this info when its time for me to finish my rig
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page