1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

antec truepower trio 650 problems

Discussion in 'General Hardware' started by JUGGERNUTZ, Jul 7, 2007.

  1. JUGGERNUTZ

    JUGGERNUTZ New Member

    Joined:
    Jul 3, 2007
    Messages:
    77 (0.03/day)
    Thanks Received:
    0
    Location:
    Fort Myers, FL
    i am looking to see if anyone has had or is haveing power problems with the antec truepower trio 650..? discribe the issues please
     
  2. dedman New Member

    Joined:
    Mar 12, 2007
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Hello, sorry to bring up an "old" thread. But I also have a problem with an Antec PSU Neo HE 550W. After a bit of searching, I found that ANTEC PSu's have stability problem with the 5v rail: http://www.pjrc.com/about/rambling/antec.html
    Although this is a compatibility problem with Asus MBs, this might as well be it.
    Antec says it has been fixed in the later revisions, but mine is a rev4 and got into trouble after 7-8 months of usage.
    The symptoms are the computer won't start, even though the MB's LED is on.
    I will stay away from Antec PSUs from now on.:mad:
    Hope it was helpful...

    Forgive my pityful English...
    :toast:
     
  3. JUGGERNUTZ

    JUGGERNUTZ New Member

    Joined:
    Jul 3, 2007
    Messages:
    77 (0.03/day)
    Thanks Received:
    0
    Location:
    Fort Myers, FL
    update

    here is my update..
    my old PSU was the antec true power trio 650, the start of my problems is when i started haveing a flicker/studder with my 3d graphics.. http://forums.techpowerup.com/showthread.php?t=34232
    this is a thread i started to help my with this problem. first the fan only 4 pin apex died and then the main power cooling fan stopped.. but this didnt happen untill i replaced every piece of hardwear in my system.. one by one with many tests for each new piece.. i talked to a tech for antec and he said that any defect or power surge will effect every piece of hardwear that is attached to the PSU.. so i replaced the power supply with a very nice cooler master 850 pro..nice.. and it gets even better.. there warrenty is now 5 years and they will also replace any hardwear that the PSU is attached if they are damaged by the PSU... real nice..
    anyways, i still have this flicker and i sent the GPU to BFG and they RMA tested it and they couldnt reproduce this flicker and said it was OK and sent it back to me....:banghead:
    so antec for a PSU, stay away from this product.. go cooler master..
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page