1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

any Idea what might have killed my 2900 xt

Discussion in 'Graphics Cards' started by trt740, Nov 5, 2007.

Thread Status:
Not open for further replies.
  1. trt740

    trt740

    Joined:
    May 12, 2006
    Messages:
    10,935 (3.65/day)
    Thanks Received:
    1,113
    not sure what happened took off the Thermalright and put on the stock cooler to try and sell the card looking more factory like and now when the card tries to run 3d games etc it locks up artifacting, so I put back the Thermalright with no better results. I think I damaged the card somehow removing the Thermalright ahhhhhhhh!!!!!!!!!! or maybe the stock cooler was not on correctly. not sure what to do now card works fine in 2d and i've reinstalled the drivers twice. Anyone got an idea
  2. Hawk1 New Member

    Joined:
    May 8, 2007
    Messages:
    1,249 (0.47/day)
    Thanks Received:
    163
    Location:
    The Big Smoke, Canada
    double check the ramsinks are having good contact. Is it still OC or did you try back at stock settings?
  3. trt740

    trt740

    Joined:
    May 12, 2006
    Messages:
    10,935 (3.65/day)
    Thanks Received:
    1,113
    na it's dead I think the heatsink was slightly off and killed something
  4. Hawk1 New Member

    Joined:
    May 8, 2007
    Messages:
    1,249 (0.47/day)
    Thanks Received:
    163
    Location:
    The Big Smoke, Canada
    Sorry to hear.:(
  5. WhiteLotus

    WhiteLotus

    Joined:
    Jul 30, 2007
    Messages:
    6,530 (2.56/day)
    Thanks Received:
    847
    could you rma it? because that is a really big shame if you cant repair it yourself
  6. intel igent

    intel igent New Member

    Joined:
    Jun 5, 2005
    Messages:
    4,641 (1.39/day)
    Thanks Received:
    434
    Location:
    Toronto, Canada
    why should he RMA? it broke because of something HE did not from manufacturer defect.
  7. regan1985 New Member

    Joined:
    Jun 7, 2006
    Messages:
    1,451 (0.49/day)
    Thanks Received:
    23
    Location:
    Coventry UNI England
    i however wouldnt listen to this and put it as stock and rma it if you can or send it back,chances are you will get a replacement !
  8. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,117 (5.53/day)
    Thanks Received:
    1,454
    Location:
    Oklahoma T-Town
    I would feel bad about RMAing something that I know that I single handily killed.

    Sorry about your card TRT/ Can you hook up a 2ed display and watch your temps while you do a 3dmark run?


    Mine survived a melt down.......
  9. Namslas90 New Member

    Joined:
    Aug 27, 2006
    Messages:
    4,851 (1.68/day)
    Thanks Received:
    555
    Location:
    Earth
    Gpu's are tough, it supprises me thats its having that problem. Maybe give it a rest for a day and then try it again. I have seen "dead" cards come back to "Life" after a rest before.

    :toast:
  10. Ripper3

    Ripper3 New Member

    Joined:
    May 10, 2007
    Messages:
    1,386 (0.53/day)
    Thanks Received:
    117
    Location:
    London, England
    I would feel bad too, but then I'd remember that the cold, heartless company that made the card has millions and millions stock piled somewhere, and that they can easily afford to send me a new one.
    I think if you destroy it through negligence, you shouldn't really RMA. You should really have been more careful.
    But if you took all the care in the world, and, even though you did a modification like changing heatsink, you at the very least deserve to find out what died/why it died, and get a replacement. Like I said above, cold heartless companies. They steal from you anyhow.
    Corporations kill kittens and puppies, and little children.
  11. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,117 (5.53/day)
    Thanks Received:
    1,454
    Location:
    Oklahoma T-Town
    But if I told them what I did and they said send it anyways. Well that's a totally different story.
  12. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,521 (13.50/day)
    Thanks Received:
    13,920

    It could be that the heatsink wasn't on correctly. I banking on syphyllis.
    Mediocre says thanks.
  13. trt740

    trt740

    Joined:
    May 12, 2006
    Messages:
    10,935 (3.65/day)
    Thanks Received:
    1,113
    oem so no rma here.
  14. DOM

    DOM

    Joined:
    May 30, 2006
    Messages:
    7,551 (2.53/day)
    Thanks Received:
    828
    Location:
    TX, USA
    sorry to hear that, but have you looked over the card see if you can see anything damaged ?

    and you put in both pci-e power plugs ?
  15. Mediocre

    Mediocre New Member

    Joined:
    Jun 11, 2006
    Messages:
    1,240 (0.42/day)
    Thanks Received:
    77
    New quote stolen

    +1 Thanks :roll:
  16. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,117 (5.53/day)
    Thanks Received:
    1,454
    Location:
    Oklahoma T-Town
    OEM donest stop you from RMAing BTW:)
  17. lemonadesoda

    lemonadesoda

    Joined:
    Aug 30, 2006
    Messages:
    6,245 (2.16/day)
    Thanks Received:
    963
    Heatsink swapping and crack a "poor" PCB and/or improperly soldered components fracture. This happened to me with 2x Sapphire 9800's. Never bought Sapphire again.
  18. trt740

    trt740

    Joined:
    May 12, 2006
    Messages:
    10,935 (3.65/day)
    Thanks Received:
    1,113
    it says it does oem is not covered
  19. panchoman

    panchoman Sold my stars!

    Joined:
    Jul 16, 2007
    Messages:
    9,595 (3.74/day)
    Thanks Received:
    1,200
    you have to go to the manufacturer for rma. newegg probably wont be able to do the rma for you.
  20. trt740

    trt740

    Joined:
    May 12, 2006
    Messages:
    10,935 (3.65/day)
    Thanks Received:
    1,113
    I cannot even get this part number to enter in ati system oh well
  21. panchoman

    panchoman Sold my stars!

    Joined:
    Jul 16, 2007
    Messages:
    9,595 (3.74/day)
    Thanks Received:
    1,200
    did you try using the card with the hr 03 back on?
  22. Fitseries3

    Fitseries3 Eleet Hardware Junkie

    Joined:
    Oct 6, 2007
    Messages:
    15,509 (6.24/day)
    Thanks Received:
    3,106
    Location:
    Republic of Texas
    if anyones interested...

    i've got a brand new 2900xt 512mb. still sealed in the plastic wrap. let me know if your interested.
  23. trt740

    trt740

    Joined:
    May 12, 2006
    Messages:
    10,935 (3.65/day)
    Thanks Received:
    1,113
    yes temps are fine but artifacting like crazy
  24. panchoman

    panchoman Sold my stars!

    Joined:
    Jul 16, 2007
    Messages:
    9,595 (3.74/day)
    Thanks Received:
    1,200
    could be a corrupt bios, you might've somehow corrupted it when you took the card out, etc. have you tried reflashing?
  25. trt740

    trt740

    Joined:
    May 12, 2006
    Messages:
    10,935 (3.65/day)
    Thanks Received:
    1,113
    thats an idea but i did it when i changed heatsinks.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Thread Status:
Not open for further replies.

Share This Page