1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

anyone know a workaround for Vista Beta 1

Discussion in 'Overclocking & Cooling' started by JaS, Jul 29, 2005.

  1. JaS New Member

    Joined:
    Apr 5, 2005
    Messages:
    74 (0.02/day)
    Thanks Received:
    0
    hey i got all my games and movies and stuff working in vista.but the thing is i cant overclock the card and if i do with ati tray tools on force an oc with atitool i get lines thru the games anyway heres a pic of what the error msg is from atitool any help would be great thx in advance

    Attached Files:

    Last edited: Jul 29, 2005
  2. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    14,787 (3.93/day)
    Thanks Received:
    11,490
    disable the "remove oc lock on 9200" option
  3. JaS New Member

    Joined:
    Apr 5, 2005
    Messages:
    74 (0.02/day)
    Thanks Received:
    0
    i found out that the lddm - longhorn display driver model uses atikmdag.sys not the ati2mtag.sys that windows xp uses ... i wonder if i renamed the ati2mtag.sys from the omega drivers to atikmdag.sys and copied it to the intall folder for the ati beta drivers for windows vista.if that would work.maybe they just renamed it for vista
    Last edited: Jul 30, 2005
  4. JaS New Member

    Joined:
    Apr 5, 2005
    Messages:
    74 (0.02/day)
    Thanks Received:
    0
    i will post the vista inf info and then a windows xp inf to show the file renaming im talking about ... i will only include the info about my card not all the info in the inf files ;-)


    ;-----------------------------------------------
    ; ATI Display Information file : atiilhag.inf
    ;
    ; Installation INF for the ATI display driver.
    ; Copyright(C) 1998-2005 ATI Technologies Inc.
    ;
    ; Windows Codename Longhorn (Beta1)
    ;
    ; Base INF Last Updated Jul 20, 2005
    ;-----------------------------------------------

    [Version]
    Signature="$Windows NT$"
    Provider=%ATI%
    ClassGUID={4D36E968-E325-11CE-BFC1-08002BE10318}
    Class=Display
    DriverVer=07/20/2005, 3.12.1.1.1
    CatalogFile=delta.cat
    ;;;GENCOMMENTLH BEGIN LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING
    ;;;GENCOMMENTLH END LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING

    [DestinationDirs]
    DefaultDestDir = 11
    R300.Miniport = 12 ; drivers
    R300.Display = 11 ; system32
    ;;;GENCOMMENTLH BEGIN LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING
    ;;;GENCOMMENTLH END LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING

    [ControlFlags]
    ExcludeFromSelect=*
    ;;;GENCOMMENTLH BEGIN LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING
    ;;;GENCOMMENTLH END LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING

    ;
    ; Driver information
    ;

    [Manufacturer]
    %ATI% = ATI.Mfg
    ;;;GENCOMMENTLH BEGIN LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING
    ;;;GENCOMMENTLH END LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING

    [ATI.Mfg]
    ;;;GENDRV_MFG BEGIN LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING
    ;;;GENDRV_MFG END LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING
    ;;;GENCOMMENTLH BEGIN LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING
    ;;;GENCOMMENTLH END LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING

    "RADEON 9600 Series (LDDM)" = atikmdag_RV350, PCI\VEN_1002&DEV_4150
    "RADEON 9600 Series (LDDM)" = atikmdag_RV350, PCI\VEN_1002&DEV_4151
    "RADEON 9600 Series (LDDM)" = atikmdag_RV350, PCI\VEN_1002&DEV_4E51
    "RADEON 9600 Series Secondary (LDDM)" = atikmdag_RV350, PCI\VEN_1002&DEV_4171
    "RADEON 9600 Series Secondary (LDDM)" = atikmdag_RV350, PCI\VEN_1002&DEV_4170
    "RADEON 9600 Series Secondary (LDDM)" = atikmdag_RV350, PCI\VEN_1002&DEV_4E71

    and ....

    ;;; GENMFG_ASICLIST atikmdag_R350 4E48 4E68 4E49 4E69 4148 4168 4149 4169
    [atikmdag_R350]
    Include=msdv.inf
    CopyFiles=R300.Miniport, R300.Display
    AddReg = atikmdag_SoftwareDeviceSettings
    AddReg = atikmdag_R350_SoftwareDeviceSettings
    DelReg = atikmdag_RemoveDeviceSettings
    DelFiles = R300.DelFiles
    ;;;GENCODE_ASIC BEGIN LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING
    ;;;GENCODE_ASIC END LINES BETWEEN COMMENTS WILL BE GENERATED DURING PACKAGING

    and here they r for xp ...

    ;-----------------------------------------------
    ; ATI Display Information file : ATIIXPAG.INF
    ; Installation INF for the ATI display driver.
    ; Copyright(C) 1998-2004 ATI Technologies Inc.
    ; Windows XP
    ; Base INF Last Updated 2005/04/01

    [Version]
    Signature="$Windows NT$"
    Provider=%ATI%
    ClassGUID={4D36E968-E325-11CE-BFC1-08002BE10318}
    Class=Display
    DriverVer=06/28/2005, 6.14.10.6553
    CatalogFile=CX_24085.CAT

    [DestinationDirs]
    DefaultDestDir = 11
    ati2mtag.Miniport = 12 ; drivers
    ati2mtag.Display = 11 ; system32

    [ControlFlags]
    ExcludeFromSelect=*
    ;
    ; Driver information
    ;

    [Manufacturer]
    %ATI% = ATI.Mfg, NTx86

    [ATI.Mfg.NTx86]
    "ALL-IN-WONDER 9000" = ati2mtag_RV250, PCI\VEN_1002&DEV_4966&SUBSYS_4F721002
    "ALL-IN-WONDER 9000 - Secondary" = ati2mtag_RV250, PCI\VEN_1002&DEV_496E&SUBSYS_4F731002
    "ALL-IN-WONDER 9200 SERIES" = ati2mtag_RV280, PCI\VEN_1002&DEV_5960&SUBSYS_4F721002
    "ALL-IN-WONDER 9200 SERIES " = ati2mtag_RV280, PCI\VEN_1002&DEV_5961&SUBSYS_2F721002
    "ALL-IN-WONDER 9200 SERIES " = ati2mtag_RV280, PCI\VEN_1002&DEV_5961&SUBSYS_4F721002
    "ALL-IN-WONDER 9200 SERIES - Secondary" = ati2mtag_RV280, PCI\VEN_1002&DEV_5940&SUBSYS_4F731002
    "ALL-IN-WONDER 9200 SERIES - Secondary " = ati2mtag_RV280, PCI\VEN_1002&DEV_5941&SUBSYS_2F731002
    "ALL-IN-WONDER 9500 SERIES" = ati2mtag_R300, PCI\VEN_1002&DEV_4144&SUBSYS_4F721002
    "ALL-IN-WONDER 9600 SERIES" = ati2mtag_RV350, PCI\VEN_1002&DEV_4150&SUBSYS_47721002
    "ALL-IN-WONDER 9600 SERIES " = ati2mtag_RV360, PCI\VEN_1002&DEV_4152&SUBSYS_47721002
    "ALL-IN-WONDER 9600 SERIES " = ati2mtag_RV350, PCI\VEN_1002&DEV_4150&SUBSYS_47221002
    "ALL-IN-WONDER 9600 SERIES " = ati2mtag_RV350, PCI\VEN_1002&DEV_4150&SUBSYS_27721002
    "ALL-IN-WONDER 9600 SERIES - Secondary" = ati2mtag_RV360, PCI\VEN_1002&DEV_4172&SUBSYS_47731002
    "ALL-IN-WONDER 9600 SERIES - Secondary " = ati2mtag_RV350, PCI\VEN_1002&DEV_4170&SUBSYS_47731002
    "ALL-IN-WONDER 9600 SERIES - Secondary " = ati2mtag_RV350, PCI\VEN_1002&DEV_4170&SUBSYS_27731002
    "ALL-IN-WONDER 9600 SERIES - Secondary " = ati2mtag_RV350, PCI\VEN_1002&DEV_4170&SUBSYS_47231002

    and ...

    ati2mtag_R350]
    Include=msdv.inf
    CopyFiles=ati2mtag.Miniport, ati2mtag.Display, ati2mtag.OpenGL, Uninstall.CopyFiles;, DVCR.CopyCodec
    AddReg=Uninstall.AddReg
    ;UpdateInis=DVCR.UpdateIni
    UninstallFiles=Uninstall.CopyFiles
    UninstallReg=Uninstall.AddReg
    CleanFiles=ati2mtag.Miniport, ati2mtag.Display, ati2mtag.OpenGL
    CleanReg=ati2mtag_SoftwareDeviceSettings, ati2mtag_R350_SoftwareDeviceSettings, atioglxx_OpenGLSoftwareSettings, ati2mtag_Desktop_SoftwareDeviceSettings, ati2mtag_LargeDesktopSettings
    CleanService=ati2mtag_RemoveService

    ok well thats the important stuff from the two files if anyone can see if renaming the file would work from that lemme know thanx
    Last edited: Jul 30, 2005
  5. JaS New Member

    Joined:
    Apr 5, 2005
    Messages:
    74 (0.02/day)
    Thanks Received:
    0
    look down ;)
    Last edited: Aug 14, 2005
  6. JaS New Member

    Joined:
    Apr 5, 2005
    Messages:
    74 (0.02/day)
    Thanks Received:
    0
    well i havent got the overclocking working yet in vista but i have got vista to see my card and ram and gpu and all

    1 install vista
    2 Download latest ati windows xp drivers and the vista beta driver from ati.com
    (run all installs in vista like this : right click on the installer and pick properties-next click the compatablility tab and check the run in compatibitity mode and select xp from the drop down box-click ok-right click the installer again and pick run elevated from the menu ..that should solve most of your os not supported things)
    3 install latest windows xp drivers from site
    4 reboot
    5 right click on my copmputer and pick manage --> device manager --->display adapers
    and right click on your ati display adapter --> update driver
    in the box that pops up pick - not at this time --> install from a specific location --> include this location ... and browse to where u have the vista beta drivers extracted to and pick that directory.
    6 let it do its thing then reboot

    thats it now vista will be able to use your vid card to its full potential i saw a proformance increase with areo glass and also in the games on vista lemme know if it helps you out

    P.S This also gets rid of the <unavailable> listings in display adapter properties.
    Last edited: Aug 14, 2005

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page