1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Asrock z68 e3g3 problems?

Discussion in 'General Hardware' started by Zaxmazr, Feb 7, 2012.

  1. Zaxmazr New Member

    Joined:
    Dec 2, 2011
    Messages:
    60 (0.05/day)
    Thanks Received:
    1
    Location:
    Michigan
    Hey everyone, I just got this board with an i5 2500k and some G.Skill Ripjaw's (2g x4 of 1333) and I'm receving a couple problems.

    1st problem: My BIOS' instant flash looks like this, thus I can't update it.
    [​IMG]

    2nd problem: Every once in awhile I get this BSOD.
    [​IMG]

    Any ideas? Does this combo or mobo have these problems a lot?
    **I have the intel stock cooler for now, but stays around 36C idle**
    ***ALSO, I am currently running the i5 at STOCK settings***
     
  2. Zaxmazr New Member

    Joined:
    Dec 2, 2011
    Messages:
    60 (0.05/day)
    Thanks Received:
    1
    Location:
    Michigan
    Meh.
     
  3. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,635 (3.17/day)
    Thanks Received:
    2,408
    Dude I don't make sense half the time but really? What are you asking? Try and be a little more explanatory please.
     
  4. Zaxmazr New Member

    Joined:
    Dec 2, 2011
    Messages:
    60 (0.05/day)
    Thanks Received:
    1
    Location:
    Michigan
    I have these problems...are they because of a defective mobo or...can these be fixed...I don't see how I wasn't clear :/
     
  5. happita

    happita

    Joined:
    Aug 7, 2007
    Messages:
    2,449 (0.85/day)
    Thanks Received:
    483
    I can't see the screenshots because I'm at work, however...check what your RAM frequency, timings, and voltage. If it doesn't match what it is spec'd for, then you need to manually change those settings and make sure it runs at the manufacturer's specs.
    Also, your CPU temp looks fine to me.
     
  6. Zaxmazr New Member

    Joined:
    Dec 2, 2011
    Messages:
    60 (0.05/day)
    Thanks Received:
    1
    Location:
    Michigan
    Okay, ill check when I get home and then update you. Thanks

    Edit: all that seems on track in the BIOS. :/
     
    Last edited: Feb 8, 2012
  7. Zaxmazr New Member

    Joined:
    Dec 2, 2011
    Messages:
    60 (0.05/day)
    Thanks Received:
    1
    Location:
    Michigan
    Nvm, Im just going to RMA it. I put my old board in and Im getting no BSOD's and I have full connection to everything. Thanks for your help!
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page