1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Asrock Z77 Extreme 4 fail

Discussion in 'Motherboards & Memory' started by wim1974, Oct 14, 2012.

  1. wim1974 New Member

    Joined:
    Oct 14, 2012
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
    I just finish building my new pc, but the motherboard fails. When i turn the system on, all fans start up, DVDplayer gets power. But USB device don't work, monitor doesn't display anything and even de debug leds stay dark.

    I have removed the Videocard, i have tried the memory in other slots and removed them completely but still the motherboard seems inactive.

    Does anybody has a suggestion how to handle this?


    Asrock Z77 Extreme4
    Intel i5 3570K
    Corsair Vengeance 8GB
    Cossair H100
    Corsair TX850
    Asus GTX670 CUII 4GB
    Crucial M4 128GB
  2. anoobarak New Member

    Joined:
    Jul 13, 2011
    Messages:
    102 (0.09/day)
    Thanks Received:
    12
    Location:
    Euroland
    Board is probably dead. I did a similar build with same board, cpu and ram. For some reason it died after one restart trying to boot windows from an usb drive. Don't waste your time just RMA it
  3. drdeathx

    drdeathx

    Joined:
    May 14, 2009
    Messages:
    2,132 (1.12/day)
    Thanks Received:
    479
    Location:
    Chicago burbs
    Build the system out of the box on your motherboard box(you may have a grounding problem). If the problem persists, Anoobarak is right. board dead. it happens.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page