1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Asus 5870 bios

Discussion in 'AMD / ATI' started by Paavo, Dec 5, 2010.

  1. Paavo New Member

    Joined:
    Dec 5, 2010
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
    So i've got the flickering issue common with these cards using displayport. best solution i've come across is updating card bios. when i try to update my bios i get an SSID error.

    my card:
    ASUS EAH5870/2DIS/1GD5/A Radeon HD 5870 (Cypress X...

    stock bios:
    http://www.techpowerup.com/vgabios/71895/ATI.HD5870.1024.090914_1.html

    bios i've tried to update to:
    http://www.techpowerup.com/vgabios/61848/ATI.HD5870.1024.091112.html
    http://www.techpowerup.com/vgabios/75015/Asus.HD5870.1024.100304.html

    is there a different one i should be using? help please!
     
  2. theoneandonlymrk

    theoneandonlymrk

    Joined:
    Mar 10, 2010
    Messages:
    3,408 (2.04/day)
    Thanks Received:
    569
    Location:
    Manchester uk
    i think im using your bios and hence get occasional flickering , i put it on so i could go past the 950 gpu wall and adjust gpu volts its worked well and il be honest only ever flickered on a still desktop so hasnt bothered me but now u mention it lol its started to get on me nerves i think the best way i heard of fixing it is to adjust the core speed profiles of your own bios with radeon bios editor so that at idle its higher then 195 as mine is something 400+ id say but havent tried Yet!
     
    5 Million points folded for TPU
  3. Reefer86

    Reefer86

    Joined:
    Jun 21, 2009
    Messages:
    1,474 (0.76/day)
    Thanks Received:
    193
    Location:
    UK
    i just rma'ed my card and now i have a new one and dont have any flicker problems at all.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page