1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ATI 5850 Bad BIOS Flash (ATIflash no adapter found)

Discussion in 'AMD / ATI' started by unknown26man, Nov 2, 2011.

  1. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    I was being a nob. I got the original firmware off my video card and then edited the bottom right in RBE (Radeon Bios Editor) and I changed the model from 5850 to 6990. Then I restarted the computer the video card worked but the ATI drivers dont work with it now. its just a standard VGA Adapter.

    I flashed with ATIWinFlash 2.0.1.14 and since i restarted the computer it wont detect a ATI Card. And neither will the latest ATIFlash in dos. Ive tested it

    In device manager its a Standard VGA Graphics Adapter

    (This is under hardware ID's)
    PCI\VEN_1002&DEV_6F9D&SUBSYS_E1401043&REV_00
    PCI\VEN_1002&DEV_6F9D&SUBSYS_E1401043
    PCI\VEN_1002&DEV_6F9D&CC_030000
    PCI\VEN_1002&DEV_6F9D&CC_0300

    (This is under compatible ID's)
    PCI\VEN_1002&DEV_6F9D&REV_00
    PCI\VEN_1002&DEV_6F9D
    PCI\VEN_1002&CC_030000
    PCI\VEN_1002&CC_0300
    PCI\VEN_1002
    PCI\CC_030000
    PCI\CC_0300


    I've tried using a different GPU for the primary. I would like your help to get this card working.

    Lol it broke yesterday and by the afternoon I had a Nvidia GTX570 as a replacement. I would like to just get this working as a secondary and maybe move it to another pc.

    Now I got a few methods

    Maybe you could edit the ATI Driver files with these ID's or something and get the ATI Display driver at least working and that way i can get ATIWinflash to detect the card and allow itself to flash it.

    I get No Adapter Found in ATIflash

    atiflash -i (Result No Adapter Found)
    atiflash -f -p 0 original.bin (Result No Adapter Found)
    atiflash -f -p 1 original.bin (Result No Adapter Found)
    atiflash -f -p 2 original.bin (Result No Adapter Found)
    atiflash -f -pa original.bin (Result No Adapter Found)

    Just let me know how i can just force flash the card cause i got the original.bin bios.

    BTW I'm Using a ASUS P6T Deluxe

    I Opened up Techpowerup GPU-Z Software
    Selected Standard VGA Adapter at the bottom

    Results
    http://imageshack.us/photo/my-images/851/ssssssi.png/




    Update......
    I've got the sapphire version.

    Which side is the eeprom, thermal paste side or the back that isnt covered by the heat sink?

    Thanks Ill be uploading some pictures of my card soon in high reso and then you can highlight exactly what chip the eeprom is. Ill also lable what the eeprom says. And I dont know where to find the datasheet so ill just give you all the letters and numbers written ontop of the eeprom chip.

    Image URLS
    [​IMG]
    [​IMG]
    [​IMG]
     
    Last edited: Nov 3, 2011
  2. Frogger

    Frogger

    Joined:
    Feb 12, 2006
    Messages:
    2,180 (0.68/day)
    Thanks Received:
    313
    if all else fails read the pdf.
    I assume you have tried to blind flash with no results
    good luck;)
     

    Attached Files:

    omegaman22 and unknown26man say thanks.
  3. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,897 (13.07/day)
    Thanks Received:
    14,306
    Why would anyone with an understanding of bios flashing do this? I hope you can get things working with the .pdf Frogger gave you.
     
  4. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    Could someone give a picture of a location where the flash chip is on the 5850
     
  5. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    I need a picture showing where the flash ship I need to solder is
     
  6. Rapidfire48

    Joined:
    Feb 23, 2009
    Messages:
    536 (0.25/day)
    Thanks Received:
    65
    google it
     
  7. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    Could someone make some sort of tutorial for this card
     
  8. Frogger

    Frogger

    Joined:
    Feb 12, 2006
    Messages:
    2,180 (0.68/day)
    Thanks Received:
    313
    here are links to 3 cards hi res :
    http://www.techpowerup.com/reviews/ASUS/EAH_5850_TOP_DirectCu/images/front_full.jpg
    http://www.techpowerup.com/reviews/HIS/HD_5850/images/front_full.jpg
    http://www.techpowerup.com/reviews/Powercolor/HD_5850_PCS_Plus/images/front_full.jpg
    on the asus card the eeprom with the green dot [lower left next to the gpu} is the chip you need to get the data sheet for. note the chips all have the same # on all cards MAKE sure your's is the same OR get the data sheet for your chip:D
     
    unknown26man says thanks.
  9. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    I've got the sapphire version.

    Which side is the eeprom, thermal paste side or the back that isnt covered by the heat sink?

    Thanks Ill be uploading some pictures of my card soon in high reso and then you can highlight exactly what chip the eeprom is. Ill also lable what the eeprom says. And I dont know where to find the datasheet so ill just give you all the letters and numbers written ontop of the eeprom chip.

    Image URLS
    http://imageshack.us/photo/my-images...oadbehind.jpg/
    http://imageshack.us/photo/my-images...loadfront.jpg/
     
  10. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    Circle and send me an image of the correct chip to solder using the pictures i uploaded. And tell me which pins to solder together is it still pin 1 to 8. or is that different in the 5850 let me know thankyou
     
  11. Frogger

    Frogger

    Joined:
    Feb 12, 2006
    Messages:
    2,180 (0.68/day)
    Thanks Received:
    313
    Last edited: Nov 3, 2011
    unknown26man says thanks.
  12. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
  13. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    Circle whatever chip you want me read off and ill give you the small imprinted writing for that or those chips

    Let me know if one of the ones i circled is right from the pictures
     
    Last edited: Nov 3, 2011
  14. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    Rather get the ATI 5850 running again beside my nvidia gtx 570.
     
  15. Frogger

    Frogger

    Joined:
    Feb 12, 2006
    Messages:
    2,180 (0.68/day)
    Thanks Received:
    313
    try this chip
     

    Attached Files:

  16. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    SL 1601
    ODC
    C0278F

    Read from the chip circled in red
     
  17. Frogger

    Frogger

    Joined:
    Feb 12, 2006
    Messages:
    2,180 (0.68/day)
    Thanks Received:
    313
    rom chip should be
     

    Attached Files:

  18. Frogger

    Frogger

    Joined:
    Feb 12, 2006
    Messages:
    2,180 (0.68/day)
    Thanks Received:
    313
    no way that is it
     
  19. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
  20. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    Pm25L0010
    CE1016
    NK90YHG
     
  21. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
  22. Frogger

    Frogger

    Joined:
    Feb 12, 2006
    Messages:
    2,180 (0.68/day)
    Thanks Received:
    313
    PM 25 l0010 :toast:
     
  23. Frogger

    Frogger

    Joined:
    Feb 12, 2006
    Messages:
    2,180 (0.68/day)
    Thanks Received:
    313
  24. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    Okay now we are making some progress can you give me links for the chips in datasheet. Also can you now help me recover the bios i got the original bios image. Help me get ATIflash to detect it.
     
  25. unknown26man New Member

    Joined:
    Nov 2, 2011
    Messages:
    35 (0.03/day)
    Thanks Received:
    0
    Got any ideas. Do a diagram what i need to do
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page