1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ATI Catalyst 5.6

Discussion in 'News' started by W1zzard, Jun 10, 2005.

  1. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,606 (3.79/day)
    Thanks Received:
    13,222
    Yesterday ATI has released their Catalyst 5.6 drivers.

    Major changes are:
    • CATALYST Mobility: An industry first with end users able to download the latest CATALYST release every month for their notebook PC, which will include all of the regular Desktop CATALYST features, plus all of the laptop specific features our notebook users are familiar with – Initially the CATALYST Mobility driver will be only supported on the Mobility RADEON X700 and Mobility RADEON X800 graphics accelerators, from select system builders.
    • CATALYST Control Center Performance enhancements: Stream-lining the CATALYST Control Center code has increased start-up time, user-interface responsiveness, and over all stability. You can expect to see the CATALYST Control Center performance and overall size to keep improving over the next few CATALYST releases.
    • CATALYST Control Center User Interface Enhancements: Enhancements to the user interface and new functionality added to the system tray makes configuring settings much simpler for end users
    • New Linux installer: ATI’s brand new installer makes installing the ATI Linux driver a much simpler and user friendly experience
    • New Video features for the CATALYST Control Center:
      - New video preview
      - Real-time video preview shows users the benefits of adjusting video settings without committing changes
      - Simpler video playback
      - Easily enable full-screen video playback on your second display
      - New video wizard
      - Helps users optimize their display configuration
      - Video de-interlacing options
      - Video enthusiasts can choose the which de-interlacing method they want to use
      - WMV9 acceleration
      - Full hardware acceleration of Microsoft Windows Movie files using DirectX 9 shaders – Reduces CPU usage up to 50%, and significantly reduces the probability of dropping frames while playing video
    • Performance gains:
      - Doom3 up to 7% (at lower resolutions)
      - As a result of efficiency improvements in the OpenGL driver Chronicles of Riddick up to 10% (at lower resolutions)
      - As a result of efficiency improvements in the OpenGL driver Halo up to 20 %, 3DMark05 up to 5 %
      - As a result of a generic driver Z-optimizations – removing un-seen pixels before running through pixel shaders

    Display Driver | Control Panel | WDM Capture Driver | Catalyst Control Center | Softmod Drivers
     
    Last edited: Jun 12, 2005
  2. Unregistered Guest

    hey w1zzard
    thx for ur work...btw, it seems to patched ati2mtag.sys doesnt work...i'm using radeon 9500 and everest program says it has 4pipeline only:(
    previous drivers worked fine for me...can u chk it again?
     
  3. 15th Warlock

    15th Warlock

    Joined:
    Aug 16, 2004
    Messages:
    2,987 (0.74/day)
    Thanks Received:
    1,565
    Location:
    Visalia, CA
    Thx for the heads up W1zzard, just one little problem, after installing the 5.6s, the option for changing the Catalyst A.I. level in Atitool 0.24 is greyed out, is there anyway to fix this? Thanks :)
     
  4. Unregistered Guest

    9500->9700 doesnt work...

    Same card same Problem!
    THX
     
  5. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,606 (3.79/day)
    Thanks Received:
    13,222
    is only the patched ati2mtag.zip file not working or are the installers broken too?
     
  6. grazzhoppa New Member

    Joined:
    Apr 16, 2005
    Messages:
    221 (0.06/day)
    Thanks Received:
    3
    I used the installer and everything is fine. ATItool says 8 pipelines and 3Dmark says the fill rate is at 2000+.

    On other note, how would I go about installing the Catalyst Control Center with the softmod? Install the display driver.exe from here and install the CCC from ati.com, in that order?
     
  7. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,606 (3.79/day)
    Thanks Received:
    13,222
    yep install the ccc download once you got everything running from a driver perspective
     
  8. DrAsh Guest

    ATITool (0.23) gave 237 fps on Catalyst 5.3, 5.4, and 5.5, but only 171 on 5.6. Upgarding to 0.24 and it gives the same 171 result with Catalyst 5.6, yet Doom3 *does* feel better (can now play on High Quality 1024x768, no AA with no real jerkiness). What gives?

    Regards,


    Sapphire 9800 Pro Atlantis 128MB
    ASUS K8VSEDX with Sempron 3100+, stock h/s
    2x512 DDR 400 Crucial RAM
    XP Pro SP2
     
  9. DrAsh Guest

    ATITool (0.23) gave 237 fps on Catalyst 5.3, 5.4, and 5.5, but only 171 on 5.6. Upgarding to 0.24 and it gives the same 171 result with Catalyst 5.6, yet Doom3 *does* feel better (can now play on High Quality 1024x768, no AA with no real jerkiness). What gives?

    Regards,


    Sapphire 9800 Pro Atlantis 128MB
    ASUS K8VSEDX with Sempron 3100+, stock h/s
    2x512 DDR 400 Crucial RAM
    XP Pro SP2
     
  10. DrAsh Guest

    Double post, my bad, sorry - the forum was running like treacle.
     
  11. Unregistered Guest

    i can't install softmod driver...installer says 'this driver does not compatible with your hardware...'
    ati's original 5.6 driver and previous softmod drivers works fine...so, i installed 5.5mod driver again:(
     
  12. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,606 (3.79/day)
    Thanks Received:
    13,222
    hmm lots of strange reports .. could one person with a 9500np and another person with a 9800se please redownload the 5.6 softmod drivers and give it a try?
     
  13. Unregistered Guest

    dont work

    Install correctly but only 4 pipes active with a 9800SE.
     
  14. Unregistered Guest

    Now works fine. I pass 3dmark2003 and have 8 pipes active but in 3dmark2001 game nature works like only 4 pipes active.
     
  15. mc00 New Member

    Joined:
    Mar 5, 2005
    Messages:
    6 (0.00/day)
    Thanks Received:
    0
    hey thanks for the release... but is not workin' with my radeon 9550 I use the last release and work fine...
     
  16. caleb

    Joined:
    Sep 15, 2004
    Messages:
    1,556 (0.39/day)
    Thanks Received:
    207
    Location:
    Poland,Slask
    feck this im gonna hard mod :)
     
  17. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,606 (3.79/day)
    Thanks Received:
    13,222
    radeon 9550 can not be softmodded to have more pipelines

    you say that in 3dmark03 you have 8 pipes and in 3dmark01 4 pipes? this is hard to imagine. what does atitool say about number of pipelines active?
     
  18. mc00 New Member

    Joined:
    Mar 5, 2005
    Messages:
    6 (0.00/day)
    Thanks Received:
    0
    actually meant to say was 5.6 I install the drivers and then reboot when you come back into windows the he SmartGart service did not initialize my video card...when I use 5.5 work fine...

    I use the program to remove all the driver from windows and then I redownloaded the driver again and still... so I went back to 5.5 and everything fine.. :(
     
  19. Unregistered Guest

    i tried all methods - softmod package, softmod display driver only, patched ati2mtag.sys - but this version does not work with my 9500:(
     
  20. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,606 (3.79/day)
    Thanks Received:
    13,222
    i re-softmodded and re-uploaded the files. please download again and see if this version works better
     
  21. Unregistered Guest

    yeah, its working finally...i didnt 3dmark test yet but everest says it has 8pipelines...thx!:)
     
  22. Sedated Guest

    isn't this odd...?

    copied and pasted from the softmod website:
    Catalyst 5.6 v6.14.10.6542
    Catalyst 5.5 v6.14.10.6546

    Why does the older package have a newer driver version? When i tried to upgrade to the newest Catalyst w/ newest softmodded ati2mtag.sys, it complained that the current driver was newer than the one being installed.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page