1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ATI Catalyst 7.2

Discussion in 'News' started by Jimmy 2004, Feb 21, 2007.

  1. Jimmy 2004

    Jimmy 2004 New Member

    Joined:
    Jan 15, 2005
    Messages:
    5,491 (1.56/day)
    Thanks Received:
    267
    Location:
    England
    AMD/ATI has released its latest version of the Catalyst drivers, which are used by the Radeon 9500 series and higher. There are 32-bit and 64-bit releases for both Windows XP and Windows Vista, and it is recommended that you upgrade to the latest version to solve any potential problems you may experience. You can download the drivers here. Please note that all versions of Windows require you to download a different driver.

    There has been a focus on improving the Catalyst Control Center, with the following results:
    • Significant performance gains; Catalyst™ Control Center start-up time has been substantially reduced, and overall responsiveness has improved.
    • Reduced system resource usage
    • New 3D preview which significantly improves the ability for users to understand the benefits of enabling the many Catalyst™ features of their ATI Radeon™ graphics accelerator
    • Increased stability
    • Native 32 and 64-bit support
    For other performance enhancements and resolved issues you can view the release notes on ATI/AMD's site - there are lists for Vista and XP.

    Source: ATI
    Last edited: Feb 21, 2007
  2. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,119 (5.47/day)
    Thanks Received:
    1,454
    Location:
    Oklahoma T-Town
    New Features
    Catalyst™ 7.2 introduces a brand new version of the Catalyst™ Control Center for Windows XP. The new Catalyst™ Control Center delivers a number of significant enhancements:

    Significant performance gains; Catalyst™ Control Center start-up time has been substantially reduced, and overall responsiveness has improved.
    Reduced system resource usage
    New 3D preview which significantly improves the ability for users to understand the benefits of enabling the many Catalyst™ features of their ATI Radeon™ graphics accelerator
    Increased stability
    Native 32 and 64-bit support
    Performance Improvements
    Open GL performance improves for all ATI Radeon™ X1000 series products. Gains of up to 25% in Doom 3, 48% in Quake 4 and 21% in Prey can be seen on a variety of ATI Radeon™ X1000 cards. These performance gains are noticed under the Windows Vista operating system.

    Resolved Issues for the Windows Vista Operating System
    This section provides information on resolved issues in this release of the ATI Catalyst™ Software Suite for Windows Vista. These include:

    Doom 3: Setting AA to 4x and AT to 8x along with the display resolution to 2560x1600 no longer results in display corruption being noticed. Further details can be found in topic number 737-25520
    Corruption is no longer noticed during fast motion of DVD playback when using MCE/WMP. Further details can be found in topic number 737-23550
    Catalyst™ Control Center->Display Manager: Connecting only a CRT display device to a system running Windows Vista no longer results in TV display modes being available. Further details can be found in topic number 737-24467
    The Microsoft Vista operating system no longer fails to resume from an S3 state on systems containing an ATI Xpress 200 series product. Further details can be found in topic number 737-25506
    A flickering display is no longer noticed when playing a DVD using the Windows Media Player in full screen and resuming from a standby state after disconnecting a CRT display device. This issue was known to occur when using a system containing an ATI Xpress 1100/1150 series product. Further details can be found in topic number 737-25507
    Catalyst™ Control Center: The Help Launching Dialog is now localized for all supported languages. Further details can be found in topic number 737-25508
    Hot plugging or un-plugging a third display device when CrossFire™ is enabled no longer results in the primary display device being swapped and identified as the display device connecting to the primary port on the master card. Further details can be found in topic number 737-25509
    Connecting a TV to a system containing an ATI Xpress 200 series and setting it to PAL no longer results in the user not being able to control the display resolution on the LCD display when using the Catalyst™ Control Center. Further details can be found in topic number 737-25511
    The Windows Vista software driver for ATI Radeon™ products no longer fails to install if copied to a directory with a long name or to a directory with a long file path location. Further details can be found in topic number 737-25514
    Display corruption is no longer noticed when watching TV under the Windows Vista operating system when using an ATI Radeon™ X1600 series product. Further details can be found in topic number 737-25515
    The Catalyst™ Control Center no longer fails to launch under the Simplified Chinese version of Windows Vista. Further details can be found in topic number 737-25516
    Connecting two display devices with one display device using the HDMI connector (secondary) no longer results in faded colors being noticed on the HDMI display device when swapping (primary and secondary) between the two display devices. Further details can be found in topic number 737-25793
    The display mode of 1440X900@75Hz is now available within the Catalyst™ Control Center when using a system containing an ATI Radeon™ X1600/1650 series of product. Further details can be found in topic number 737-25794
    Disconnecting the primary display device when the Windows Vista operating system is in a standby state may result in the log-in screen failing to appear when resuming. Further details can be found in topic number 737-24470
    Hot-unplugging a secondary CRT display device while the Vista screen saver is active no longer results in corruption being noticed on the LCD display when ending the screen saver activity. Further details can be found in topic number 737-25795
    The PowerPlay option is no longer available on systems that do not support the option under the Japanese version of the Windows Vista operating system. Further details can be found in topic number 737-25796
    Changing the PowerPlay setting to either Power Saving or High Performance under Windows Vista, followed by rebooting the system no longer results in the PowerPlay setting displaying Battery Life mode regardless of the system being on AC power. Further details can be found in topic number 737-25797
    Resolved Issues for the Windows XP Operating System
    This section provides information on resolved issues in this release of the ATI Catalyst™ Software Suite for Windows XP. These include:

    Battlefield 2: Attempting to launch the game under Windows XP with the in-game display setting at 1920x1440 or 2048x1536 and AA set to 6x no longer results in the game failing to launch. Further details can be found in topic number 737-22817
    Desperados 2: The game no longer fails to play and display an error in atioglxx.dll when AA is enabled. Further details can be found in topic number 737-25109
    Splinter Cell Double Agent: Corruption is no longer noticed when playing the game with AA enabled. Further details can be found in topic number 737-25104
    Catalyst™ Control Center->Basic View: Connecting a secondary display device and attempting to enable it, no longer results in the inability to enable the device when using Basic view. Further details can be found in topic number 737-23447
    Connecting a CRT as the primary display device and CV as the secondary display device no longer results in the desktop area and refresh rate being reported incorrectly when applying the 1080i30 Optimized mode within the Catalyst™ Control Center. Further details can be found in topic number 737-25174
    Enabling CrossFire™ no longer results in display corruption being noticed when playing certain 3D games such as Tiger Woods PGA Tour 2006 and Madden Football. Further details can be found in topic number 737-23006
    Catalyst™ Control Center->Basic View: Connecting a secondary display device and attempting to enable it, no longer results in the inability to enable the device when using Basic view. Further details can be found in topic number 737-24347
    Catalyst™ Control Center: Connecting an HDTV or DFP display device no longer results in some of the HDTV formats being listed twice in the Catalyst™ Control Center->Digital Panel Properties->HDTV Support. Further details can be found in topic number 737-24349
    A blank display no longer occurs when switching the display mode from 1920x1200 60Hz to 1600x1200 60Hz. Further details can be found in topic number 737-25811
    The display mode of 1080p is no longer added to mode list and customized list on HDTV where the maximum display mode is 1080i. Further details can be found in topic number 737-25812
  3. Jimmy 2004

    Jimmy 2004 New Member

    Joined:
    Jan 15, 2005
    Messages:
    5,491 (1.56/day)
    Thanks Received:
    267
    Location:
    England
    Or you can read DaMulta's post for the fixed issues... as you can see it is quite long, and because XP and Vista's fixes have been different I decided not to post them!
  4. Easy Rhino

    Easy Rhino Linux Advocate

    Joined:
    Nov 13, 2006
    Messages:
    13,411 (4.71/day)
    Thanks Received:
    3,233
    funny the link on their download page is broke :mad:
  5. mikek75

    mikek75 New Member

    Joined:
    Aug 28, 2006
    Messages:
    1,371 (0.47/day)
    Thanks Received:
    118
    Location:
    Chippenham, Wilts, United Kingdom
    Overdrive still doesn't work on the X1950pro.
  6. Jimmy 2004

    Jimmy 2004 New Member

    Joined:
    Jan 15, 2005
    Messages:
    5,491 (1.56/day)
    Thanks Received:
    267
    Location:
    England
    If you're using XP 32-bit you can download them from techPowerUp! They're near the top of the home page.
  7. C.Ash

    C.Ash New Member

    Joined:
    Feb 1, 2007
    Messages:
    204 (0.07/day)
    Thanks Received:
    0
    Location:
    Columbia, Missouri
    48% increase in Quake 4??????
  8. Ketxxx

    Ketxxx Heedless Psychic

    Joined:
    Mar 4, 2006
    Messages:
    11,510 (3.72/day)
    Thanks Received:
    570
    Location:
    Kingdom of gods
    Use drivercleaner and reinstall, overdrive works on my 1950Pro even with cats 6.11 and the CCC from cats 6.2.
  9. Jimmy 2004

    Jimmy 2004 New Member

    Joined:
    Jan 15, 2005
    Messages:
    5,491 (1.56/day)
    Thanks Received:
    267
    Location:
    England
    CCC only uses about 10MB now, give or take. Much better than it used to be, but I still don't see any reason for me to be running it...
  10. Easy Rhino

    Easy Rhino Linux Advocate

    Joined:
    Nov 13, 2006
    Messages:
    13,411 (4.71/day)
    Thanks Received:
    3,233
    the x64 link is still broken. btw, anyone using vista know if CCC will conflict with atitool ?
  11. technicks

    technicks

    Joined:
    Apr 23, 2006
    Messages:
    3,560 (1.17/day)
    Thanks Received:
    257
    Location:
    Enschede, The Netherlands
    The drivers from last year work for me to, but since 7.1 i get a flickering screen when using it.:mad:

    Imo i think it's time for Ati Tool 0.27 ( Vista ready:D ). We X1950 pro users need it.;) :laugh:
  12. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,119 (5.47/day)
    Thanks Received:
    1,454
    Location:
    Oklahoma T-Town
    Battlefield 2: Attempting to launch the game under Windows XP with the in-game display setting at 1920x1440 or 2048x1536 and AA set to 6x no longer results in the game failing to launch. Further details can be found in topic number 737-22817


    This took FOREVER to fix
  13. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,119 (5.47/day)
    Thanks Received:
    1,454
    Location:
    Oklahoma T-Town
    I bet not all brands include overdrive.
  14. mikek75

    mikek75 New Member

    Joined:
    Aug 28, 2006
    Messages:
    1,371 (0.47/day)
    Thanks Received:
    118
    Location:
    Chippenham, Wilts, United Kingdom
    My Sapphire does, it worked until 7.1, which caused flicker. 7.2 doesn't enen show the clock speeds.:banghead:
  15. Alec§taar New Member

    Joined:
    May 15, 2006
    Messages:
    4,677 (1.55/day)
    Thanks Received:
    94
    Location:
    Someone who's going to find NewTekie1 and teach hi
    "WoW!!!"²... that IS a huge boost!

    :)

    * Congrats to the ATI camp on THAT account... by ALL means, because it is one of the FEW games I do play!

    (And, typically, ATI is Nvidia's 'inferior' on OpenGL gaming, & vice-a-versa on DirectX gaming - although, BOTH are very fast on either display API imo @ least, nowadays!)

    APK

    P.S.=> Personally, though I truly AM more of an "NVidia fanboy" (I have owned & used both vidcard families though), this competition w/ ATI gets everyone bennies... competition is good, usually! apk
  16. wazzledoozle

    wazzledoozle New Member

    Joined:
    Aug 30, 2004
    Messages:
    5,414 (1.48/day)
    Thanks Received:
    161
    Location:
    Seattle
    I got a whole 2fps boost in Counter Strike Source. :ohwell:

    I guess its progress...
  17. Easy Rhino

    Easy Rhino Linux Advocate

    Joined:
    Nov 13, 2006
    Messages:
    13,411 (4.71/day)
    Thanks Received:
    3,233
    ahh, there we go. drivers work great without CCC installed. and atitool 26 runs without a hitch on vista ultimate x64 ! yay!
  18. Sovereign

    Sovereign New Member

    Joined:
    Jan 26, 2007
    Messages:
    797 (0.29/day)
    Thanks Received:
    65
    Location:
    Midwest USA
    Has anyone else had a slight upgrading issue with the Catalyst Upgrade Manager program within Windows Vista? I launched the program today in order to update to Catalyst 7.2 and the program only detected that the Catalyst Control Panel software needed updating.

    I then decided to manualy download the latest 7.2 package myself and unpack it into C:/ATI/SUPPORT/ and do a manual driver upgrade from within Windows Device Manager. Sure enough, WDM found a newer version of the drivers in the latest download package and proceeded to update them. The ATI Display driver went from a release date of 1/18/08 to 2/02/07 as well as a newer driver revision number.

    My question is, why didn't ATI's Catalyst Upgrade Manager detect and/or do something about this? :wtf: :twitch:
  19. Exceededgoku

    Joined:
    Mar 26, 2006
    Messages:
    410 (0.13/day)
    Thanks Received:
    24
    Mine found it :S....
  20. Sovereign

    Sovereign New Member

    Joined:
    Jan 26, 2007
    Messages:
    797 (0.29/day)
    Thanks Received:
    65
    Location:
    Midwest USA
    Damnit, it must hate me or something ...

    I tried to run the update program 3 seperate times, all without any luck. :wtf:
  21. WarEagleAU

    WarEagleAU Bird of Prey

    Joined:
    Jul 9, 2006
    Messages:
    10,796 (3.63/day)
    Thanks Received:
    545
    Location:
    Gurley, AL
    Alright, I have a connect3D radeon X800 GTO2 card thats been modded to an X850 PE. What I need to know is, which one do I download for? The X800 Series or the X850 series? Quick responses are appreciated.
  22. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,119 (5.47/day)
    Thanks Received:
    1,454
    Location:
    Oklahoma T-Town
    Its the same driver no matter what card you pick 7.2 is 7.2
  23. WarEagleAU

    WarEagleAU Bird of Prey

    Joined:
    Jul 9, 2006
    Messages:
    10,796 (3.63/day)
    Thanks Received:
    545
    Location:
    Gurley, AL
    Oh, alright, because it asked for which card I had, so I selected the X850 series as windows and bioses and stuff read it that way.
  24. WarEagleAU

    WarEagleAU Bird of Prey

    Joined:
    Jul 9, 2006
    Messages:
    10,796 (3.63/day)
    Thanks Received:
    545
    Location:
    Gurley, AL
    Driver Cleaner pro is the bomb. Make sure you restart after you clean, then do a fresh install of the drivers.
  25. tkpenalty New Member

    Joined:
    Sep 26, 2006
    Messages:
    6,958 (2.41/day)
    Thanks Received:
    345
    Location:
    Australia, Sydney
    Cool... no more artifacting in Half Life 2 Episode one (damn XG warcat.. I hate them now!!!)

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page