1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ATI Catalyst 9.5 is Now Official, Release Notes too

Discussion in 'News' started by malware, May 19, 2009.

  1. DRDNA

    DRDNA

    Joined:
    Feb 19, 2006
    Messages:
    4,768 (1.55/day)
    Thanks Received:
    561
    Location:
    New York
    Oh well I am finished with ATI graphic cards....over $800 of their crapola cards in my rig and they still DO not do what they are advertised to do.The Green team has been giving a regular spanking to ATI anyway so look out Nvidia looks like you have another customer who is switching from the red team...Shit the only way ATI can even touch Nvidia is by using dual GPU cards....I would rather spend the extra $30 for Green teams best.Sorry for the rant but I have been patient far too long.:shadedshu:shadedshu ATI :shadedshu:shadedshu
    :D:D Nvidia :D:D
  2. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,034 (3.36/day)
    Thanks Received:
    1,888
    Shit and imo The green team needs Physics X to run better numbers..... but thanks.... I think ill settle for ATI till Havoc Accelerator comes out:wtf:
  3. Kreij

    Kreij Senior Monkey Moderator Staff Member

    Joined:
    Feb 6, 2007
    Messages:
    13,881 (5.08/day)
    Thanks Received:
    5,615
    Location:
    Cheeseland (Wisconsin, USA)
    I downloaded and installed 9.5s without any problem. Didn't even bother to uninstall 9.4, just ran the installer and let it do it's thing. The 2D/3D problem is fixed so my card is running cooler in 2D mode.
    I've not tried gaming yet, but for what I play I don't anticipate any real issues in performance.
  4. DRDNA

    DRDNA

    Joined:
    Feb 19, 2006
    Messages:
    4,768 (1.55/day)
    Thanks Received:
    561
    Location:
    New York
    Yes this set up games very nice ....doesnt GPU bench as well as I would like! I also wanted the converter badly It was a nice feature when it worked...My older x1000 series cards did a very nice job of it . Looking forward to trying out some 295's in Laue of my current disappointment.
  5. Kreij

    Kreij Senior Monkey Moderator Staff Member

    Joined:
    Feb 6, 2007
    Messages:
    13,881 (5.08/day)
    Thanks Received:
    5,615
    Location:
    Cheeseland (Wisconsin, USA)
    Hey DRDNA,

    With 2 X2s you should be running happily. What are they not doin that has been advertised.
    I'm curious as I've been kicking around the idea of a second X2.
    My rig works fine with one.
  6. Steevo

    Steevo

    Joined:
    Nov 4, 2005
    Messages:
    8,119 (2.54/day)
    Thanks Received:
    1,126
    So no go on the Avivo for X64 vista?
    10 Million points folded for TPU
  7. fullinfusion

    fullinfusion 1.21 Gigawatts

    Joined:
    Jan 11, 2008
    Messages:
    8,034 (3.36/day)
    Thanks Received:
    1,888
    Took a hit in the mark06 department (big tyme) and half the shit in the 9.5 dont work.... Back to ol trusty 9.4 for me :nutkick:
  8. DRDNA

    DRDNA

    Joined:
    Feb 19, 2006
    Messages:
    4,768 (1.55/day)
    Thanks Received:
    561
    Location:
    New York
    Avivo doesn't work in Vista 64! Advertised that it works in Windows.


    I want it back soo bad I might just set a dual boot to be able to use it.
  9. a_ump

    a_ump

    Joined:
    Nov 21, 2007
    Messages:
    3,583 (1.47/day)
    Thanks Received:
    361
    Location:
    Smithfield, WV
    eh according to Tweaktown, 9.4 drivers are better. the linky is a review 9.5 vs 9.4
  10. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,117 (5.52/day)
    Thanks Received:
    1,454
    Location:
    Oklahoma T-Town
    Anyone click on the blog link?

    HEHE
  11. dieselcat18

    dieselcat18

    Joined:
    Aug 7, 2008
    Messages:
    443 (0.20/day)
    Thanks Received:
    55
    Location:
    Deerfield Beach, FL
    So, since this thread seems to be back on topic, should I un-install my current drivers (v8.12) and install v9.4 or v9.5 before I install my new 4890...or just switch out the cards first, then install new drivers ?....which driver version is best to go with, or is that something I'll just have to test to see which set of drivers runs better with this particular card ?

    *+
  12. DRDNA

    DRDNA

    Joined:
    Feb 19, 2006
    Messages:
    4,768 (1.55/day)
    Thanks Received:
    561
    Location:
    New York
    I would stick with 9.4's unless you have an issue with them.
    dieselcat18 says thanks.
  13. Steevo

    Steevo

    Joined:
    Nov 4, 2005
    Messages:
    8,119 (2.54/day)
    Thanks Received:
    1,126
    It shows as working with GPU acceleration in the release notes, AVIVO that is, however I install it and it doesn't show up in basic view of CCC, then I went to the actual AVIVO installer and ran that, and it get a error about two ATI *'dll's not registering, so I tried regestering them manually with regsrv32 and it errors out.





    Good job ATI. At this rate I will be going green by next month.
    DRDNA says thanks.
    10 Million points folded for TPU
  14. DRDNA

    DRDNA

    Joined:
    Feb 19, 2006
    Messages:
    4,768 (1.55/day)
    Thanks Received:
    561
    Location:
    New York
    Same ole shit here too Steevo ....I don't think they even linked the AVIVO for Vista 64 correctly! I think they are linking the VISTA 32 bit ones as the file name for the Vista 64 AVIVO reads>>> 9-5_vista32_xcode...Now I have been with ati for a long time and when an app is for 64 bit they put 64 in the file name and when its for 32 bit they put 32 in the file name now maybe this AVIVO package for Vista is suppose to be the same package for either 32 or 64 bit but I highly doubt it!ERRRRR dirty no good rat bastards I have given ATI in GPU's alone over $4000+ of my hard earned green backs and they are feeding me bull crap!

    ATI. At this rate I will be going green sooner than next month.
  15. DRDNA

    DRDNA

    Joined:
    Feb 19, 2006
    Messages:
    4,768 (1.55/day)
    Thanks Received:
    561
    Location:
    New York
    NOW THIS IS ATHE ATI I REMEMBER!!!!!!

    Okay here is the scoop..
    ATI originally had linked the Avivo Video Converter for Vista 64 file named >> 9-5_vista32_xcodeWHICH WAS WRONG!
    Now ATI has linked Avivo Video Converter for Vista 64 file named >> 9-5_vista32-64_xcode
    WHICH IS CORRECT AND WORKING!
    AND WORKING!
    AND WORKING!
    AND WORKING!

    ATI IS MY BEST FREIND AGAIN!!!!
    Please ATI forgive me for all the bad things I said and thought!

    So I have tested and it works BETTER than ever ! WOW H.264 and FAST!Happy Days are here again!!!:rockout::rockout::rockout::respect:ATI :respect:
  16. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,011 (11.72/day)
    Thanks Received:
    9,403
    i just installed the x64 package under win 7, and cant figure out how to run the damn thing?


    edit: ah its the usual thing. the installer fails under 7, and you have to go into C:/ati and find an installer .exe :)
  17. RuskiSnajper

    RuskiSnajper

    Joined:
    Feb 18, 2009
    Messages:
    1,607 (0.81/day)
    Thanks Received:
    231
    Location:
    slovenia , europe
    Where's the Quicksilver skin?
  18. Meizuman

    Meizuman

    Joined:
    Nov 8, 2008
    Messages:
    625 (0.30/day)
    Thanks Received:
    88
    Location:
    Finland (northern)
    9.6 is already out, but didn't find it on news section...

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page