1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ATI CCC problem on win7 x64

Discussion in 'AMD / ATI' started by crush3r, Dec 19, 2009.

  1. crush3r

    crush3r New Member

    Joined:
    Apr 29, 2008
    Messages:
    346 (0.15/day)
    Thanks Received:
    61
    Location:
    Manchester, UK
    I recently bought 2 second hand 4850s off here to crossfire on my UD3P, however i can't for the life of me get the catalyst control centre to install, which ive been told is required to enable crossfire (this is my first set of ATI cards).

    [​IMG]

    The display driver on its own installs (both 9.11 & 9.12) but the combined install of the display driver and catalyst centre hangs without becoming non-responsive. I'm puzzled :confused: Any help would be greatly appreciated!
  2. HalfAHertz

    HalfAHertz

    Joined:
    May 4, 2009
    Messages:
    1,886 (0.99/day)
    Thanks Received:
    378
    Location:
    Singapore
    reinstall your 2005 redistributable thingie
    crush3r and Kei say thanks.
  3. crush3r

    crush3r New Member

    Joined:
    Apr 29, 2008
    Messages:
    346 (0.15/day)
    Thanks Received:
    61
    Location:
    Manchester, UK
    Thanks for your response, i have many 2005 redistributables on the list, i reinstalled the x64 one and the installation got furthur, up to "enumerating..." and on the first attempt it hung and second it just disappeared. Which redistribs should i be looking at?

    [​IMG]

    EDIT: No Luck when i uninstalled ALL 2005 redistributables then reinstalled :/

    This is where it's getting stuck:

    [​IMG]
    Last edited: Dec 19, 2009
  4. HalfAHertz

    HalfAHertz

    Joined:
    May 4, 2009
    Messages:
    1,886 (0.99/day)
    Thanks Received:
    378
    Location:
    Singapore
    You would usually need to have both x32 and x64 redistributables when running a x64 OS. Ok just to make things clear, you removed all of them and let the driver package install its own? Plus it would be a good idea to download a fresh copy of the drivers just in case.
    crush3r says thanks.
  5. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,511 (13.50/day)
    Thanks Received:
    13,918
    crush3r says thanks.
  6. Flak New Member

    Joined:
    Jul 7, 2008
    Messages:
    402 (0.18/day)
    Thanks Received:
    70
    Location:
    US
    Not sure which version of the drivers you are installing. But I could not get the 9.11 cats to install on my 4850 CF setup in Win 7 64bit. I haven't yet tried the 9.12. However, in my case CCC would install but the drivers wouldn't. If you view the log what is it erroring on? I originally thought it was CCC but after viewing the log in my case it installed everything but the drivers.
    crush3r says thanks.
  7. 10TaTioN

    10TaTioN New Member

    Joined:
    Sep 15, 2009
    Messages:
    257 (0.14/day)
    Thanks Received:
    108
    Location:
    Portugal
    1: My Computer
    2: Uninstall or Change a Program.
    3: Right Click - ATi Catalyst Install Manager - Select Change
    3.1: Express Install ALL ATi Software
    4: Reboot
    5: Start Catalyst Installation - Select Express Install - NOT Custom
    6: After it finishes installing, even if you see the Yellow Warning, check the Right Click on the desktop, if there's the Catalyst Option then the CCC was installed correctly...
    crush3r says thanks.
  8. ucanmandaa New Member

    Joined:
    Nov 30, 2008
    Messages:
    168 (0.08/day)
    Thanks Received:
    12
    Location:
    North Cyprus
    i have the exact same problem on Vista x64. Even tried that guide erocker posted. Any driver sets post 9.9 give me this error. I have crossfired 4850s like you but on a maximus formula. Seems like a format is the only way...
    crush3r says thanks.
  9. crush3r

    crush3r New Member

    Joined:
    Apr 29, 2008
    Messages:
    346 (0.15/day)
    Thanks Received:
    61
    Location:
    Manchester, UK
    Thanks for your help everyone, erocker i've followed your guide but what stops me from completing it after restart is windows installing drivers automatically :banghead:

    [​IMG]

    Anybody know the process name of that auto installer so i can kill it before it has a chance to complete?
    I'm going to try cat 9.9's or 9.8's to see if i have any luck.

    Halfahertz: Yep, uninstalled all and then ran the installer, once it attempted to install and gave the screen in post #3 i found that they hadnt been reinstalled, and i still had no driver or CCC.

    10tation: I'm unable to do this, there is no Ati *anything* in there, maybe because what's running at the moment is generic windows display drivers?

    Flak: Recently it's no longer given me the error message, it just disappears. I'm stuck :twitch:

    Ucan: Thanks, i'll try earlier driver versions, if i can ever get this autoinstaller to stop :mad:
  10. HalfAHertz

    HalfAHertz

    Joined:
    May 4, 2009
    Messages:
    1,886 (0.99/day)
    Thanks Received:
    378
    Location:
    Singapore
    Sorry for the hassle then. Hmm aren't these drivers downloaded from the interwebz? Maybe try disconnecting or installing the drivers under safe mode?
    crush3r says thanks.
  11. crush3r

    crush3r New Member

    Joined:
    Apr 29, 2008
    Messages:
    346 (0.15/day)
    Thanks Received:
    61
    Location:
    Manchester, UK
    No worries :toast: That's what i thought, so unplugged ethernet and to my frustration it happily chugged away with the usual autoinstall :/ maybe if i can find where this microsoft driver is on my disc...
    And no luck with 9.9's :/ will try safe mode
  12. 10TaTioN

    10TaTioN New Member

    Joined:
    Sep 15, 2009
    Messages:
    257 (0.14/day)
    Thanks Received:
    108
    Location:
    Portugal
    Every time you install the drivers and/or CCC the Install Manager appears on the Uninstall section of Windows.

    http://game.amd.com/us-en/drivers_catalyst.aspx?driver=VideoCard/win7-64-components

    Try downloading the CCC only and install (Express install), if it shows any error let us know.

    I suppose your DirectX is updated (not by games by by yourself), if not: http://www.microsoft.com/downloads/...FamilyID=04ac064b-00d1-474e-b7b1-442d8712d553

    Also try the Catalyst Uninstaller if none of the above worked: https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/cat-uninstaller.exe

    PS: Try installing the Driver/CCC package to another folder.
    crush3r says thanks.
  13. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    14,639 (3.93/day)
    Thanks Received:
    11,374
    do you have an older version of daemon tools installed? ccc installer enumeration has some issues with that
    crush3r says thanks.
  14. crush3r

    crush3r New Member

    Joined:
    Apr 29, 2008
    Messages:
    346 (0.15/day)
    Thanks Received:
    61
    Location:
    Manchester, UK
    Thanks 10 I haven't had time to do all of that yet but i still got the error :/ will try the catuninstaller and diff. directory tomorrow!

    W1zz: Yes i had daemon tools installed, i uninstalled it and tried the driver install again to no avail.

    Would a fresh install of win7 solve this?

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page