1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ATi OpenCL-Beta 2.0 (Cat 9.11)

Discussion in 'AMD / ATI' started by erocker, Oct 19, 2009.

  1. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,535 (13.48/day)
    Thanks Received:
    13,934
    I found these browsing around, they work and work well. Do before and afters of 3DMark and find out. Haven't had any problems with games. You will need to uninstall all instances of Microsoft Visual C++ via the Control Panel after uninstalling your old drivers and installing these. Or you can just follow this guide for a fresh reinstall: http://forums.techpowerup.com/showthread.php?t=52502

    You will need to register with AMD to get these (anyone can do it). You will also need a HD 48XX or 58XX series video card.

    Here is the link to the download page: http://developer.amd.com/gpu/ATIStreamSDKBetaProgram/Pages/default.aspx#five

    The download is listed as: ati-opencl-beta-driver-v2.0-beta4-"your O/S here".zip (XXXMB)

    You can also download the Stream SDK 2.0 Betas through the link. First install the developer kit, then the sample kit.

    Have fun! :toast:

    *This was already (kind of) posted here already in News about the revealing of Hemlock here.
    Last edited: Oct 19, 2009
    newfellow, AsRock, musek and 2 others say thanks.
  2. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,011 (11.72/day)
    Thanks Received:
    9,404
    9.11 beta?

    did i miss 9.10?
  3. TheMailMan78

    TheMailMan78 Big Member

    Joined:
    Jun 3, 2007
    Messages:
    20,901 (7.99/day)
    Thanks Received:
    7,487
    9.10 was the Ninja edition. You missed it.
  4. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,535 (13.48/day)
    Thanks Received:
    13,934
    [​IMG]
    [​IMG]

    Now we just need some OpenCL stuff for F@H!!
  5. 1Kurgan1

    1Kurgan1 The Knife in your Back

    Joined:
    Dec 8, 2008
    Messages:
    10,321 (5.01/day)
    Thanks Received:
    2,371
    Location:
    Duluth, Minnesota
    Wow almost a 400 point gain on GPU score and even a nice CPU gain, I'm sold!
  6. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,011 (11.72/day)
    Thanks Received:
    9,404
    E mentioned in another thread, that these may fix the 59Hz issues for some people.


    if so, it may also fix the 30Hz in DX10 over HDMI issues as well.



    edit: THESE DRIVERS DO INDEED FIX THE 59HZ ISSUES IN WINDOWS 7!!!!!!!!!!!!!!111one1one1111!!!!!!
    Last edited: Oct 20, 2009
    Kei and AsRock say thanks.
  7. AsRock

    AsRock TPU addict

    Joined:
    Jun 23, 2007
    Messages:
    10,756 (4.14/day)
    Thanks Received:
    1,642
    Location:
    US
    Cool so hopefully they fix it for vista too :).
  8. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,011 (11.72/day)
    Thanks Received:
    9,404
    [​IMG]



    1920x1080, DX10, all settings max, 8xAA
    (test done fullscreen, had to window to screenshot)
    :)

    the FPS dip in the third part was actually the game alt tabbing, my antivirus updated
  9. AsRock

    AsRock TPU addict

    Joined:
    Jun 23, 2007
    Messages:
    10,756 (4.14/day)
    Thanks Received:
    1,642
    Location:
    US
    umm none for Vista x64 with SP2 ?..will still give them a try tomorrow though..
  10. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,011 (11.72/day)
    Thanks Received:
    9,404
    probably means SP1 and up, meaning that you dont need SP2 to install the drivers.


    I recall this kind of thing with XP after SP2 came out, you needed some drivers to be SP2 compatible, older ones wouldnt work.
  11. AsRock

    AsRock TPU addict

    Joined:
    Jun 23, 2007
    Messages:
    10,756 (4.14/day)
    Thanks Received:
    1,642
    Location:
    US
    well they work but scaling issue is still there for me. Ever since trying 9.9 it not been right since.

    And installing a older version even after going in to safe mode using driver cleaner an driver sweeper will not solve the issue.
  12. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,011 (11.72/day)
    Thanks Received:
    9,404
    scaling = still broken

    refresh rate issue = PARTIAL fix. i've noticed the 59-60Hz issue is fixed in some games, however the DX10 issues still exist in some games.

    update!

    turns out i'm having CROSSFIRE issues, not refresh rate issues with flickering.

    disable crossfire, and the flickering goes away in CoH, for example. might be time to stick that second crossfire bridge in there...

    google knows about this, and its not a new issue either

    thanks to that old TPU thread, i learned that turning Vsync on fixes the issue.

    it also seems to be related to using the crossfire bridge in the "wrong" location, or using two. They suggest using the one closest to the "front" of the card (closest from the DVI ports) (mines in that position already and i get the flickering, i'll eventually test the other location)
    edit: i just tested with one bridge in either location and with two bridges, to no effect. this is definitely driver related.
    Last edited: Oct 20, 2009
  13. Hayder_Master

    Hayder_Master

    Joined:
    Apr 21, 2008
    Messages:
    5,173 (2.26/day)
    Thanks Received:
    638
    Location:
    IRAQ-Baghdad
    thanx man im go download it
  14. SonDa5

    SonDa5

    Joined:
    Aug 3, 2008
    Messages:
    1,645 (0.75/day)
    Thanks Received:
    344
    The beta 9.11 drivers feel like they are speeding up my HD4770s or using more resources and I have had to down clock them a little to stay stable but they seem to perform better.


    Almost beat my best 3dMark06 score first time I ran these drivers.

    [​IMG]




    These drivers did put a very nice boost for my Vantage score. New PR with these drivers on first run with lower clock then I have done in the past.


    [​IMG]

    http://service.futuremark.com/compare?3dmv=1514443
  15. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,011 (11.72/day)
    Thanks Received:
    9,404
    anyone with these drivers having problems with TF2 and L4D? neither game will start for me (they quit when they reach the in game menu)
  16. DRDNA

    DRDNA

    Joined:
    Feb 19, 2006
    Messages:
    4,768 (1.55/day)
    Thanks Received:
    561
    Location:
    New York
    Yes I have been palying with these for several days now ...with the PCIe bench test they have.
  17. 1Kurgan1

    1Kurgan1 The Knife in your Back

    Joined:
    Dec 8, 2008
    Messages:
    10,321 (5.01/day)
    Thanks Received:
    2,371
    Location:
    Duluth, Minnesota
    I asked before and no one seemed to have an answer, what exactly does that difference of 1 cause thats so horrible?
  18. TheMailMan78

    TheMailMan78 Big Member

    Joined:
    Jun 3, 2007
    Messages:
    20,901 (7.99/day)
    Thanks Received:
    7,487
    WTF! I installed these drivers and my wife still wont sleep with me! You're a liar Erocker!
  19. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,011 (11.72/day)
    Thanks Received:
    9,404
    many screens dont like not running at their native refresh rate.


    settings such as scaling and over/underscan dont work when not at 60Hz either, in ATI drivers.
  20. DRDNA

    DRDNA

    Joined:
    Feb 19, 2006
    Messages:
    4,768 (1.55/day)
    Thanks Received:
    561
    Location:
    New York
    WOW these are by far the best drivers I have used since I cant remember for Blue-Ray and video in general and they are pretty fast too...they don't bench bad either actually they bench very well.
  21. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,535 (13.48/day)
    Thanks Received:
    13,934
    They both work for me, though I'm not using CrossFire.
  22. DRDNA

    DRDNA

    Joined:
    Feb 19, 2006
    Messages:
    4,768 (1.55/day)
    Thanks Received:
    561
    Location:
    New York
    I am using CFX and they work great for me no issues at all .
  23. Flak New Member

    Joined:
    Jul 7, 2008
    Messages:
    402 (0.18/day)
    Thanks Received:
    70
    Location:
    US
    I was going to replace my 4850 512mb CF setup with a 5850 or 5870 until I tried these. Maybe I was just having problems before but the CF setup has never been so smooth in so many games and there's been a performance increase across the board as well.
  24. SonDa5

    SonDa5

    Joined:
    Aug 3, 2008
    Messages:
    1,645 (0.75/day)
    Thanks Received:
    344


    No problems at all. These are the best drivers I have ever used. Worked great for my HD4770s in Xfire and for my HD5850. :toast:
  25. DRDNA

    DRDNA

    Joined:
    Feb 19, 2006
    Messages:
    4,768 (1.55/day)
    Thanks Received:
    561
    Location:
    New York
    getting higher GPU over clocks as well :eek: ........ But again the Video quality is just absolutely bar NONE :rockout:

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page