1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ATiTool conflicting w/ new Punkbuster Services?

Discussion in 'ATITool Bug Reports' started by Mustang Man, May 2, 2007.

  1. Mustang Man New Member

    Joined:
    Apr 19, 2006
    Messages:
    13 (0.00/day)
    Thanks Received:
    0
    Well I didnt come here to put down ATiTool or any program. I came to hopefully get some answers...

    Ever since Punkbuster started running a couple of services I have been having problems. The services are pnkbstrA & B .exe

    After endless hours skipping forum after forum, here is the best I can describe my situation... Basically my PC freezes with a constant sound loop only while playing BF2142, or a screech of death (that sounds much like a fax modem, but I have no modem installed).

    I run ATiTool version 0.26 and have been running it for a couple of months without a problem. Now, before you think it's definitely a hardware problem, it's not. I have 3 different PC's, and they all freeze only with bf2142.

    I have tried everything, I changed every piece of hardware on my PC, installed windows again, bf2142 again... etc. Still froze. So then I simply turned off these two services (via MSCONFIG) from punkbuster and guess what? the problem went away completely.

    That is until April 17th, when Evenbalance (punkbuster) made it mandatory to run these files to play in a punkbuster server. So after not freezing for days, I was forced to run these files again to be able to play (if you dont run them you get a "losing key packets" error). Anyway, I ran the services and again, I froze. The only way to get out of this state is to reboot the PC.

    2 other people I know (and who knows how many else) were having this same problem.

    So I had to do some major, back to basic thinking and figured that the main thing these PC's freezing had in common was that they had ati cards and running atitool. So just for kicks, we uninstalled atitool, this was about 1 1/2 weeks ago, we have not frozen since.

    To make sure this was not a coincidence, I reinstalled ATiTool and within 5 minutes of playing BF2142, the PC froze. First time since I had uninstalled it that it froze.

    I have been through hell and back trying to figure out what was causing my freezing problem, and I think I found that ATitool and pnkbstrA and B are not "getting along".

    Of course, I would rather have ATiTool running since my card seems to get quite hot without it, this is very frustrating. Please, experts, need some help.
  2. Mustang Man New Member

    Joined:
    Apr 19, 2006
    Messages:
    13 (0.00/day)
    Thanks Received:
    0
    Ok, just incase anyone was interested or had this same problem, Evenbalance closed my trouble ticket with this to say about ATiTool and their punkbuster services:


    05/11/2007 15:28:07 - "Glenn Courington"
    Note #6: This looks like this could definitely be the issue. As to what ATITool is doing, I'm not sure, as I don't have the code for it. But it definitely appears to be the source of your problem, so at least for now, I'd suggest not running it when playing PB-enabled games.
  3. jaxxxon New Member

    Joined:
    Jan 7, 2007
    Messages:
    174 (0.06/day)
    Thanks Received:
    11
    Location:
    Wales
    Turn off temperature monitoring (the fan speeds will still work). This sometimes fixes the problem.
  4. velvok New Member

    Joined:
    Jun 5, 2007
    Messages:
    3 (0.00/day)
    Thanks Received:
    1
    Aha! I am having the same exact problem, except that I am still running 0.25b13. Turns out lots of 2142 players are having this crash-and-looping-sound problem. Some attribute it to the Punkbuster updates, and others to the 1.25 patch update. Here is my unusual situation:

    I run XP on a MacBook Pro (natively) to play Battlefield 2142. Since the beginning, I've had to run ATITool to *underclock* my X1600 to keep these sorts of freezes and sound-loops from happening in games that use DirectX 9.0c. Battlefield 2142 worked perfectly thanks to ATITool, right up until EA changed -- whatever they changed.

    I had initially come here to see if a newer beta might be more compatible with my video card (anything after 0.25b13 causes my backlight to turn off when ATITool is started, for some reason), but seeing that you've had this very same problem only on machines running ATITool is extremely helpful. :)

    In the meantime, EA recommended setting the sound acceleration in DXDIAG to "basic" and clearing out temp and %temp%. I have serious reservations as to how effective that will be, but it's worth a try. :) I'll try running without ATITool tonight to corroborate
  5. Unwinder RivaTuner Creator

    Joined:
    Jun 7, 2007
    Messages:
    8 (0.00/day)
    Thanks Received:
    7
    Guys, it looks like ATITool is absolutely not the reason of that problem. We're invesstigating similar issue in RivaTuner support forum, as it also "conflicts" with the latest version of BF 2142 with the same symptoms:

    http://forums.guru3d.com/showthread.php?t=226934

    I'm almost 100% certain that PunkBuster is doing that by improperly accessing process memory of any twekaing tool. I've explained my point of view and understanding of the problem here:

    http://forums.guru3d.com/showpost.php?p=2294004&postcount=67

    So if it is true and if you're using any graphics hardware related tool residing in memory - you've a good chance to be crashed by the latest PunkBuster. If you've something more to add - you're welcome to that thread. I hope that this issue will be finally closed soon with help of community.
    Urlyin says thanks.
  6. pbmaster

    pbmaster New Member

    Joined:
    Aug 6, 2006
    Messages:
    2,590 (0.89/day)
    Thanks Received:
    292
    Location:
    Savannah, GA
    I have the EXACT same problem with CoD2. I too use ATi tool for temps. It just started doing it again today. So should I just not use ATi Tool while playing?
  7. velvok New Member

    Joined:
    Jun 5, 2007
    Messages:
    3 (0.00/day)
    Thanks Received:
    1
    Yes; turn off ATITool for the time being. I was able to update my ATI drivers using hints in these forums, making my Macbook Pro stable enough to run BF2142 without ATITool present. Once I removed it, my crashes completely ceased.

    And I do think that it's *all* tweaking tools being affected by Punkbuster. You can see on the forums that lots of users are having this same problem -- not just ATI users. I bet most of them have graphics card tuners, too.
    pt says thanks.
  8. Dippyskoodlez New Member

    Joined:
    Jul 1, 2005
    Messages:
    5,061 (1.54/day)
    Thanks Received:
    230
    Location:
    Ohio
    Chances are is punkbuster.

    That softwares a pile of shit. Its the cause of 99% of the problems when a game w/ it has problems.

    But good luck getting it fixed, that company's worthless when it comes to support.

    Even if it were Atitool, Punkbuster wouldn't allow w1zz to dissassemble it to figure out the root of the cause anyways.
  9. pt

    pt not a suicide-bomber

    Joined:
    Mar 11, 2006
    Messages:
    8,982 (2.95/day)
    Thanks Received:
    208
    Location:
    Portugal
    so that's the %$&#&$# reason i couldn't play bf2
    glad i found this thread :)
  10. NeilWroughton New Member

    Joined:
    Nov 29, 2008
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
    hi,

    Yes; turn off ATITool for the time being. I was able to update my ATI drivers using hints in these forums, making my Macbook Pro stable enough to run BF2142 without ATITool present. Once I removed it, my crashes completely ceased.:slap:

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page