1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Best Drivers for a 4870X2??

Discussion in 'AMD / ATI' started by Melvis, Jan 15, 2014.

  1. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia
    Hi guys,

    I have two old 4870X2's and 1 of them started to have artifacting issues a good 14months ago or so and I have finally got around to refurbishing it completely. Full stripped it down to nothing, cleaned it inside and out, replaced all thermal pads and paste, greased the fan etc. Anyway so I got it all done (took like 4hrs) and I put it into my work station PC to test it out, so far so good but im having issues with drivers. Ive tested out 13.1, 13.4 and 13.9 and they all do different things like one GPU is clocked higher then the other, or both are clocked down but wont clock up when under load.....so I was wondering what is the best driver to use for an old 4870X2 so I can properly test the card in a game. Its been a very long time since Ive used the card so....

    Thanks In advance!! :)
     
  2. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia
    Ive tried 12.10 and also 12.6 and still no good :(
     
  3. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia
    Seems to me that the drivers are not picking up that the card runs in crossfire, I get no option to turn on or off crossfire, only 1 GPU is working when playing games. Any idea people? or is my card faulty?
     
  4. Law-II

    Law-II

    Joined:
    May 9, 2011
    Messages:
    1,584 (1.26/day)
    Thanks Received:
    648
    Location:
    Mainland Britain
    Hi

    HD 4870 x2 it would not have a crossfireX enable tab, [if it is a single vga card] only dual card configurations have this]

    Do both GPU's show in device manager?

    This is a fresh install of Windows 7; if not installing fresh deep clean the drivers use DDU or Other application; also *may need to remove any ghost images from device manager:
    [go to Control Panel\All Control Panel Items\System\advanced\Enviroment Variables\System variables
    Select: New \ Set Variable name: Set devmgr_show_nonpresent_devices \Set Variable value: 1 \ Select: OK \ Select: OK \ Select: OK
    go to Control Panel\All Control Panel Items\Devise manager\View\Show hidden devices Select: Display adapters [if there are any greyed out images of the adapter precent highlight ONLY these and uninstall them]

    CAP's are installed

    Try legacy driver
    Catalyst 12.2 Whql [Edit:
    all links to this driver appear to have been blocked by AMD]
    Release Notes - here
    Use CAP 12.2 available here or later [not sure if later versions are 100% compatible]
    Select AFR friendly application to test system

    atb

    Law-II
     
    Last edited: Jan 17, 2014
  5. Jack1n

    Joined:
    Oct 8, 2012
    Messages:
    1,026 (1.38/day)
    Thanks Received:
    233
    Location:
    Central Israel
    Wrong i still have my 4870x2 laying around and it did show up as crossfire in catalyst and in GPU-Z.
    latest drivers to support the 4XXX HD is the 12.6 i believe.
     
    Law-II says thanks.
  6. Law-II

    Law-II

    Joined:
    May 9, 2011
    Messages:
    1,584 (1.26/day)
    Thanks Received:
    648
    Location:
    Mainland Britain
    Hi

     
  7. Jack1n

    Joined:
    Oct 8, 2012
    Messages:
    1,026 (1.38/day)
    Thanks Received:
    233
    Location:
    Central Israel
    It is enabled by default.
     
    Law-II says thanks.
  8. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia
    Thanks for your reply, I cant remember if the crossfire enable tab was there or not under 1 card but I can check this with my other 4870X2 that was running 100% perfectly fine last time I used it.

    Yes both GPU's show up in device manager and also in CCC but when the card is under load crossfire doesnt seem to want to work :S.

    That link doesnt send me to the 12.2 drivers but the latest ones I think?

    Its a fresh install of windows 7 but its not dirty either but ill try to use driver sweeper as when I uninstall the drivers it still says drivers are installed :S
     
  9. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia
    Ok some how i got it working. i did do a driver sweeper clean out and then let windows install the drivers by itself. At first this still didnt work, so then I installed 13.9 CCC then the drivers then the rest of the suit and ran Metro 2033. As soon as I ran the game the card started to run correctly, WEIRD!!!

    Next issue is temps, all the temps I see are good apart from one and thats the MEMIO Temp on GPU1 its hitting 91c. Can some one explain more indepth about that for me? is it ok temps? where is the MEMIO? etc. Cheers,
     
    Law-II says thanks.
  10. kn00tcn

    kn00tcn

    Joined:
    Feb 9, 2009
    Messages:
    692 (0.33/day)
    Thanks Received:
    122
    Location:
    Toronto
    i ran the core at 90 target & memio was always +5 or +10 more

    you do not get a CFx tab in CCC if it's just 1 card (2 gpus), but gpuz does mention CF enabled... you probably want to disable ULPS if it happens to be enabled

    12.6legacy is the last real driver, the couple legacy updates are the same driver with tweaks so minor it doesnt even matter

    unfortunately i'm gonna wind up posting multiple links to my site, but that's where my instructions are... there are also multiple options & considerations, so let's get to it:

    kevsamiga1974 on guru3d packaged up the best legacy driver in one or a couple of his threads

    avoid any thread or post where the 'dellon132' user claims newer legacy versions, he is an absolute liar using years old dlls that happen to be about the same filesize as the newer 5-7series drivers, shame people listen to & thank this punk, i should have pressured asder to permanently ban him

    there is also some legacy modder tool that i'm not quite sure how it works since it appeared after my 4870x2 stopped working properly, it seems to be a few tweaks & a 'driver cocktail maker' that simplifies some manual file management from your end

    personally i prefer to deal with it myself by using 12.6l, his clock fix app on startup (basically, windows boot = stuck 3d clocks on gpu2, launch+exit a dx9 app fixes that, i was putting guildwars in my startup before his app)

    then i put different driver version dx9/dx10/ogl dlls into specific game folders as needed since frostbite2 needed one set, borderlands needed another set, etc

    i dont care about DXVA, just pure framerate & artifact fixes, so in my case i only focused on the dx9/dx10/ogl parts, while kev focused on making the most stable+feature rich+DXVA working+general crossfire legacy driver (at the cost of fewer driver profiles & a bigger soup of dlls)

    CAP versions are compatible yes, you might even be able to take CAP files from drivers in 2013, but do note that certain driver tweaks in certain game profiles dont apply to legacy & might even cause problems, & if you poke at the XML files like i do (they're posted on my site), you'll notice a few betas ago that the entire name of a tweak/toggle in most of the crossfire profiles has changed, so it probably only works when a matching driver dll that has this tweak is present

    there was an entire thread about f1 2012 being ruined on certain CAP versions, so it's all about which games you play & which profiles you force in CCC if it's a game without a profile

    enjoy your frankenstein driver installation & game profiles, i had fun tweaking but i dont recommend it for others unless you know what you're getting into

    if you have any questions i guess quote or PM me, maybe even become active in kev's thread, reporting findings or asking questions there (i dont have the link on me)

    i actually want to see what happens when i switch to a 290, there are known opengl issues that happened after catalyst 10.4, which is no problem for a legacy card using the older supported dlls, but a newer card cant use tricks like that
     
    Melvis and Law-II say thanks.
  11. Law-II

    Law-II

    Joined:
    May 9, 2011
    Messages:
    1,584 (1.26/day)
    Thanks Received:
    648
    Location:
    Mainland Britain
    Hi

    Thanks for the heads up; all links to this driver appear to have been blocked by AMD :oops:

    edit: just looked here as a last resort AMD have removed 12.2

    atb

    Law-II
     
    Last edited: Jan 17, 2014
    Melvis says thanks.
  12. kn00tcn

    kn00tcn

    Joined:
    Feb 9, 2009
    Messages:
    692 (0.33/day)
    Thanks Received:
    122
    Location:
    Toronto
  13. Blín D'ñero

    Blín D'ñero

    Joined:
    Feb 21, 2009
    Messages:
    245 (0.12/day)
    Thanks Received:
    50
    Location:
    Netherlands
    Hi. On Windows 7 x64, i use the latest Catalyst supporting HD4870X2 which is Cat 13.9 Legacy.
     
    Last edited: Jan 21, 2014
    Melvis and Law-II say thanks.
  14. Blín D'ñero

    Blín D'ñero

    Joined:
    Feb 21, 2009
    Messages:
    245 (0.12/day)
    Thanks Received:
    50
    Location:
    Netherlands
    How did you check ?
    Right-click on AMD Catalyst icon in taskbar -> select the first Radeon HD4870X2 -> AMD CrossfireX settings -> Show CrossfireX status icon (where applicable).
    Launch a game. If the icon shows up ingame, it's definitely working.
     
  15. Blín D'ñero

    Blín D'ñero

    Joined:
    Feb 21, 2009
    Messages:
    245 (0.12/day)
    Thanks Received:
    50
    Location:
    Netherlands
    This thread made me update drivers on my 4870X2 system, it still had legacy 13.1.
    Appaling to see that this driver (a whql fgs!) still has the "2nd gpu at load-clocks" bug. Yes the fix Knootcn mentions still works, but godammit AMD.

    The card runs 80 °C on GPU 1 (53°C on GPU2 - room temp is 19,5 °C) at idle now (and with the previous driver also)... maybe time to clean the card.
     
  16. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia
    No worries. Im using the latest ones of 13.9 and they seem to work ish. Metro 2033 works great with them but Dota 2 sux big time.

    I do a complete driver sweep before installing the drivers this seems to work best for that machine anyway.

    Still working out a few bugs, but ill try a fresh install of 13.1 next.

    Edit: After reading more I might go back to 12.6 then and see what happens there. And yes the 2nd GPU is always stuck at the high clocks at idle until I run a game then it goes to normal :S Ill see about that fix that Knootcn said see what happens.

    My GPU temps are 48 and 40 c at idle, sometime slower depending on temp in room. But I do use afterburner so I can set my own fan speeds etc. Ill post a pic soon of what I set mine at for the card.
     
    Last edited: Jan 21, 2014
  17. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia
    My MSI Afterburner settings for the 4870X2
     

    Attached Files:

  18. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia
    Ok everything seems good even on the latest drivers and the 3D clock reset did the trick for the second GPU. Now when I run Dota 2 Crossfire isnt working and also the clock speed of the GPU's are at idle clocks, there not clocking up at all once the game starts. Any ideas?
     
  19. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia

    I noticed with the clock reset tool that I have to run it every time the computer boots up, is that right?
     
  20. kn00tcn

    kn00tcn

    Joined:
    Feb 9, 2009
    Messages:
    692 (0.33/day)
    Thanks Received:
    122
    Location:
    Toronto
    every windows boot yes (i would be inclined to say every driver boot, it's possible that if you have a driver reset, you might have to check clocks again), so just stick kev's tool or a dx9 game into your startup :cool:

    dota... are you running it windowed? crossfire (all generations) AND 3d clocks (this card for sure) only work in fullscreen, otherwise my other idea would be to disable ULPS if you have it enabled
     
    Melvis says thanks.
  21. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia
    Ahh kk no worries, bummer, but Ic an live with that i guess.

    Yep I changed it to full screen mode from not windows mode but the other option they give you. At first the screen was flashing like crazy until I shut the game down and restarted it in full screen mode. After that its all working great. thanks :)
     
  22. kn00tcn

    kn00tcn

    Joined:
    Feb 9, 2009
    Messages:
    692 (0.33/day)
    Thanks Received:
    122
    Location:
    Toronto
    let me know if the corrupted mouse cursor bug is still there, very common in dota in 2012 for multiple generations

    i'm also not sure how well CF scaling will be, or if there will be flickering, but even if it's single 4870 performance, shouldnt be too bad
     
  23. Melvis

    Melvis

    Joined:
    Mar 18, 2008
    Messages:
    3,587 (1.49/day)
    Thanks Received:
    528
    Location:
    Australia
    No corrupted mouse that I saw, so all good there.

    Crossfire scaling from what Ive seen for the 4870X2 was very good in Dota 2. Max FPS at Max settings at 1680*1050 was 80FPS. Both GPU's working well. BUT in the main menu it rans like arse at 9FPS, but i can live with that. I do get flickering in game but only when you open up the shop menu as your playing, this happens with my 7870's also.
     
  24. GUIGO New Member

    Joined:
    Sep 27, 2014
    Messages:
    1 (0.04/day)
    Thanks Received:
    0
    Hello , (i'm french so excuse me...)
    I recently repair a 4870x2 (mix 2 breaks 4870 one with memory error and one with the fan hs )
    But with installing catalyst 14.4 my bench was low cause windows reconize only one gpu and catalyst badely installed (no right option )so i search for and

    the best drivers seems to be the ati catalyst 13.1(without sdk runtime option), + 12.7cap + hydravision 13.1 + amd sdk 2.9

    just a probleme of sbksync.exe error at startup due to amd sdk that i need to desinstall (so i put the app amd sdk 2.9) ( exemples :passed from windows7 bench 6 to 7.1 and in game dirt 2 bench 50 to 110..... 1 week that i use it still perfect work)
    So this f.... card seems to be f..... good cause i just see that a new radeon hd 4870x2 is in sale http://www.amazon.com/dp/B0068OHBYU/?tag=tec06d-20 at 120$ ...
    hope that you enjoy :) GUIGO
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page