1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Changing lowest CCC clocks

Discussion in 'RBE' started by Musho, Apr 21, 2010.

  1. Musho New Member

    Joined:
    Apr 21, 2010
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    When I edit the 3d clocks _below_ the lowest possible clocks in CCC, my computer crashes when entering windows. This can be fixed by not loading CCC on startup. Now I was wondering if it was possible to be able to boot into windows successfully at ultra low 3d clocks, while still loading CCC? Is it possible by editing the registry, or will this have to be done in the bios with signatures as well, just as the upper-limit? Thanks for all the help!

    Ps. As for all the people wondering why I'd like to be able to do this: I am trying to figure out the multi-monitor flickering problem and this might help us get a fix out for this problem.

    Edit: This probably has to do with the fact the signature still states the default clocks are 850core/1200mem. Is it possible to edit these values as well? Or to make the lower-limit lower than they currently are in CCC (600/900)?
    Last edited: Apr 21, 2010
  2. muggy New Member

    Joined:
    Oct 7, 2008
    Messages:
    31 (0.01/day)
    Thanks Received:
    3
    Does it have to be the 3d clocks? What are you using to get the clocks below the CCC limit?

    You can edit the CCC limits using Radeon Bios Editor, and flash them into your card. The sliders in RBE go down to 0, I'm not sure if the card will recognize this, but I've used these sliders to successfully change the upper limits.

    The cards default to a very low state in 2d mode, 157/300. You should be able to change your clock settings for any state you want. Once when I setup my bios wrong the card would default to 400/900, even when I ran 3d apps, so I know you can go below 600/900. You can change this through flashing the bios, and most other clocking tools, including CCC if you change the limits.

    How low do you really need to go? I'm not sure how going much lower than 600/900 proves anything, but if you think it will, give it a shot.
  3. Musho New Member

    Joined:
    Apr 21, 2010
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    I am using RBE to edit the "Clock info 00" field. That sets the 3d clocks. But when I set those clocks below the CCC lower-limits, I can't boot into windows, unless I don't enable CCC to start on windows-startup. So I was wondering if it is possible to edit the CCC lower-limits, either through bios editing, editing the registry or through driver modding.

    Even after editing the bios' 3d clocks, the signature still shows 850/1200 as default speed, eventhough the 3d speed is actually only say 200/400. So maybe that's the key to changing the lower-limits. Not sure.

    Anyway, I managed to use some software tricks to get 157/300 idle working with 850/1200 3d speeds, but I'd like to be able to get that working through the hardware. That was without the desktop flickering in idle, while still running multiple monitors! (3) That's why I need that limitation to be gone.
  4. muggy New Member

    Joined:
    Oct 7, 2008
    Messages:
    31 (0.01/day)
    Thanks Received:
    3
    So did you try editing the CCC limits in RBE yet?

    It's in the additional features tab, you should use Method 2 No Hash, and you can change the limits there.
  5. Musho New Member

    Joined:
    Apr 21, 2010
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Those sliders are for the upper-limit, aren't they? I'd like to change the lower limits instead, but I'm not sure how to. Thanks for all the suggestions so far though! :toast:
  6. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,485 (13.55/day)
    Thanks Received:
    13,896
  7. Musho New Member

    Joined:
    Apr 21, 2010
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Yeah, it's a good fix, but I managed to get it even better. I'm using multiple monitors, and I'm able to let my card idle at 157/300, while it's using 850/1200 in 3d.
    No flickering at all. Not with flash videos, blurays, browsing, etc
    I'd like to implement this at bios level rather than via software, so I'm wondering if it's possible to lower those lower-limits. That would prolly make it possible.
  8. BAGZZlash

    BAGZZlash RBE Author

    Joined:
    Mar 9, 2008
    Messages:
    583 (0.25/day)
    Thanks Received:
    357
    Could you please post your BIOS?
  9. BAGZZlash

    BAGZZlash RBE Author

    Joined:
    Mar 9, 2008
    Messages:
    583 (0.25/day)
    Thanks Received:
    357
    I made some experiments regarding the lower overdrive limits. Since the lower limits aren't "hardcoded" somewhere in the BIOS the way the upper limits are I was wondering how the CCC would determine those limits. I figured out something interesting. I have a 5830 with this BIOS:

    [​IMG]

    See clock info mode 02 there? In the whole PowerPlay structure this mode is exclusively used as medium setting for powerstate 1. Pretty useless one would think.
    It turned out that these clocks are in fact the lower overdrive limits. I changed them to some odd values, flashed, rebooted and looked into the CCC - and there they were, the new lower overdrive limits! :slap:

    Maybe you should look for a similar clock info mode in you BIOS as well. Please keep us posted about your success. :toast:
    erocker, erixx and Tatty_One say thanks.
  10. Musho New Member

    Joined:
    Apr 21, 2010
    Messages:
    7 (0.00/day)
    Thanks Received:
    0
    Thanks for the info! Haven't had much time recently, but will definitely start messing around with this tomorrow. I'll keep you guys posted! :toast:
  11. Musho New Member

    Joined:
    Apr 21, 2010
    Messages:
    7 (0.00/day)
    Thanks Received:
    0

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page