1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Connect3D x800GTO flash to x850xt bios help

Discussion in 'Graphics Cards' started by wowza, Oct 26, 2006.

  1. wowza New Member

    Joined:
    Oct 26, 2006
    Messages:
    16 (0.01/day)
    Thanks Received:
    0
    Location:
    Orinda, California
    Ok, I just bought a x850 CF edition Connect3D graphics card, and I was looking to flash my x800GTO to an x850xt bios so I can use that with my CF card. I currently have it flashed to the modded bios with 16 pipes here, but doesn't work with the x850 CF card. So I was searching through BIOS's here to find a x850 bios and didn't know which one to choose. My x800GTO uses 2.0 samsung ram, and was wondering if I can flash it to a bios that uses 1.6 samsung ram? Also, my card has the r423 core, since it was a x800GTO by connect 3D, and will run 550/550 without a problem (has ATi Scilencer 5 installed). ATI tool pix in attachments if that helps at all.

    Attached Files:

    • pic2.JPG
      pic2.JPG
      File size:
      32.8 KB
      Views:
      167
    • pic.JPG
      pic.JPG
      File size:
      36.5 KB
      Views:
      145
  2. wowza New Member

    Joined:
    Oct 26, 2006
    Messages:
    16 (0.01/day)
    Thanks Received:
    0
    Location:
    Orinda, California
    anyone?
  3. SPHERE New Member

    Joined:
    Mar 31, 2005
    Messages:
    822 (0.25/day)
    Thanks Received:
    1
    Location:
    arizona (cave creek)
    have you tried running crossifre with the stock bioses?

    been a while since i helped anyone with x800/x850 stuff but i believe that you should be able to flash your gto with a x850 bios safely (if anything goes wrong use your x850 to boot and flash it back)

    id recomend moding the bios that your gonna flash to 500mem /520 core before you flash it to the card though :)
    ^rabit works nicely for moding bioses :)
  4. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,117 (5.73/day)
    Thanks Received:
    1,453
    Location:
    Oklahoma T-Town
    What motherboard do you have?
  5. SPHERE New Member

    Joined:
    Mar 31, 2005
    Messages:
    822 (0.25/day)
    Thanks Received:
    1
    Location:
    arizona (cave creek)
    a crossfire compatible one id hope lol :p
  6. wowza New Member

    Joined:
    Oct 26, 2006
    Messages:
    16 (0.01/day)
    Thanks Received:
    0
    Location:
    Orinda, California
    Yes, I have a crossfire compatible motherboard. It's in my system specs. It's an MSI 975x Platinum Powerup edition.
  7. SPHERE New Member

    Joined:
    Mar 31, 2005
    Messages:
    822 (0.25/day)
    Thanks Received:
    1
    Location:
    arizona (cave creek)
    cool :) let us know if you decide to give it a try :)
  8. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,117 (5.73/day)
    Thanks Received:
    1,453
    Location:
    Oklahoma T-Town
    It should work, you can plug any x8XX series in with a master card and it will work.
  9. DaMulta

    DaMulta My stars went supernova

    Joined:
    Aug 3, 2006
    Messages:
    16,117 (5.73/day)
    Thanks Received:
    1,453
    Location:
    Oklahoma T-Town
    Maybe its the intel chipset, I don't know if they supprt crossfire outside of the X1xxx series/ I need to read up on that my self.

    You do know you turn it on in Catalyst control center right?
  10. wowza New Member

    Joined:
    Oct 26, 2006
    Messages:
    16 (0.01/day)
    Thanks Received:
    0
    Location:
    Orinda, California
    Um, well the crossfire option in my Catalyst Control Center is missing, I thought you turned it on there?

    here is my motherboard.
  11. dolf New Member

    Joined:
    Mar 16, 2005
    Messages:
    2,058 (0.62/day)
    Thanks Received:
    30
    Wowza, save your GTO BIOS and open it with RaBit. Change your Device ID to 5D52 (X850XT R480) or 5D4D (X850XT PE); SubSystem ID to 0302 (for X850XT) or 0812 (for X850XT PE) and finally SubVendor ID to 1002 for both. Save that new BIOS (something short like x850.bin) and flash your R423 card with it using atiflash in DOS mode with:

    atiflash -f -p -newbios 0 x850.bin command

    Reinstall the drivers.

    Open ATITool and check the current Device ID. If it is 5Dxx everything is OK and you have new X850 card. Then probably your CF tab will appear. Please to report the result here.

    Good luck
    Last edited: Nov 6, 2006
  12. SPHERE New Member

    Joined:
    Mar 31, 2005
    Messages:
    822 (0.25/day)
    Thanks Received:
    1
    Location:
    arizona (cave creek)
    humm that could work there still may be other things that the drivers could look for but what the hell give it a shot :)
  13. wowza New Member

    Joined:
    Oct 26, 2006
    Messages:
    16 (0.01/day)
    Thanks Received:
    0
    Location:
    Orinda, California
    Thanks a ton for the advice dolf, it worked! Reads as an r480 core and works flawless in Crossfire mode :) See pic below (had to do some minor croping for bandwith requirements)

    Attached Files:

    • CCC.JPG
      CCC.JPG
      File size:
      192.2 KB
      Views:
      158
  14. SPHERE New Member

    Joined:
    Mar 31, 2005
    Messages:
    822 (0.25/day)
    Thanks Received:
    1
    Location:
    arizona (cave creek)
    sick :p what clocks do you have em runnin at now?
  15. dolf New Member

    Joined:
    Mar 16, 2005
    Messages:
    2,058 (0.62/day)
    Thanks Received:
    30

    Wowza, you can continue not only with the device ID's (and the card to be recognized like X850XT or X850XT PE). But it is also possible to flash X850XT or X850XT PE BIOS (probably some features like automatic overclocking in 3D mode from the driver won't be usable but I am not very sure ;) ). If you decide to do that I have special moded BIOSes for 1xVGA/1xDVI (X850XT PE PCI-E comes only with 2xDVI). The only thing that you should specify is VIVO or non VIVO is your card.
    Last edited: Nov 17, 2006
  16. wowza New Member

    Joined:
    Oct 26, 2006
    Messages:
    16 (0.01/day)
    Thanks Received:
    0
    Location:
    Orinda, California
    Humm, ok, I'll probably do that then, since it seems to flash to this without a problem. Thanks :)
  17. dolf New Member

    Joined:
    Mar 16, 2005
    Messages:
    2,058 (0.62/day)
    Thanks Received:
    30
    In fact the X800GTO from C3D is X800XT PCI-E. You have few posibilities to flash to:

    1. X800GTO moded to be recognized like X850XT or XT PE (done)
    2. X800XT BIOS to be recognized like X850XT or XT PE (probably the Overdrive tab will appear but X800 model tab)
    3. X850XT / XT PE BIOS (my special mod for VIVO cards) for 1xVGA/1xDVI (R480 should have some power management features which couldnt be used on R423 but it is not so important. Also the X850XT Overdrive should appear after the X850XT / PE BIOS flash. Please to check the pipe number and to post fuse screen shot after the X850 BIOS flash.

    Of course save the GTO BIOS which is moded to be recognized like X850 in case that you have to rollback to it.

    I am very curious what will be the result with X850XT or PE BIOS. If everything works normally open the Overdrive tab (if appear) and try the automatic overclock. After that check whether the "apply only for 3D applications" function. It should be the only difference between R423 and R480.

    For easy flashing of X850XT or X850XT PE BIOS (1xVGA/1xDVI VIVO) you can use my automated flash utility on bootable CD image from here:

    http://www.savefile.com/projects/482201

    Read the flash instructions file before to begin. After the flash it will be necessary to re-install the drivers (with exception of the X850 BIOS as which your card is currently recognized). For example X850XT.

    Good luck and please keep us informed :)
  18. p-jack New Member

    Joined:
    Jul 13, 2006
    Messages:
    334 (0.12/day)
    Thanks Received:
    8
    Location:
    Arheilgen
    ok, my card is a C3D X800GTO (R423, 2.0ns mem, 1xVGA/1xDVI). i tried the X850XT BIOS supplied in the image above, and this is what happened:

    1. winxp would only boot into safe mode
    2. screen messed up with red+blue dots
    3. gpu fan not spinning any more :)eek: :eek: :eek: )

    i managed to flash back to my old X800XT BIOS and now modded that myself with RaBit.

    but that was quite a scary experience....
  19. dolf New Member

    Joined:
    Mar 16, 2005
    Messages:
    2,058 (0.62/day)
    Thanks Received:
    30
    P-jack that is very important to know (based on experiment) that X850XT BIOS is not suitable for R423 card.
    Even scary experience it is not so dangerous like it seems to be.

    It is worst to flash AGP X800XT BIOS on PCI-E card.

    Many thanks for the feedback. It is now clear that the card X800GTO / X800XT with R423 could be moded to be recognized like X850 but not transformed to X850.
    If you can please mod the X800XT BIOS with the ID's for X850XT or XT PE and check whether some Overdrive tab will appear after the flash. If yes please post a screen shoy of it. Many thanks in advance.

    Also if possible somebody with X800GTO / XT R423 to test with 3DMark03/05 and to check is there any benefit after changing of the ID's (between X800GTO/XT and X850 recognized like R480).
    Last edited: Nov 17, 2006
  20. dunnleed08 New Member

    Joined:
    Dec 9, 2005
    Messages:
    223 (0.07/day)
    Thanks Received:
    0
    Location:
    in some sh@#%$!part of tennessee
    sapphire x800gto

    is it possible to make my x800 gto sapphire any better by flashing......taking into account that it ran on 16 pipes out of the box...?
  21. dolf New Member

    Joined:
    Mar 16, 2005
    Messages:
    2,058 (0.62/day)
    Thanks Received:
    30
    R480 or R430? AGP or PCI-E?

    If R430 you can forget about something better ;) .
  22. p-jack New Member

    Joined:
    Jul 13, 2006
    Messages:
    334 (0.12/day)
    Thanks Received:
    8
    Location:
    Arheilgen
    et voilá... :D

    3DM05 score went up by approx. 400.... :rockout:

    dolf, many thanks for all the information/explanation :toast:


    P.S. all C3D X800GTO users: feel free to give the attached bios a try...

    Attached Files:

  23. dunnleed08 New Member

    Joined:
    Dec 9, 2005
    Messages:
    223 (0.07/day)
    Thanks Received:
    0
    Location:
    in some sh@#%$!part of tennessee
    ...

    its only the 430.....that what I thought
  24. dolf New Member

    Joined:
    Mar 16, 2005
    Messages:
    2,058 (0.62/day)
    Thanks Received:
    30
    Congratulations for the "wining" of your new X850XT card.
    I have some questions and will be glad to hear your answers. Preliminary thanks for that.

    1. Do you gain some performance at equal clocks. (card recognized like X800XT and like X850XT at 520/540MHz)?
    2. You have moded X800XT PCI-E BIOS?
    3. What is your max core / memory overclock achieved using the Overdrive?
    4. Do the option "Enable ATI Overdrive clocks for 3D applications only" is working properly?

    As you can see that it is not so frightful to experiment (but knowing what you are doing). Thanks for the courage to follow my somethimes daring ideas. But all they are devoted to help to the people which want to get the best possible from their VGA's.

    I am asking that because X800XT BIOS has 2 Overdrive levels and if you are limited with the automatic Overdrive it will be necessary further BIOS modification to overcome that.

    Finally I will prepare Automated Flash Utility for C3D X800GTO and X800XT to X850XT which can be used in cases of CF comfiguration with X850CF card and X800XT or X800GTO with R423.
    Last edited: Nov 18, 2006
  25. p-jack New Member

    Joined:
    Jul 13, 2006
    Messages:
    334 (0.12/day)
    Thanks Received:
    8
    Location:
    Arheilgen
    after some testing/benching i can draw the following conclusions:

    yep. my standard 3d clocks are 550/550. highest 3DM05 score ever achieved with X800XT bios was 6590; highest 3DM05 score ever achieved with X850XT bios was 7059 (so far).

    that´s right. first i had the modded C3DX800GTO bios from w1z´s "X800 GTO and GTO² to X850 XT Mod" article; result=X800GTO, 400/490, 16p. then someone in the forums suggested flashing the bios of a powercolor X800XT PCI-E(since that card also uses R423+2.0ns memory); result=X800XT, 500/500. i dumped that bios with ATITool, set the default clocks to 520/540 and changed the IDs as you suggested; result=X850XT, 520/540, chip now seen as R480.

    max clocks overdrive could find are 594/560 (see pic). max "artifact-free" clocks with ATITool are 582/582.

    the whole catalyst overdrive thing only works with ATITool NOT running... hitting the "ok/apply" buttons in the overdrive tab with ATITool running leads to immediate system freeze/messed up screen. without ATITool running it works fine, though.

    Attached Files:

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page