1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

creative drivers won't install

Discussion in 'General Hardware' started by KainXS, Jun 17, 2009.

  1. KainXS

    KainXS

    Joined:
    Sep 25, 2007
    Messages:
    5,601 (2.14/day)
    Thanks Received:
    502
    these stupid creative drivers won't install, when I try to remove them it gives an error, when I try to install new drivers, it says higher driver detected and clicks off. I tried everything, whiping the registry, drivercleaner, can you guys recommend me something, I can't do system restore because I would lose too much data, last time I used this card was a good while back.:mad::(
     
  2. allen337

    allen337

    Joined:
    Aug 29, 2004
    Messages:
    958 (0.26/day)
    Thanks Received:
    113
    Location:
    Danville IL
    remove the card from device manager and the c/programs/creative folder and try to reinstall the new drivers
     
  3. hat

    hat Maximum Overclocker

    Joined:
    Nov 20, 2006
    Messages:
    16,951 (5.80/day)
    Thanks Received:
    2,074
    Location:
    Ohio
    Open the driver install .exe with winrar and extract it somewhere. Go to the Drivers folder and hit setup.exe. You should be able to install from there. Go through the registry manually (with regedit) and delete everything Creative.
     
    Crunching for Team TPU
  4. CAPITAL LETTERS

    CAPITAL LETTERS New Member

    Joined:
    Jan 4, 2009
    Messages:
    136 (0.06/day)
    Thanks Received:
    13
    Location:
    Ninja's Dont Need Homes
    i use a program called "driver sweep" when ran, this app will delete any remains of any driver that you select. in this case it may or may not work (due to the fact that they aren't installed in the first place) but if u have any previous audio drivers installed, use this to get rid of them and then try installing the creative drivers again.

    hope it works
     
  5. KainXS

    KainXS

    Joined:
    Sep 25, 2007
    Messages:
    5,601 (2.14/day)
    Thanks Received:
    502
    well . . . ..

    I tried all that
     
  6. hat

    hat Maximum Overclocker

    Joined:
    Nov 20, 2006
    Messages:
    16,951 (5.80/day)
    Thanks Received:
    2,074
    Location:
    Ohio
    Well if you manually went through the registry and deleted everything there that said something about Creative, then to the computer, the drivers don't even exist and you should have no problem installing the new ones...
     
    Crunching for Team TPU
  7. KainXS

    KainXS

    Joined:
    Sep 25, 2007
    Messages:
    5,601 (2.14/day)
    Thanks Received:
    502
    I know thats whats pissin me off, I deleted everything that had a their name on it or device id in the damn registry and it still thinks I have drivers

    This is why I HATE their cards
     
  8. hat

    hat Maximum Overclocker

    Joined:
    Nov 20, 2006
    Messages:
    16,951 (5.80/day)
    Thanks Received:
    2,074
    Location:
    Ohio
    I hate that there's no uninstaller for the drivers :/ maybe you missed something somewhere? Maybe your computer knows better and just won't accept Creative software? :nutkick:

    Sounds like you're gonna have to reformat.
     
    Crunching for Team TPU
  9. KainXS

    KainXS

    Joined:
    Sep 25, 2007
    Messages:
    5,601 (2.14/day)
    Thanks Received:
    502
    T.T I gotta reformat T.T
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page