1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Creative X-Fi now not recognised by windows 7

Discussion in 'General Hardware' started by Stonesour767, Oct 22, 2009.

  1. Stonesour767

    Stonesour767 New Member

    Joined:
    Jan 3, 2009
    Messages:
    182 (0.08/day)
    Thanks Received:
    1
    Just literally installed 7 home premium, and for some odd reason its not letting me use my sound card as a sound card. It's detecting it but i cant use it to play audio. I dont know what really else to put down. sorry for making this hard for you guys. I dont really know what info you'd need.
     
  2. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    40,408 (12.58/day)
    Thanks Received:
    15,057
    Go to Device Manager and disable the ATi HDMI Audio driver. Restart.
     
  3. Stonesour767

    Stonesour767 New Member

    Joined:
    Jan 3, 2009
    Messages:
    182 (0.08/day)
    Thanks Received:
    1
    there's 3 different high definition audio devices according to this. and also the sound card.
     
  4. Stonesour767

    Stonesour767 New Member

    Joined:
    Jan 3, 2009
    Messages:
    182 (0.08/day)
    Thanks Received:
    1
    fixed! thank you.
     
  5. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    40,408 (12.58/day)
    Thanks Received:
    15,057
    Take a screenshot. You probablly have your onboard audio enabled in your BIOS as well.

    *Good to hear it's working. :toast:
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page