1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Deploying a Crystal Report project in VS2008

Discussion in 'Programming & Webmastering' started by Kreij, May 1, 2008.

  1. Kreij

    Kreij Senior Monkey Moderator Staff Member

    Joined:
    Feb 6, 2007
    Messages:
    13,881 (4.92/day)
    Thanks Received:
    5,616
    Location:
    Cheeseland (Wisconsin, USA)
    I have been beating my head against the wall (for 2 weeks) trying to get a application project I wrote in VS2008, that uses Crystal Reports, to deploy to workstations.

    Without going into gory details on what didn't work, here is what worked for me.

    VS2008 has CR 2008 Basic included in it.

    After you have built the setup project for you app (which will include something like app.msi and setup.exe)
    and pushed them to the server location that the workstations will be installing from,
    go to
    "C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\Packages\CrystalReports10_5"
    and copy the CRRedist2008_x86.msi file to the server directory also.

    From the workstation, run CRRedist2008_x86.msi and then your setup.exe file and it should work fine.

    For some reason the forum is putting a space between the Re and ports of the CR directory name. There should not be one.
    It should be "CrystalReports10_5"
     
    Last edited: May 1, 2008

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page