1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Extremely Slow....

Discussion in 'General Hardware' started by vito7766, Mar 25, 2006.

  1. vito7766 New Member

    Joined:
    Feb 14, 2006
    Messages:
    63 (0.02/day)
    Thanks Received:
    0
    For some reason my hard drive switched from Dma to Pio mode and I can't switch it back. Any suggestions? I've looked all over the bios, nothing, and the properties at the Device Manager say Dma if available.:confused: My computer went from booting in 35 seconds to 2-3 minutes.:banghead:
  2. malware New Member

    Joined:
    Nov 7, 2004
    Messages:
    5,476 (1.55/day)
    Thanks Received:
    956
    Location:
    Bulgaria
    First check in BIOS if the DMA access is enabled, then in windows delete the IDE channel(which your hdd is on), restart, wait windows to install the drivers and set to DMA if available again. It's common problem with hdd and cd-rom devices.
  3. vito7766 New Member

    Joined:
    Feb 14, 2006
    Messages:
    63 (0.02/day)
    Thanks Received:
    0
    I already checked in the bios. But how do you delete the IDE channel. I can't wait until i get my 250g Sata hard drive.
  4. malware New Member

    Joined:
    Nov 7, 2004
    Messages:
    5,476 (1.55/day)
    Thanks Received:
    956
    Location:
    Bulgaria
    Simply go to the device manager, then IDE ATA/ATAPI controllers.....click on the first or second IDE chan(where the hard is pluged) hit the delete key and confirm. After that just restart the OS, wait Windows to install the IDE drivers again and set to DMA if available.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page