1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Fallout 3 GOTY still crashes

Discussion in 'Games' started by Animalpak, Jun 24, 2010.

  1. Animalpak

    Animalpak

    Joined:
    Feb 8, 2008
    Messages:
    2,072 (0.88/day)
    Thanks Received:
    533
    Hey guys


    Im playing Fallout 3 with the patch 1.7 on win 7 64-bit, I can play for 10 minutes after the game freezes then crash.

    I do not understand every time I enter into a closed area FPS increase but when I go out into the open everything becomes slow this did not happen with the old drivers.


    Drivers are updated to 257.21 to be honest I feel hurt about.

    What could the problem be?
  2. Black Panther

    Black Panther Senior Moderatorâ„¢ Staff Member

    Joined:
    May 30, 2007
    Messages:
    8,558 (3.29/day)
    Thanks Received:
    1,911
    Go back to the old drivers?
    Sorry for not actually 'solving' the problem but that way you will be able to game at least. :ohwell:
  3. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,489 (13.55/day)
    Thanks Received:
    13,899
    Yes. Obviously something with the new drivers doesn't like Fallout 3. Always use drivers that work best for you, not the newest/latest.
  4. Black Panther

    Black Panther Senior Moderatorâ„¢ Staff Member

    Joined:
    May 30, 2007
    Messages:
    8,558 (3.29/day)
    Thanks Received:
    1,911
    QFT.

    Some weeks ago I installed the latest mobility drivers for my laptop, the WHQL from the Nvidia site.
    Laptop wouldn't even start up, just BSOD :eek:
  5. Animalpak

    Animalpak

    Joined:
    Feb 8, 2008
    Messages:
    2,072 (0.88/day)
    Thanks Received:
    533
    not sure about drivers now i tried the old 197 and still crashes...

    I have seen the percentage of work on the graphics card with EVGA Precision tool and has never 100%! He goes up and down 30-80% this could explain the drop in frame rate might have a problem of supply.

    I have to investigate on my powersupply I believe has been damaged and that does not feed well the graphics card. I can not mount my GTX 295 just for one reason of amperage.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page