1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

far cry 3 adaptive vsync.

Discussion in 'Games' started by barlowLAD, Dec 2, 2012.

  1. barlowLAD New Member

    Joined:
    Jul 16, 2012
    Messages:
    85 (0.11/day)
    Thanks Received:
    6
    Location:
    Cheshire, England
    Hi all.

    Cannot seem to force adaptive vsync on in the nvidia cp. Getting awful screen tears and vsync causes stuttering.

    The option is there but in game I still get the tears. It works fine in all other games.

    Running 310.64
  2. MxPhenom 216

    MxPhenom 216 Corsair Fanboy

    Joined:
    Aug 31, 2010
    Messages:
    9,930 (6.79/day)
    Thanks Received:
    2,207
    Location:
    Seattle, WA
    It probably doesnt work with Far Cry 3 yet.
  3. barlowLAD New Member

    Joined:
    Jul 16, 2012
    Messages:
    85 (0.11/day)
    Thanks Received:
    6
    Location:
    Cheshire, England
    I have seen others using this as a fix for these issues, so it must work, how would I troubleshoot a game that doesnt respond to forced cp commands
  4. qubit

    qubit Overclocked quantum bit

    Joined:
    Dec 6, 2007
    Messages:
    9,821 (3.99/day)
    Thanks Received:
    3,480
    How about using regular vsync?
  5. barlowLAD New Member

    Joined:
    Jul 16, 2012
    Messages:
    85 (0.11/day)
    Thanks Received:
    6
    Location:
    Cheshire, England
    Causes stutter.
  6. ...PACMAN...

    ...PACMAN...

    Joined:
    Nov 22, 2012
    Messages:
    288 (0.44/day)
    Thanks Received:
    93
    Try Vsync and the MSI Afterburner in the background with a 60fps frame rate cap.
  7. qubit

    qubit Overclocked quantum bit

    Joined:
    Dec 6, 2007
    Messages:
    9,821 (3.99/day)
    Thanks Received:
    3,480
    There could be several causes for this:

    - Windows 8 is new, so the drivers could be buggy. Framerate may not be keeping up with the 60Hz monitor refresh. Check it with www.fraps.com and try with Windows 7 if possible

    - The game is new, so the above applies

    - System may have insufficient performance, even though it's powerful. However, FC3 might be putting a helluva load on it being the latest and greatest. Try lowering the resolution to 1024x768 and see if it improves. Also, try lowering AA/AF and in-game quality settings and see how it goes. If the frame rate improves, then there's your answer.
  8. Crap Daddy

    Crap Daddy

    Joined:
    Oct 29, 2010
    Messages:
    2,739 (1.95/day)
    Thanks Received:
    1,044
    Odd. Have you tried vsync on 1 and mess with GPU max buffered frames?
    barlowLAD says thanks.
  9. Spaceman Spiff

    Spaceman Spiff

    Joined:
    Mar 6, 2007
    Messages:
    631 (0.23/day)
    Thanks Received:
    128
    Try using application controlled vsync in nvidia control panel and using D3DOverrider to force vsync and triple buffering in DX apps. Triple buffering in NvCP is only for OpenGL apps. I have not tried this in FC3 but use these settings for every game I play except some emulators which cause issues.

    Reading around I've found adaptive vsync is largely broken in many applications. Correct me if I am wrong though.
  10. Frag Maniac

    Frag Maniac

    Joined:
    Nov 9, 2010
    Messages:
    2,450 (1.76/day)
    Thanks Received:
    506
    I heard this game has VSync 1 frame and 2 frame mode in the menu, which I've never seen before in a game. Have you tried both modes? Also, try setting an FPS cap, even if it's lower than 60 if having VSync on doesn't keep it at 60.

    Usually this kind of stutter is due to FPS fluctuating from high to low. DxTory can set FPS to any rate, and there's a free trial version. It's worth buying if you do a lot of game capture though.

    You should also try different mouse settings with and without acceleration to see if it smooths things out.
    barlowLAD says thanks.
  11. MightyMission

    MightyMission

    Joined:
    Mar 21, 2011
    Messages:
    1,031 (0.82/day)
    Thanks Received:
    136
    I'm using win 8 (pro 64 bit) and a 680,i set the vsync to 1 frame and 5 frames buffer,no tearing here..
    [​IMG]
    Last edited: Dec 2, 2012
    barlowLAD says thanks.
  12. Super XP

    Super XP

    Joined:
    Mar 23, 2005
    Messages:
    2,754 (0.80/day)
    Thanks Received:
    538
    Location:
    Ancient Greece, Acropolis
    What? I hope this game isn't infested due to bad programming. Rage comes to mind, despite loving the game.
  13. barlowLAD New Member

    Joined:
    Jul 16, 2012
    Messages:
    85 (0.11/day)
    Thanks Received:
    6
    Location:
    Cheshire, England
    ^This^ works :)
  14. lyndonguitar

    lyndonguitar I play games

    Joined:
    Apr 1, 2010
    Messages:
    1,629 (1.01/day)
    Thanks Received:
    338
    Location:
    Philippines
    vsync 2 on me causes stuterring, I use AMD

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page