1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

flashed 5970 with 7600GT bios..... Now with fix!

Discussion in 'AMD / ATI' started by computertechy, Feb 14, 2010.

  1. Black Panther

    Black Panther Senior Moderator™ Staff Member

    Joined:
    May 30, 2007
    Messages:
    8,577 (3.21/day)
    Thanks Received:
    1,928
    That's just great!!! :toast:

    I had only read till the part where you asked where the bios chip is, and I had found a picture of a 5970 to post here for you:

    [​IMG]

    I'm curious to know how you did it too.

    W1zzard is an awesome bottomless well of knowledge! :rockout:
     
  2. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    12,464 (4.72/day)
    Thanks Received:
    1,481
    Was Wizzard talking about a Reset Jumper on the Video card or the system motherboard???
     
  3. assaulter_99

    assaulter_99

    Joined:
    Dec 7, 2009
    Messages:
    1,792 (1.02/day)
    Thanks Received:
    277
    Damn, its only now that I realise that the 5870 is a very loooong card! ;) Nice to see such an expensive poh ressurected! Seems wizz is the man! :laugh:
     
    computertechy says thanks.
  4. t_ski

    t_ski Former Staff

    Joined:
    Apr 11, 2006
    Messages:
    10,820 (3.51/day)
    Thanks Received:
    4,272
    That's not a 5870 in the pic, but a 5970 card (the dual GPU version).

    Come on techy, what the story???!?!
     
    computertechy says thanks.
    Crunching for Team TPU
  5. assaulter_99

    assaulter_99

    Joined:
    Dec 7, 2009
    Messages:
    1,792 (1.02/day)
    Thanks Received:
    277
    Ooops! Stupid typo! :slap:
     
    computertechy says thanks.
  6. BradleyKZN

    BradleyKZN New Member

    Joined:
    Feb 5, 2009
    Messages:
    1,148 (0.56/day)
    Thanks Received:
    58
    Location:
    South Africa
    Excellent, great to hear!
     
    computertechy says thanks.
  7. DannibusX

    DannibusX

    Joined:
    Aug 17, 2009
    Messages:
    2,528 (1.36/day)
    Thanks Received:
    979
    Location:
    United States
    When I read that you accidentally flashed your 5970 like that, I facepalmed, laughed a little and hoped you would get it sorted.

    Glad to hear that you got things squared away!
     
    computertechy says thanks.
  8. Duffman

    Duffman New Member

    Joined:
    Dec 5, 2007
    Messages:
    1,011 (0.41/day)
    Thanks Received:
    67
    Location:
    Mt. Pocono, PA
    Awesome! Wizzard is the beez kneez
     
    Cybrnook and computertechy say thanks.
  9. computertechy

    computertechy New Member

    Joined:
    Apr 3, 2006
    Messages:
    828 (0.27/day)
    Thanks Received:
    177
    Location:
    UK, Brighton
    i fixed it all thanks to this :) and some help from wizzard with finding the correct chip :toast:

    http://home.no/rogerh99/1.pdf (thanks to Frogger for posting this previously):toast:

    had to bridge pin 1 & 8 of U8 chip(on the back of the card) & U37 chip(on the front of the card) notice that their are 2 bios chips for each GPU core(like the 4870X2) pin 1 should have a dot on the IC or a arrow pointing to it, and pin 8 should be the exact oposite.

    DATASHEET ON FLASH ROM

    atiflash see's the card when those pins are bridged but doesnt allow flashing, just unbridge the pins and flash....job done :D

    FRONT OF CARD

    BACK OF CARD

    Hope this helps :D:toast:

    EDIT: doing the front bios was extremely hard with a water block on it, but after some blutak and some superglue...job done LMAO

    [​IMG]

    [​IMG]
     
    Last edited: Feb 17, 2010
    Xazax, DRDNA, Scrizz and 14 others say thanks.
  10. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    12,464 (4.72/day)
    Thanks Received:
    1,481
    too bad we cant have those chips socketed like Motherboards do.
     
    computertechy says thanks.
  11. InnocentCriminal

    InnocentCriminal Resident Grammar Amender

    Joined:
    Feb 21, 2005
    Messages:
    6,486 (1.85/day)
    Thanks Received:
    847
    A lot has been learnt from this thread. If you're accident hadn't have happened computertechy this method wouldn't have come about.
     
    computertechy says thanks.
  12. mlee49

    mlee49

    Joined:
    Dec 27, 2007
    Messages:
    8,488 (3.45/day)
    Thanks Received:
    2,105
    I have a feeling that after this thread goes dormant for a few months a new forum member will post for help.


    Also, it is said that you don't really learn something properly until you break it(and fix it yourself). Congratulations on breaking and fixing your card. :toast:
     
    computertechy says thanks.
  13. DrPepper

    DrPepper The Doctor is in the house

    Joined:
    Jan 16, 2008
    Messages:
    7,483 (3.06/day)
    Thanks Received:
    813
    Location:
    Scotland (It rains alot)
    We should all thank computertechy for this. It's very rare to see people experiment like that these days unlike a while back where people would mod everything because they could.
     
    computertechy says thanks.
  14. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    12,464 (4.72/day)
    Thanks Received:
    1,481
    We Need a Sticky to this Thread
     
    computertechy says thanks.
  15. Polarman

    Polarman New Member

    Joined:
    Jun 24, 2008
    Messages:
    1,627 (0.71/day)
    Thanks Received:
    292
    Location:
    Rimouski
    You should make a detailed explantion on how to recover this kind of bad flash in a seperate thread and ask Wizzard to have it stickied.
     
    computertechy says thanks.
  16. xrealm20

    xrealm20 New Member

    Joined:
    Jan 29, 2010
    Messages:
    467 (0.28/day)
    Thanks Received:
    129
    Location:
    Houston
    Grats on getting your card working again - I'm sure that was a stressful process.
     
    computertechy says thanks.
  17. Frogger

    Frogger

    Joined:
    Feb 12, 2006
    Messages:
    2,180 (0.69/day)
    Thanks Received:
    313
    :toast: Happy to see all is working again:D
     
    Last edited: Feb 17, 2010
    computertechy says thanks.
  18. Asylum

    Asylum

    Joined:
    Jul 18, 2008
    Messages:
    2,799 (1.24/day)
    Thanks Received:
    674
    Location:
    South Carolina
    Glad to see you got it straighten out.
     
    computertechy says thanks.
  19. computertechy

    computertechy New Member

    Joined:
    Apr 3, 2006
    Messages:
    828 (0.27/day)
    Thanks Received:
    177
    Location:
    UK, Brighton
    sorry frogger i meant you :p

    post edited :D
     
  20. cbupdd

    cbupdd New Member

    Joined:
    Jun 6, 2009
    Messages:
    102 (0.05/day)
    Thanks Received:
    21
    Location:
    [EU] Panxa del Bou!
    It happened a funny thing to me; I was going to resurrect my old x300se with this metode, but I had a problem with ati flash, "flash not detected, error 0fl01 :(
    I searched on the web, and there was a solution using flashrom.. The result, my 5670 was flashed with a x300se bios :laugh:
    I booted with a pci, and my 5670 wasn't found with atiflash, so I used this metode and my 5670 is now alive :eek:
    The bios chip of the 5670 was on the back, so I didn't need to solder anything, I just made contact pin 1 with pin 8 with a wire, until de computer booted.
    Also, if it helps someone, I will make a step by step guide, with photos
     
    DRDNA says thanks.
  21. DTV DRAGON

    DTV DRAGON New Member

    Joined:
    Jun 3, 2008
    Messages:
    877 (0.38/day)
    Thanks Received:
    64
    Location:
    canada
    Iam so happy for you as well!! Lord knows Ive been in the situation a few times before Dragon
     
  22. mlee49

    mlee49

    Joined:
    Dec 27, 2007
    Messages:
    8,488 (3.45/day)
    Thanks Received:
    2,105
    I think it would be important to change the title of this thread to include a "Fixed" portion for those that may be googleing with the same trouble in the future.
     
  23. boulard83

    Joined:
    Jan 28, 2009
    Messages:
    399 (0.19/day)
    Thanks Received:
    61
    Awesome ! good job ! :)
     
  24. Aceman.au

    Aceman.au

    Joined:
    Jun 19, 2008
    Messages:
    1,446 (0.63/day)
    Thanks Received:
    62
    Flashing a 5970 with a 7600GT... Smartest person I've seen yet
     
    El_Mayo says thanks.
  25. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,231 (11.61/day)
    Thanks Received:
    9,529
    you're just jealous you didnt think of it first.


    Seriously tho, thats a bit borderline on personal attack/insulting another member.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page