1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Foxconn Renaissance 2 weeks old dead =(

Discussion in 'Motherboards & Memory' started by InTeL-iNsIdE, Oct 13, 2009.

  1. InTeL-iNsIdE Guest

    Well I think my motherboard has crapped out on me, I came down this morning and my pc was on but there was no signal to the monitor, have been trying to sort it for the last few hours to no avail.

    I had to turn it off at the mains to get it to power down and then it wouldnt power back on, or it would get caught in a cycle of powering up and powering off over and over again with no signal being recieved bu the monitor. I have tried clearing cmos and removing everything including all sticks of ram bar one, and just having the bare essentials plugged in.

    I have read reviews on the egg about people having this same reboot cycle with this board and am sure a couple of the cpu socket pins were bent when I first got it although it worked fine when installed so I didnt take any notice, again reviewers have noted bent pins on these boards from new.

    After a while it wouldnt even power on and the only way I could get any power going through it was by pulling the 24 pin atx plug out of the board and putting it back in and then pressing the power switch straight away, which again gave me the power on,power off symptom :banghead:

    Have just emailed Ebuyer, and awaiting there reply, I think I am going to change the board completely :cry:
     
  2. Sir_Real

    Sir_Real New Member

    Joined:
    Feb 24, 2009
    Messages:
    706 (0.35/day)
    Thanks Received:
    94
    Location:
    Lincoln England
    Has the mobo been warp / bent much by the cpu heatsink? I read a bit back its a common prob with heatsinks & mobos these days with the clips on heatsinks having zero flex in them. This can sometimes put excessive pressure on the mobo & damage the circuit board.
     
  3. InTeL-iNsIdE Guest

    No not been bent at all, its a common (ish) problem with these boards, so I realised after hours of trying to hunt for Foxconn LED error codes.

    Well it is being picked up tomorrow I think I will just ask for a refund and grab a new board :rolleyes:
     
  4. Jstn7477

    Jstn7477

    Joined:
    Aug 30, 2009
    Messages:
    3,833 (2.08/day)
    Thanks Received:
    1,527
    Location:
    Sarasota, Florida, USA
    That really sucks that your shiny new X58 board crapped out on you after 2 weeks. Better luck with a different brand. :)
     
    Crunching for Team TPU More than 25k PPD

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page