1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Game starts lagging after 20-30 mins

Discussion in 'NVIDIA' started by sergiyny, Feb 4, 2012.

  1. sergiyny New Member

    Joined:
    Feb 4, 2012
    Messages:
    4 (0.00/day)
    Thanks Received:
    1
    I've been playing Batman Arkham Asylum, and the game started lagging more and more, until it was impossible to play. Can anyone help me to solve the problem, with my specs i shouldn't have a single lag. Help:(
    Here are my specs:
    Intel Core i7 3.2Ghz
    GeForce GTX 570
    12 GB RAM
    850W power supply
     
  2. xxdozer32

    xxdozer32 New Member

    Joined:
    Oct 15, 2011
    Messages:
    210 (0.19/day)
    Thanks Received:
    21
    Location:
    OC, SOCAL
    maybe your card is getting too hot. check your temps
     
    sergiyny says thanks.
  3. xenocide

    xenocide

    Joined:
    Mar 24, 2011
    Messages:
    2,149 (1.64/day)
    Thanks Received:
    463
    Location:
    Burlington, VT
    I suspect overheating.
     
    sergiyny says thanks.
  4. Yo_Wattup New Member

    Joined:
    Jan 26, 2012
    Messages:
    790 (0.79/day)
    Thanks Received:
    200
    Location:
    Brisbane, Australia
    Yep.
     
  5. sergiyny New Member

    Joined:
    Feb 4, 2012
    Messages:
    4 (0.00/day)
    Thanks Received:
    1
    Didn't happen before
     
  6. MT Alex

    MT Alex

    Joined:
    Aug 2, 2009
    Messages:
    3,791 (1.99/day)
    Thanks Received:
    1,627
    sergiyny says thanks.
  7. d3fct

    d3fct

    Joined:
    Jul 15, 2009
    Messages:
    1,087 (0.56/day)
    Thanks Received:
    165
    Location:
    Upstate NewYork
    sounds like overheating, ive played that game for many hours and have beaten it without any issues, also with a 570. i would suggest installing something like afterburner, then crank up your fan to like 60% or so and play again, if its a heat issue this should clear it up. leaving you the task of figuring out why it's running hot.

    edit: (after thought) maybe bad air flow in the case.
     
    Last edited: Feb 8, 2012
    sergiyny says thanks.
  8. St.Alia-Of-The-Knife New Member

    Joined:
    Mar 9, 2011
    Messages:
    195 (0.15/day)
    Thanks Received:
    32
    Location:
    Montreal, Canada
    overheating or memory leak
     
  9. d3fct

    d3fct

    Joined:
    Jul 15, 2009
    Messages:
    1,087 (0.56/day)
    Thanks Received:
    165
    Location:
    Upstate NewYork
    would think memory issue would artifact, could be wrong.
     
  10. sergiyny New Member

    Joined:
    Feb 4, 2012
    Messages:
    4 (0.00/day)
    Thanks Received:
    1
    made the speed of fan go faster and looks like the problem is solved. everyone thanks!
     
    erocker says thanks.
  11. d3fct

    d3fct

    Joined:
    Jul 15, 2009
    Messages:
    1,087 (0.56/day)
    Thanks Received:
    165
    Location:
    Upstate NewYork
    fixed for now, i think maybe your case is air restrictive. you shouldn't have to push the fan speed up, is what i'm getting at, now you need to address the overheating issue, why and what is causing it.
     
    Last edited: Feb 8, 2012
  12. Goodman

    Goodman

    Joined:
    Jun 13, 2009
    Messages:
    1,519 (0.78/day)
    Thanks Received:
    324
    Location:
    Canada/Québec/Montreal
    Yeah i agree fixed now!
    You could also buy a can of compress air & spray all the dust out of your case included , mobo , CPU , GC & PSU every 3-4 months

    God damn... just lost my 1337 with this post :rolleyes:
     
  13. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    12,976 (4.86/day)
    Thanks Received:
    1,629
    Clean/dust your case and every heasink/ fan in it plus. If youre overclocking RAM/ CPU RELAX CLOCK SPEED/TIMINGS.
     
  14. Yo_Wattup New Member

    Joined:
    Jan 26, 2012
    Messages:
    790 (0.79/day)
    Thanks Received:
    200
    Location:
    Brisbane, Australia
    How many fans in your case/what size? I have 3x 120mm fans and my 6950 is always getting to 75C, so I'm modding may case and putting 4 more in.
     
  15. sergiyny New Member

    Joined:
    Feb 4, 2012
    Messages:
    4 (0.00/day)
    Thanks Received:
    1
    1 in front 120mm, 1 on the side panel which about 130mm, and Liquid CPU Cooler. and i kind of started again experiencing lags :(
     
    Last edited: Feb 9, 2012

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page