1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

General Manufacturer Support Thread

Discussion in 'General Hardware' started by Cold Storm, Dec 31, 2010.

  1. Drone

    Drone

    Joined:
    Sep 1, 2010
    Messages:
    3,125 (1.81/day)
    Thanks Received:
    2,062
    Cold Storm says thanks.
  2. jeff New Member

    Joined:
    May 16, 2013
    Messages:
    2 (0.00/day)
    Thanks Received:
    0
    I need help. Got no power to hisense 50 in. Led
     
  3. remixedcat

    remixedcat

    Joined:
    May 13, 2010
    Messages:
    3,329 (1.81/day)
    Thanks Received:
    849
  4. jeff New Member

    Joined:
    May 16, 2013
    Messages:
    2 (0.00/day)
    Thanks Received:
    0
    is there n e one that can help me out. I was hooking up surround sound on flat screen and it was like I popped a fuse. Now I get no power. Is there a reset button
     
  5. remixedcat

    remixedcat

    Joined:
    May 13, 2010
    Messages:
    3,329 (1.81/day)
    Thanks Received:
    849
    What surround sound system do you got?

    Please post a new thread and provide more detail so we can further assist you. Thank you.
     
  6. shariarkhabir21 New Member

    Joined:
    Nov 25, 2013
    Messages:
    2 (0.00/day)
    Thanks Received:
    0
    well, this is a great post on different specifications and it would help others hopefully.
     
  7. Arjai

    Arjai

    Joined:
    Apr 3, 2012
    Messages:
    2,704 (2.36/day)
    Thanks Received:
    5,035
    Location:
    St. Paul, MN
    Nice work, Cold Storm!! Just found this thread. Should be VERY useful, once I get back on my feet. Thanks for being a TPU-er!!

    :lovetpu:

    Also Kudos to Drone for all those links, nice work! Between the two of you, just about everything is at our fingertips!!

    :toast:
     
    Cold Storm says thanks.
    Crunching for Team TPU
  8. AsRock

    AsRock TPU addict

    Joined:
    Jun 23, 2007
    Messages:
    11,751 (4.06/day)
    Thanks Received:
    2,054
    Location:
    US
    Trying to get Thrustmaster to email me as it seems it's not available or support on their site. Just got off the phone from them once already with them.

    They picked up while typing this.

    After waiting over a hour for a email i just happened to get of the phone again to get told they deal with all the phone calls before they email people lol.

    Waiting system is screwed i always get put second in line with a crappy tune they play and a little later followed with a 2 minute wait time which each time the tune ends it adds on a minutes lol.

    The email i want of them asks me to follow what is required for a replacement which in my case requires a sound recording of the fault and i believe they will require me to cut cables to but will have to wait on that.

    Thrustmaster used to be a good company but not these days as it seems like they trying to avoid support their products.

    Anyways will update once i get the email that's if it arrives lol.

    Here's the email address thrustmaster-english@guillemotsupport.com
     
    Last edited: May 12, 2015
  9. remixedcat

    remixedcat

    Joined:
    May 13, 2010
    Messages:
    3,329 (1.81/day)
    Thanks Received:
    849
    well I have had a good experience with Logitech support lately....

    had an issue with the G700 on wireless where the cursor movement would start up slow after it woke up... tried a buncha stuff and didn't make any difference. well I submitted a support ticket and then they gave me a G700s and didn't have to send the G700 back!
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page