1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Got the Xigmatek Thor's Hammer :/

Discussion in 'Overclocking & Cooling' started by Nick89, Sep 5, 2009.

  1. Nick89

    Nick89

    Joined:
    Jun 1, 2006
    Messages:
    1,742 (0.59/day)
    Thanks Received:
    176
    Location:
    The Nevada Wasteland
    So I got the Xigmatek Thor's hammer and it doesn't cool any better than a S1283.

    I have two fans blowing through the thing and I'm getting the same temps as my S1283, And yes I reseated it. I used AS5 for the thermal paste.

    NO this is not a help thread, I don't want any help. I installed the thing correctly it just isn't any better than a S1283.

    It seems a lot of reviewers are full of BS because I've used 2-3 other coolers and only one of them didn't perform as well as the S1283 and that was the CCF.

    Current idle temp is 42C..... Same as my S1283. I guess the S1283 is better than I thought. Now that I think about it 42C is what I get with the stock cooler.

    At least it looks cool.......
    Last edited: Sep 5, 2009
  2. Kantastic

    Kantastic

    Joined:
    May 12, 2009
    Messages:
    5,140 (2.70/day)
    Thanks Received:
    993
    I doubt your Phenom could get any cooler than what the S1283 had to offer anyway, the Thor's Hammer might make a difference when cooling an i7.

    PS - The DK looks cooler IMO.
  3. sneekypeet

    sneekypeet Unpaid Babysitter Staff Member

    Joined:
    Apr 12, 2006
    Messages:
    21,474 (7.09/day)
    Thanks Received:
    5,987
    What fans are you using?

    Oh and of course its the same idle temp....the load temp is what matters.
  4. rampage

    Joined:
    May 31, 2007
    Messages:
    1,050 (0.40/day)
    Thanks Received:
    69
    Location:
    Port Fairy, Victoria, Australia
    idle temps wont change much, that's cpu volts... load temps are what will change
  5. Nick89

    Nick89

    Joined:
    Jun 1, 2006
    Messages:
    1,742 (0.59/day)
    Thanks Received:
    176
    Location:
    The Nevada Wasteland
    I'm using two 120mm Scythe Slipstream 110-CFM fans.

    http://www.newegg.com/Product/Product.aspx?Item=N82E16835185060

    Load is the same as the S1283...

    Used line pack in OCCT for 40mins to get load. Load with both coolers is 55C
  6. aCid888*

    aCid888* New Member

    Joined:
    May 19, 2008
    Messages:
    2,754 (1.22/day)
    Thanks Received:
    645
    Location:
    In a state of flux...
    Reseat the cooler...it should be a bit better than the 1283.
  7. Nick89

    Nick89

    Joined:
    Jun 1, 2006
    Messages:
    1,742 (0.59/day)
    Thanks Received:
    176
    Location:
    The Nevada Wasteland
    Did you read my post? its been done multiple times with different amounts of Thermal paste. I'm using my normal amount of thermal paste ATM because more makes it worse and less makes it worse.

    Also I'm not in need of help, I put the thing on correct. Its just not that exceptional it seems.
  8. sneekypeet

    sneekypeet Unpaid Babysitter Staff Member

    Joined:
    Apr 12, 2006
    Messages:
    21,474 (7.09/day)
    Thanks Received:
    5,987
    I would get with Xigmatek about your findings, I bet they may send a replacement.
  9. Nick89

    Nick89

    Joined:
    Jun 1, 2006
    Messages:
    1,742 (0.59/day)
    Thanks Received:
    176
    Location:
    The Nevada Wasteland
    The top of the cooler was damaged when I got it so I doubt I can get a replacement.

    It wasn't seriously damaged the aesthetic part that covers the ends of the heat pipes was beat up but there was no other damage.

    Attached Files:

  10. Kenshai

    Joined:
    Mar 2, 2008
    Messages:
    1,646 (0.70/day)
    Thanks Received:
    218
    Location:
    Raleigh, North Carolina
    Were you using the same push/pull set-up with the 1283?

    Edit: You're not even pushing 1.4v, of course there will be little to no difference. That's not a whole lot of volts. I say crank it up and give it a shot with both of them.
  11. Kantastic

    Kantastic

    Joined:
    May 12, 2009
    Messages:
    5,140 (2.70/day)
    Thanks Received:
    993
    I would've been on the phone with Newegg the moment I saw the damage done to that Thor's Hammer.

    Well that is if you got it off Newegg, but regardless of the place you purchased it, I would have been screaming at the customer service agent for an RMA.
    Last edited: Sep 5, 2009
  12. Nick89

    Nick89

    Joined:
    Jun 1, 2006
    Messages:
    1,742 (0.59/day)
    Thanks Received:
    176
    Location:
    The Nevada Wasteland
    well its not to late for that.
  13. sneekypeet

    sneekypeet Unpaid Babysitter Staff Member

    Joined:
    Apr 12, 2006
    Messages:
    21,474 (7.09/day)
    Thanks Received:
    5,987
    Dude if thats how it came, no wonder its disfunctional...get with the egg, UPS, or Xig and get this sorted ASAP, that is unacceptable.

    you should have said this from the start BTW;)
  14. Nick89

    Nick89

    Joined:
    Jun 1, 2006
    Messages:
    1,742 (0.59/day)
    Thanks Received:
    176
    Location:
    The Nevada Wasteland
    eh. None of the heat pipes were damaged.
  15. sneekypeet

    sneekypeet Unpaid Babysitter Staff Member

    Joined:
    Apr 12, 2006
    Messages:
    21,474 (7.09/day)
    Thanks Received:
    5,987
    doesnt matter, that kind of blow could have warped the base at the very least. Why on earth would you not want to return it, it is obviously broken.
  16. chuck216

    chuck216

    Joined:
    Mar 27, 2007
    Messages:
    577 (0.22/day)
    Thanks Received:
    72
    Location:
    Tampa FL
    Something's not quite right with either the 1238 or the Thor's hammer if you're getting a 42c idle and 55c load temp with both of them. My Big Typhoon VX, non-lapped with mx-2 keeps my cpu at 37c at idle and 51c at load and it's not supposed to be half as good as either of those. Ambient temp is around 80f BTW.
  17. [I.R.A]_FBi

    [I.R.A]_FBi New Member

    Joined:
    May 19, 2007
    Messages:
    7,664 (2.92/day)
    Thanks Received:
    540
    Location:
    c:\programs\kitteh.exe
    if ur selling the 1283 holler
  18. sneekypeet

    sneekypeet Unpaid Babysitter Staff Member

    Joined:
    Apr 12, 2006
    Messages:
    21,474 (7.09/day)
    Thanks Received:
    5,987
    look at post #9 thats whats wrong;)
  19. chuck216

    chuck216

    Joined:
    Mar 27, 2007
    Messages:
    577 (0.22/day)
    Thanks Received:
    72
    Location:
    Tampa FL
    Oh I saw that, but I noted that his 1238 wasn't performing quiet as good as it could have either, he should get far better temps than I do with my BT VX even with the 1238. The hammer not performing is of course due to the damage.
  20. Kantastic

    Kantastic

    Joined:
    May 12, 2009
    Messages:
    5,140 (2.70/day)
    Thanks Received:
    993
    Don't worry about shipping fees, Newegg will email you a 'one time UPS shipping label' when you ask, simply print that out and slap it on the box and UPS will ship it free of charge.
  21. WOOKZ

    WOOKZ New Member

    Joined:
    Apr 13, 2009
    Messages:
    112 (0.06/day)
    Thanks Received:
    5
    Location:
    SYD AUS
    YO YOUR MAKING ME NERVOUS i just scoured every where for one shekled up and you may have a true review however mine didnt look like a used one rolled down stairs but i hope your findings arnt accurate thank u for heads up
  22. IINexusII

    IINexusII

    Joined:
    Apr 11, 2009
    Messages:
    907 (0.47/day)
    Thanks Received:
    171
    Location:
    London, UK
    looks like someone used a thor hammer on your hsf and dented it.
    Nick89 says thanks.
  23. TheMailMan78

    TheMailMan78 Big Member

    Joined:
    Jun 3, 2007
    Messages:
    20,896 (8.00/day)
    Thanks Received:
    7,477
    What kinda paste did you use? I ask because I get better idle temps with my orb so I think your thor is messed up or you used cheap paste.
  24. radeon747

    radeon747 New Member

    Joined:
    Sep 1, 2009
    Messages:
    112 (0.06/day)
    Thanks Received:
    6
    Location:
    Australia/Victoria/Melbourne
  25. Nick89

    Nick89

    Joined:
    Jun 1, 2006
    Messages:
    1,742 (0.59/day)
    Thanks Received:
    176
    Location:
    The Nevada Wasteland
    I wanted to see if it was "broken". Its an absolute nightmare to return.

    I used AS5. Stated in the first post.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page