1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Graphics card Problem After BIOS update-Need BIOS file

Discussion in 'Graphics Cards' started by curioz, Jul 20, 2013.

  1. curioz New Member

    Joined:
    Jul 20, 2013
    Messages:
    3 (0.01/day)
    Thanks Received:
    0
    Hi there

    I've flashed the Video BIOS of my Sapphire Radeon HD4650 AGP IGB graphics card
    BIOS rom downloaded from here

    http://www.techpowerup.com/vgabios/...=HD**4650&interface=AGP&memType=&memSize=1024

    Before flashing this was my GPU data

    Field Value
    Graphics Processor Properties
    Video Adapter ATI Radeon HD 4670 (RV730)
    BIOS Version 011.022.009.002.033328
    BIOS Date 2/16/2011
    GPU Code Name RV730 XT
    Part Number 11xxxxxxA
    PCI Device 1002-9490 / 174B-0028 (Rev 00)
    Transistors 514 million
    Process Technology 55 nm
    Die Size 146 mm2
    Bus Type AGP 8x @ 8x
    Memory Size 1 GB
    GPU Clock 300 MHz (original: 600 MHz)
    RAMDAC Clock 400 MHz
    Pixel Pipelines 8
    Texture Mapping Units 32
    Unified Shaders 320 (v4.1)
    DirectX Hardware Support DirectX v10.1
    Pixel Fillrate 2400 MPixel/s
    Texel Fillrate 9600 MTexel/s
    PowerControl 0%

    Memory Bus Properties
    Bus Type DDR2
    Bus Width 128-bit
    Real Clock 396 MHz (DDR) (original: 400 MHz)
    Effective Clock 792 MHz
    Bandwidth 12.4 GB/s

    Utilization
    GPU 8%
    Dedicated Memory 138 MB
    Dynamic Memory 42 MB

    ATI PowerPlay (BIOS)
    State #1 GPU: 600 MHz, Memory: 400 MHz (Boot)
    State #2 GPU: 600 MHz, Memory: 400 MHz
    State #3 GPU: 600 MHz, Memory: 400 MHz (UVD)
    State #4 GPU: 600 MHz, Memory: 400 MHz


    After flashing BIOS my video display becomes 1024*768 , it was1366*768 before . And new data shows something like this , I can't change the display configuration anymore.


    Field Value
    Graphics Processor Properties
    Video Adapter Sapphire Radeon HD 4670 AGP
    BIOS Version 011.022.005.000.033328
    BIOS Date 11/17/2010
    GPU Code Name RV730 Pro
    Part Number 11xxxxx1
    PCI Device 1002-9495 / 174B-0028 (Rev 00)
    Transistors 514 million
    Process Technology 55 nm
    Die Size 146 mm2
    Bus Type AGP 8x @ 8x
    Memory Size 1 GB
    GPU Clock 599 MHz (original: 600 MHz)
    RAMDAC Clock 400 MHz
    Pixel Pipelines 2
    Texture Mapping Units 32
    Unified Shaders 320 (v4.1)
    DirectX Hardware Support DirectX v10.1
    Pixel Fillrate 1198 MPixel/s
    Texel Fillrate 19168 MTexel/s

    Memory Bus Properties
    Bus Type DDR2
    Bus Width 128-bit
    Real Clock 396 MHz (DDR) (original: 400 MHz)
    Effective Clock 792 MHz
    Bandwidth 12.4 GB/s

    ATI PowerPlay (BIOS)
    State #1 GPU: 600 MHz, Memory: 400 MHz (Boot)
    State #2 GPU: 600 MHz, Memory: 400 MHz
    State #3 GPU: 600 MHz, Memory: 400 MHz (UVD)
    State #4 GPU: 600 MHz, Memory: 400 MHz


    I forgot to keep a backup file of my old GPU BIOS. I urgently need the old BIOS file. It would be great if someone could provide me that, my system is unstable and now my system not completely detecting my graphics card configuration. I am waiting for some help

    After some googling i found my device ID here, could someone help me please, my graphics card temperature is also high i think.
    http://www.techpowerup.com/gpuz/4vuva/
     
  2. Law-II

    Law-II

    Joined:
    May 9, 2011
    Messages:
    1,572 (1.28/day)
    Thanks Received:
    645
    Location:
    Mainland Britain
    Hi

    Welcome to TPU

    Are sure this is an HD4650 AGP as device ID shows 4670! ?
    http://www.sapphiretech.com/presentation/product/?cid=1&gid=4&sgid=571&pid=275&lid=1# Is this card?

    HD4650 AGP
    *Maybe this here

    nb: if you get a chance next time you are logged in to forum; fill in your system specs in User CP hardware brandnames; model numbers and OS

    atb (all the best)

    Law-II
     
    Last edited: Jul 20, 2013
    curioz says thanks.
  3. curioz New Member

    Joined:
    Jul 20, 2013
    Messages:
    3 (0.01/day)
    Thanks Received:
    0
    My GPU seems to be 4650 XT based one ,but currently it becomes Pro, May be a wrong file flash.

    Default Video BIOSdata

    Graphics Processor Properties
    Video Adapter ATI Radeon HD 4670 (RV730)
    BIOS Version 011.022.009.002.033328
    BIOS Date 2/16/2011
    GPU Code Name RV730 XT
    Part Number 11xxxxxxA
    PCI Device 1002-9490 / 174B-0028 (Rev 00)



    After flashing


    Video Adapter Sapphire Radeon HD 4670 AGP
    BIOS Version 011.022.005.000.033328
    BIOS Date 11/17/2010
    GPU Code Name RV730 Pro
    Part Number 11xxxxx1
    PCI Device 1002-9495 / 174B-0028 (Rev 00)

    It's SAPPHIRE HD 4650 1GB DDR2 AGP card only. But I've seen many other members also got my same card for example my ID matches with this
    http://www.techpowerup.com/gpuz/4vuva/


    So if anyone else has got this card please share the BIOS file with me, I will be really thankful to you, My old system works because of this card. Unfortunately there are no BIOS backups in my hand :confused:. I hope some one will help me here.
     
  4. drdeathx

    drdeathx

    Joined:
    May 14, 2009
    Messages:
    2,132 (1.09/day)
    Thanks Received:
    479
    Location:
    Chicago burbs
    Why are you flashing your bios?
     
  5. curioz New Member

    Joined:
    Jul 20, 2013
    Messages:
    3 (0.01/day)
    Thanks Received:
    0
    I was just trying to update the BIOS, I thought it will boost my system performance. :rolleyes:

    Anybody got this card?, then please help me. Thank you very much.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page