1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Guide to running multiple GPU work units

Discussion in 'World Community Grid (WCG)' started by KieX, Oct 21, 2012.

  1. KieX

    Joined:
    Dec 18, 2009
    Messages:
    2,408 (1.38/day)
    Thanks Received:
    2,461
    Location:
    London, UK
    Your BOINC is version 7.0.28 You will need to get 7.0.40 or higher in order for the app_config to work. Currently in BETA, but seems to be stable, link to all the downloadable versions:

    http://boinc.berkeley.edu/download_all.php
     
    [Ion], Norton and HammerON say thanks.
  2. m&m's

    m&m's

    Joined:
    Sep 2, 2011
    Messages:
    206 (0.18/day)
    Thanks Received:
    136
    Location:
    North
    I think you have to set this:

    <app_config>
    <app>
    <name>hcc1</name>
    <max_concurrent>16</max_concurrent>
    <gpu_versions>
    <gpu_usage>.125</gpu_usage>
    <cpu_usage>.5</cpu_usage>
    </gpu_versions>
    </app>
    </app_config>

    From what I understand, you got 2 cards, with 8 WU each so 2*8=16
    Each card does 8 WU so 1/8=0.125
    Your CPU got 8 threads so 8/16=0.5

    Hope it works.
     
    Crunching for Team TPU
  3. HammerON

    HammerON The Watchful Moderator Staff Member

    Joined:
    Mar 2, 2009
    Messages:
    6,497 (3.18/day)
    Thanks Received:
    3,598
    Crap!!! Thanks KieX. Downloading now:toast:

    Hmm...
    My CPU actually has 12 threads so I guess the cpu_usage should be at .75.

    Okay - looks like both rigs are good to go now:)
    Running 8 WU's/GPU on the main rig and 4 WU's/GPU on the other:toast:
    [​IMG]
    [​IMG]
     
    Last edited: Jan 1, 2013
    [Ion] and manofthem say thanks.
    Crunching for Team TPU
  4. mstenholm

    Joined:
    Nov 7, 2009
    Messages:
    2,054 (1.15/day)
    Thanks Received:
    1,155
    HammerON says thanks.
    Crunching for Team TPU
  5. ThE_MaD_ShOt

    ThE_MaD_ShOt

    Joined:
    Nov 29, 2011
    Messages:
    4,863 (4.69/day)
    Thanks Received:
    3,416
    Location:
    Hi! I'm from the Internet
    Maybe I ought to crank up my gpus. I am still only running 1 wu per card in the Cfd' rig and 3 wu's on the 7850.
     
    Crunching for Team TPU
  6. Norton

    Norton WCG-TPU Team Captain

    Joined:
    Dec 21, 2011
    Messages:
    8,661 (8.52/day)
    Thanks Received:
    19,603
    That 7850 should be able to handle 6 wu's without too much trouble ;)

    IMHO I would keep the 6850's doing single wu's...
     
    ThE_MaD_ShOt says thanks.
    Crunching for Team TPU
  7. BarbaricSoul

    BarbaricSoul

    Joined:
    Feb 21, 2008
    Messages:
    5,173 (2.14/day)
    Thanks Received:
    2,047
    so how exactly should I have my config file written out so I get the most I can get out of my 2600k/7970 system, then how should I have the config file written out for my i7 860/GTX 560 system
     
    Crunching for Team TPU
  8. manofthem

    manofthem

    Joined:
    Jan 9, 2011
    Messages:
    5,983 (4.39/day)
    Thanks Received:
    7,461
    That looks awesome HammerOn, some crazy points will be coming from those setups! I'm jelly :roll: Glad to have you back up and running, like a champ. Looks like I'll be giving up my pie spot soon :cry:
     
    HammerON says thanks.
    Crunching for Team TPU More than 25k PPD
  9. Norton

    Norton WCG-TPU Team Captain

    Joined:
    Dec 21, 2011
    Messages:
    8,661 (8.52/day)
    Thanks Received:
    19,603
    This app_config will do 10 gpu wu's, which is a good starting point for a 7970 and should get you close to 100k ppd on the rig :)

    <app_config>
    <app>
    <name>hcc1</name>
    <max_concurrent>10</max_concurrent>
    <gpu_versions>
    <gpu_usage>.1</gpu_usage>
    <cpu_usage>.8</cpu_usage>
    </gpu_versions>
    </app>
    </app_config>

    Just follow the instructions in post #1 of this thread on getting it into your project folder and install the latest version of BOINC (7.0.42 (x64) )*
    *note- multiple wu's has issues with Win8 (ok w/Win7)

    The GTX 560 rig may do best just with single wu's (NVidia gpu's are pretty slow with these)
     
    BarbaricSoul says thanks.
    Crunching for Team TPU
  10. theonedub

    theonedub habe fidem

    Joined:
    Apr 30, 2009
    Messages:
    7,140 (3.60/day)
    Thanks Received:
    3,664
    Production running 3WUs on my 580 resulted in noticeable increase of PPD. I have it running 5WUs across 2 CPU threads and so far production looks to be up. I think 5 is the limit for Nvidia.

    Also, the 6770 (a rebadged 5770) handles 3WUs across 3 CPU threada fine although the computer will be laggy. Doesn't bother me since its dedicated. The 6850 should at least match the 6770 in # of WUs.

    Still able to run WUs from other projects on the free CPU threads, too.
     
    Norton says thanks.
    Crunching for Team TPU
  11. Norton

    Norton WCG-TPU Team Captain

    Joined:
    Dec 21, 2011
    Messages:
    8,661 (8.52/day)
    Thanks Received:
    19,603
    Thanks for the info! :toast:

    Is your project selection set to more projects than just HCC? Was wondering if the app_config was a viable workaround for this.

    Is the 6770 running on Win8? manofthem was having issues trying to run with multiple wu's while running on 8.
     
    Crunching for Team TPU
  12. theonedub

    theonedub habe fidem

    Joined:
    Apr 30, 2009
    Messages:
    7,140 (3.60/day)
    Thanks Received:
    3,664
    Yes its running every other active project I meet the req for. What were you thinking about the app info?

    The 6770 is on Win8. I gave the info I had to MoT, but unfortunately it was not able to solve his multiGPU issues.
     
    Norton says thanks.
    Crunching for Team TPU
  13. Norton

    Norton WCG-TPU Team Captain

    Joined:
    Dec 21, 2011
    Messages:
    8,661 (8.52/day)
    Thanks Received:
    19,603
    I have a 6c/12t Xeon running 4 gpu wu's on a 7770 with the balance running HCC cpu wu's atm. Wasn't sure if the app_config would interfere with other wu's if I added them to the WCG profile for the rig (i.e. thought the app_config needed to specify what to run like what the app_info setup needed)..... apparently not based on your info.

    Will need to adjust the WCG profile for the rig and try this out! :cool:
     
    Crunching for Team TPU
  14. m&m's

    m&m's

    Joined:
    Sep 2, 2011
    Messages:
    206 (0.18/day)
    Thanks Received:
    136
    Location:
    North
    Hello everybody, I did a utility to set all the settings required faster.
    The utility works with Vista/7/8 and with the new app_config.xml (BOINC version 7.0.40 or above).

    Basically, it creates the app_config.xml with all your settings.

    It should (I hope) save you time.

    Happy new year!
     

    Attached Files:

    A novice, KieX, BarbaricSoul and 4 others say thanks.
    Crunching for Team TPU
  15. Norton

    Norton WCG-TPU Team Captain

    Joined:
    Dec 21, 2011
    Messages:
    8,661 (8.52/day)
    Thanks Received:
    19,603
    Great idea! :toast:

    Does it create the file and save it to the proper folder or does it just create the file?

    **NOTE- it does deposit the completed file exactly where it needs to go but remember to shut down BOINC before you use it**
     
    Last edited: Jan 2, 2013
    m&m's says thanks.
    Crunching for Team TPU
  16. m&m's

    m&m's

    Joined:
    Sep 2, 2011
    Messages:
    206 (0.18/day)
    Thanks Received:
    136
    Location:
    North
    Create and save (or replace the old file) to the proper folder.
     
    Crunching for Team TPU
  17. t_ski

    t_ski Former Staff

    Joined:
    Apr 11, 2006
    Messages:
    10,841 (3.50/day)
    Thanks Received:
    4,294
    Well, I traded off the GTX280 in the kids rig for a mobo, so I took one of the 7770's out of the i5 3570K rig so the kids can use their computer. I figured I'd try to run WCG overnight on it, but it keeps crashing. Temps look fine for CPU and GPU. Any thoughts?

    I tried 12.11 beta 11's and 12.10 official and get the same result.
     
    Crunching for Team TPU
  18. manofthem

    manofthem

    Joined:
    Jan 9, 2011
    Messages:
    5,983 (4.39/day)
    Thanks Received:
    7,461
    AMD driver crash/recover or like a BSOD?


    Unrelated, anyone else not getting a fresh supply of GPU WU's? My flow had slowed a bit earlier, saying that there was no work available, and then they started incoming again. now I just sent a whole lot of completed WUs, and none received : confused:

    Just realized I'm still using the old method, so after these WUs are done, I'm going to be updating and using the app_config instead.
     
    Last edited: Jan 2, 2013
    Crunching for Team TPU More than 25k PPD
  19. t_ski

    t_ski Former Staff

    Joined:
    Apr 11, 2006
    Messages:
    10,841 (3.50/day)
    Thanks Received:
    4,294
    Yes, first with 12.11beta11 it was driver crash, then GPU recover. I uninstalled and installed 12.10 official and got a hard lock with GPU fan at 100%. Had to power off the PC & reboot.

    EDIT: I think the card is bad. I tried to run BOINC again on it and noticed the GPU temp was going up and up, so I went to turn up the fan temp in Afterburner. The system locked up again, but this time when I rebooted there were green lines everywhere :banghead:

    Nice card, too:

    http://www.asus.com/Graphics_Cards/AMD_Series/HD7770DC1GD5/
     
    Last edited: Jan 2, 2013
    Crunching for Team TPU
  20. manofthem

    manofthem

    Joined:
    Jan 9, 2011
    Messages:
    5,983 (4.39/day)
    Thanks Received:
    7,461
    So I updated and am now using the app_config but it doesn't seem to be taking effect. It just runs 1 WU/ card... Ran it for a while to see if it would adjust and 40 minutes later, same thing. Tried again: uninstall/reinstall BOINC, put in app_config, same 1 WU. weird. Any ideas?

    edit-1: might be getting somewhere, seems 4 WUs are working ok. Need to get it up to 10 again
    edit-2: looking good now. For some reason, it didn't work the first several tries. But it did seem to work when I gradually increased the numbers in the app_config :confused: It seems to be working now :)

    That sucks! Did you ever have a problem before with it?
     
    Last edited: Jan 2, 2013
    Crunching for Team TPU More than 25k PPD
  21. BarbaricSoul

    BarbaricSoul

    Joined:
    Feb 21, 2008
    Messages:
    5,173 (2.14/day)
    Thanks Received:
    2,047
    I used that config file, followed the instructions, and updated my bionic client to the .42 beta and it's still only running 1 WU on my GPU :banghead:

    [​IMG]
     
    Crunching for Team TPU
  22. mstenholm

    Joined:
    Nov 7, 2009
    Messages:
    2,054 (1.15/day)
    Thanks Received:
    1,155
    Some people report that it takes a try or two. Restart you PC. If that don't help then stop (suspend and close it down) the BOINC client. Delete the file, Restart the PC, start the BOINC client. Copy the file in. Restart PC.
     
    Crunching for Team TPU
  23. t_ski

    t_ski Former Staff

    Joined:
    Apr 11, 2006
    Messages:
    10,841 (3.50/day)
    Thanks Received:
    4,294
    No, it was humming right along in the i5 rig to the best of my knowledge, but it was not the main GPU. PPD was still strong. I'm hoping I didn't blow it up by trying to tweak it in Afterburner. :(
     
    Crunching for Team TPU
  24. mstenholm

    Joined:
    Nov 7, 2009
    Messages:
    2,054 (1.15/day)
    Thanks Received:
    1,155
    It worked for me. Now 10 GPU on 8 cores. KieX please include this in first post and we or rather you should not need to guide anybody in how to set up multiple GPUs. I just hope that all the people that gave up in the past would give it a try. Just remember to stop BONIC, run the script, restart PC.

    Edit:I'm not sure that 10 is better then 8 for my 7950. It might even out but for now I tend to run either to much GPU or CPU, you know when they run in sync. My 24 GPU/12 cores did that to begin with but is now spread out so GPU and CPU load is more or less constant. I now see 0-96% GPU and 30-100% CPU on the 7950. Anyway I will let it run for some days. It has to bet 100k PPD.

    ps: CPU is only at 3.3 GHz due to heat.
     
    Last edited: Jan 2, 2013
    m&m's and KieX say thanks.
    Crunching for Team TPU
  25. BarbaricSoul

    BarbaricSoul

    Joined:
    Feb 21, 2008
    Messages:
    5,173 (2.14/day)
    Thanks Received:
    2,047
    Like mstenholm, using m&m's utility got me up and running. Currently running 8 WU on my 7970 and 8 WU on my 2600k.

    [​IMG]
     
    m&m's, mstenholm and KieX say thanks.
    Crunching for Team TPU

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page