1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Having problems with my Razer naga mouse

Discussion in 'General Hardware' started by tuunade98, Sep 14, 2012.

  1. tuunade98

    Joined:
    Jan 12, 2010
    Messages:
    191 (0.11/day)
    Thanks Received:
    4
    I have just recently bought a Razer naga mouse, it has been awesome. But its been having annoying problems. Every time i boot up my computer the mouse doesn't boot up . I have to replug the usb cable every single time for it to actually work and light up.
    I tried installing a new firmware, which fixed the problem for a few days, until a new update for the mouse came out. After the update my mouse stopped working properly, as mentioned above. It won't boot up properly during the startup of my computer. Turning on the computer, restarting computer and turning of and on the computer, gives all the same results. Does anyone know a fix for this?
     
  2. razor2890

    Joined:
    Aug 2, 2012
    Messages:
    111 (0.14/day)
    Thanks Received:
    12
    Reinstall Microsoft .NET Framework 4 Extended, and the repair of the Microsoft .NET Framework 4 Client Profile. This did the trick for me... I had similar problems..
    I have a Razer Naga mouse as well as a Logitech wireless mouse.

    But then after I updated drivers for Razer. Razer Naga wasn't moving when I boot-up, awake from sleep. I can move my wirless mouse and the Razer Naga will work just fine like normal.
    I reinstalled .net framework and problem was solved...
     
    purecain and tuunade98 say thanks.
  3. tuunade98

    Joined:
    Jan 12, 2010
    Messages:
    191 (0.11/day)
    Thanks Received:
    4
    Thanks.. for your reply, it worked out great.
     
  4. razor2890

    Joined:
    Aug 2, 2012
    Messages:
    111 (0.14/day)
    Thanks Received:
    12
    Glad it worked...Happy to help...
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page