1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

help needed to reset file names

Discussion in 'General Software' started by keakar, Jul 12, 2009.

  1. keakar

    keakar

    Joined:
    Mar 27, 2007
    Messages:
    2,376 (0.88/day)
    Thanks Received:
    292
    Location:
    just outside of new orleans
    i dont know what i did but somehow i changed all my dat files to show up as video cd movie files instead of saying its a dat file.

    im not talking about the file extentions because they still show as file.dat so thats still ok but the ID tag you see shown under the file name is whats showing up as a video cd movie

    can someone tell me how to restore this to the default file ID so it reads correctly again?

    i have uninstalled nero 7 thinking it had something to do with nero vision but that didnt fix it and i reset the defaults for internet options and i even uninstalled explorer 8 but that didnt help either.

    i would be very greatfull if someone can help me fix this :respect:

    thank you in advance for your help
  2. temp02 New Member

    Joined:
    Mar 18, 2009
    Messages:
    493 (0.25/day)
    Thanks Received:
    166
    If you are talking about file opener association then open regedit and browse to the key: Computer\HKEY_CLASSES_ROOT\.dat and delete this entry.
    Or simply run the file in the attachment.
    Either one should do the trick, just remmember to get Admin privilege before doing anything (Run as... Admin).
    Restar the computer just in case and it should be ok by then.
    Editing the registry is dangerous, be extra carefull what you do in there (it's best to backup before editing it manually).

    Attached Files:

    • Fix.zip
      File size:
      217 bytes
      Views:
      104
  3. keakar

    keakar

    Joined:
    Mar 27, 2007
    Messages:
    2,376 (0.88/day)
    Thanks Received:
    292
    Location:
    just outside of new orleans
    what i am talking about is when you put the mouse over a file it shows additional info under the name such as:

    file type
    date modified
    size

    its the file type description that has changed from a "dat" file into a "video CD movie" type.



    i see you made a self installing registry thing to add something to the registry but i would never use something like that for security reasons but i am very capable of opening the registry and editing it myself if i know where to go and what to edit so if you know what i need to do i can follow your instructions to open up the registry and edit it manually.


    also i think i forgot to mention that i am using windows xp and i have made no changes to windows default settings so its set to keep name suffixes hidden but the file still shows the .sim .zon .act .dds but none of the .dat files read as .dat files anymore, it shows just the file name only.

    i really dont want to reformat and reinstall the OS to fix this :confused:
    Last edited: Jul 12, 2009
  4. keakar

    keakar

    Joined:
    Mar 27, 2007
    Messages:
    2,376 (0.88/day)
    Thanks Received:
    292
    Location:
    just outside of new orleans
    oh well, i'm just going to go ahead and reformat the hdd and reinstall the OS to fix this since nobody knows a solution :banghead:
  5. temp02 New Member

    Joined:
    Mar 18, 2009
    Messages:
    493 (0.25/day)
    Thanks Received:
    166
    I understood what you wanted in your first post and if you run that registry file it will fix it (I'm almost sure).
    The file I created doesn't add nothing to your registry, in fact it removes something. Also if you say that you are able to edit the registry manually, if you check the very first line of my post you will see that it has all the info you need to do that manually.
    If you are concerned about you privacy (or whatever) why didn't you edit that .reg I gave you and see what it contains (open with notepad)? It's just a text file with 3 lines of text (1st file header; 2nd blank line; 3rd remove specific registry entry)...
    Next time read things carefully, what were you expecting from a helpful post, a button with "magic" written on it? :laugh:

    P.S.: Also, follow the instructions on this page after fixing the problem, then kill explorer.exe (on taskmanager) and restart explorer again (new task on task manager, write explorer.exe). This will change the .dat icon to it's default (unassociated).
    Last edited: Jul 14, 2009
  6. thraxed Guest

    I think if you associated the file type with cmd.exe it would reset it. Right click on the .dat file and choose open with. Hold the shift key when you right click if you don't see the option. Just have to find the right program to change the hover info. In folder options I think there a box for showing extensions on registered file types.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page