1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

[HELP!] TV won't play mkv files through the network from my PC

Discussion in 'Networking & Security' started by adulaamin, Mar 18, 2014.

  1. adulaamin

    adulaamin

    Joined:
    Aug 1, 2009
    Messages:
    630 (0.35/day)
    Thanks Received:
    218
    Location:
    Baguio City, Philippines
    Good day TPU!

    I'm having an issue with my TV playing mkv files that are located on my PC. Here's all the info about the hardware:

    Router: TP-LINK WR2543ND
    TV: LG 32LS5700
    PC: Indicated on system specs

    PC >>> (wired connection) <<< Router >>> (wi-fi) <<< TV

    What happens is the TV won't play mkv files when I try to access it directly on my PC through the network. The file shows up on the TV although it won't play. The file looks like this on the TV:

    [​IMG]

    If I save the file on a flash drive/external drive and plug it directly to the TV or plug it on the USB port on the router I'm able to play the file. The file looks like this on the TV:

    [​IMG]

    What I did to the videos folder on my PC is so just share it on the network (Read only) so it would show up on the TV or on the other PC in the house. It's a bit of a hassle to have to save the video on an external drive and plug it to the TV or the router every time someone wants to watch a movie.

    Am I doing something wrong? Is there some setting I should enable/disable?
  2. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    14,645 (3.93/day)
    Thanks Received:
    11,381
    Are you using DLNA for playback? Or just a normal Windows Network Share?

    I recently bought a new TV and started running Plex Media Server (free) on my download PC to stream to TV.
    adulaamin says thanks.
  3. adulaamin

    adulaamin

    Joined:
    Aug 1, 2009
    Messages:
    630 (0.35/day)
    Thanks Received:
    218
    Location:
    Baguio City, Philippines
    I tried LG's SmartShare and normal network share. Both don't work. I'll try Plex Media Server once I get home.

    EDIT: Worked like a charm! Thanks W1z! :toast:
    Last edited: Mar 18, 2014

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page