1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Help with XFS file system (linux)

Discussion in 'Storage' started by Mussels, Mar 24, 2013.

  1. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    Short version: i have a NAS device i bought on impulse. It works fine.


    However, the ONLY file system it supports, is linux based XFS.


    I need to find an operating system that i can run in a VM or boot from a live CD, that will allow me to access the data on these drives should the NAS fail.

    I've tried the latest ubuntu - and failed. it didnt see the drive(s) appear when connected to the system.


    Can someone suggest alternative operating systems i can try? i'm quite the beginner with linux. ALL i want is something that reads XFS hard drives from this stupid buffalo NAS, and will allow me to copy them to other drives.
     
  2. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    bump.


    no linux experts here?
     
  3. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    13,663 (5.00/day)
    Thanks Received:
    1,863
    you might have to try SourceForge or FSF
     
  4. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    some more details please?
     
  5. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    13,663 (5.00/day)
    Thanks Received:
    1,863
    FSF is Free Software Foundation, or even try the site of your build of linux.
     
  6. RCoon

    RCoon Gaming Moderator Staff Member

    Joined:
    Apr 19, 2012
    Messages:
    7,993 (8.15/day)
    Thanks Received:
    4,106
    Location:
    Gypsyland, UK
    I have Ubuntu 12.4 LTE running on a VM that is sharing a folder tree to windows networked drive through Samba.
    That is a total pain in the ass but it works, i just google everything when i feel like killing linus torvalds
     
  7. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,043 (3.88/day)
    Thanks Received:
    11,951
    On CentOS 6 you just need to install the xfsprogs package to mount XFS filesystems.

    yum install xfsprogs
     
    Mussels says thanks.
  8. Chevalr1c

    Chevalr1c

    Joined:
    Sep 3, 2010
    Messages:
    3,308 (2.10/day)
    Thanks Received:
    1,489
    Location:
    NL, Europe
    All modern Linux distros should be able to use the XFS FS using xfsprogs, actually. That includes Ubuntu.
     
    Crunching for Team TPU
  9. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    i installed ubuntu and had no luck, is XFSprogs installed by default?
     
  10. bencrutz

    Joined:
    Jun 23, 2011
    Messages:
    176 (0.14/day)
    Thanks Received:
    34
    no, well, it think it was, now it isn't

    why not just use apt-get install xfsprogs?

    edit: am pretty sure you can also 'apt-get install' on live session, so no need to install ubuntu
     
    Last edited: Apr 23, 2013
    Chevalr1c and Mussels say thanks.
  11. BiggieShady

    BiggieShady

    Joined:
    Feb 8, 2012
    Messages:
    1,045 (0.99/day)
    Thanks Received:
    365
    Location:
    Zagreb, Croatia
    Mussels says thanks.
  12. Geekoid New Member

    Joined:
    Mar 27, 2013
    Messages:
    77 (0.12/day)
    Thanks Received:
    24
    Location:
    UK
    Any Linux distro can use the XFS file system. Its been around for ages, so even older distros will support it. If you like Ubuntu and unity, then go with that. If not, then pick a distro that suits you: http://distrowatch.com/

    If you're using ubuntu, just click Software Centre and install xfsprogs.

    I guess its a single drive NAS, as you haven't said?
     
  13. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    quad drive, but im not running RAID.


    i'm a total beginner at linux, so even installing packages was new to me when i made the first post.
     
  14. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    ok so i've tried two methods in here just now, and neither worked. please offer help.


    1. apt-get install xfsprogs

    says im not root. no idea how to change to be root/admin in ubuntu.
    edit: sudo, got it. said another process was using needed files, working on that now.


    2. 'software centre' i cant find this program. theres software sources and software updater?
     
  15. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    ok so XFSprogs is installed, but the drive still doesnt show up automatically like my USB drives do.


    any ideas lads?


    edit: woot progress!

    [​IMG]


    now to figure out how to read it since its apparently an unknown filesystem :/


    http://javathought.wordpress.com/2011/06/18/ubuntu-xfs-and-buffalo-nas/

    ^ this page has a 'fix' guide but some of the commands appear outdated. he asks to edit a fstab file, which i have now done.


    now theres one more step where he gives some commands im not sure what they do:

    sudo mkdir/media/MyXFSDriv
    sudo mount /dev/sdd6


    these do not work (command not found)


    another edit:

    sudo mount /dev/sdb[6] /media/mussels

    ^ this command worked, but says "mount: unknown filesystem type 'linux_raid_member'"
     
    Last edited: Apr 24, 2013
  16. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    ok i've got as close as i think i can get.

    apparently the drive thinks its in a RAID 1 array when its not (thanks buffalo!)

    the following command should have worked to mount it:

    sudo mount -t xfs /dev/sdb[6] /media/mussels

    but instead i get the error:
    "mount: wrong fs type, bad option, bad superblock on /dev/sdb6,
    missing codepage or helper program, or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so"


    googling suggests i need a program called mdadm, but installing it gets me stuck on a screen where it asks for a mail server and i cant select or type anything :/ stuck again i guess
     
    Last edited: Apr 24, 2013
  17. bencrutz

    Joined:
    Jun 23, 2011
    Messages:
    176 (0.14/day)
    Thanks Received:
    34
    Nice progress there :)

    Have never playing around with buffalo nas, but i'll see if i can help you later, when i'm back from work.

    Ps: sorry, should have mention that sudo thing…
     
  18. Chevalr1c

    Chevalr1c

    Joined:
    Sep 3, 2010
    Messages:
    3,308 (2.10/day)
    Thanks Received:
    1,489
    Location:
    NL, Europe
    Well if it is on RAID (or Ubuntu "thinks" it is) we should first look at that. Problem is hough that I lack experience with RAID and Linux. :(

    Maybe you should PM Easy Rhino or Aquinus? They know vastly more than I do.
     
    Crunching for Team TPU
  19. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,043 (3.88/day)
    Thanks Received:
    11,951
    try to import that raid .. mdadm is used to administrate raid arrays, you might have to install it.

    mdadm --scan should tell you more
     
    Chevalr1c says thanks.
  20. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    mdadm wont install. it comes up with a prompt about some kind of email server and wont accept any inputs.
     
  21. Geekoid New Member

    Joined:
    Mar 27, 2013
    Messages:
    77 (0.12/day)
    Thanks Received:
    24
    Location:
    UK
    Software Centre is the icon you use to install or remove software in Ubuntu. Some information about it is here:

    http://www.ubuntu.com/desktop/features/more-apps

    Its not the only way to install or remove software, but it is graphical and hence easier for people to use that aren't used to typing commands. The icon is a bag, choc full o' stuff and is automatically placed on the left for you. You could also access it from dash home, and will appear automatically as you type 'software'. Its good to use as it will do everything automatically for you, including installing other bits (such as libraries) that may to needed to run the item you have selected.

    So, taking this example, to install mdadm to manage your Linux MD arrays, you would open Software Centre and search for mdadm. You would then click 'install' to install it. As you've only got a single 500GB drive in your buffalo NAS, it is indeed pretty strange for it to try and use RAID-1!

    Anyway, first things first, you should verify that you really do have xfsprogs installed. You should install this and xfsdump. Software Centre should show them as being installed, and also when you use gparted you will see xfs support has green ticks rather than red circles with crosses (under file system support).
     
    Mussels says thanks.
  22. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    XFSprogs and XFSdump tell me that they're already installed and up todate. i'll try installing MDADM through software centre.

    that was so much easier than command prompts.
     
    Last edited: Apr 25, 2013
  23. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,565 (11.40/day)
    Thanks Received:
    9,836
    as soon as MDAM was installed the array automatically popped up and worked.


    thank god for that!

    lets hope this helps other people in the same boat.
     
    Chevalr1c says thanks.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page