1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

HIS ATi radeon 4870X2 problem

Discussion in 'AMD / ATI' started by Jaffakeik, Dec 6, 2008.

  1. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    I got some big problem.I bought this videocard and for about month all was ok.than my videocard started overheat rapidly.ok i used in system fan speed at 40% and in games about 60% and was ok again.but now i get grenn dot and white line gliches over all screen even when i turn on pc and videcard is cooled down gliches are there anyway but videocard temperature is only 50'C max.and still hepens these glitches.when i got some lucky time without glitches when windows starts in just case i tur fan at 100% but gliches starts to appier anyway and system holds and monitors starts to turn off on and no normal screen to see only full screen of green or white squeres or dots.I tried everything newest drivers anything nothing helps.I think i trie to get new one with my one year varranty.its definetly videocard issue.
     
  2. douglatins

    douglatins

    Joined:
    May 15, 2008
    Messages:
    2,867 (1.24/day)
    Thanks Received:
    273
    Location:
    Brasil
    If RMAing wont be a hassle, you should do it
     
  3. mos187

    mos187 New Member

    Joined:
    Mar 30, 2007
    Messages:
    181 (0.07/day)
    Thanks Received:
    7
    Rma...
     
  4. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    Ok in first place what is RMA?and second when i fully delete all videocard drviers videocard dont get glitches anymore in lovest resulution,but when i install drivers again in happens again.
     
  5. christof139 New Member

    Joined:
    Nov 14, 2008
    Messages:
    447 (0.21/day)
    Thanks Received:
    20
    Location:
    Detroit, Motown, Michigan.
    Hi, Try using the ATI Catalysts drivers rather than HIS drivers, or visa versa if you are already using the ATI drivers. You night have old drivers on your machine tht weren't totally removed when you removed them. Here is a link to the ATI river Removal page with instructions on how to completely remove old drivers, but I don't know if this is the problem. Hope it helps you.

    http://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&questionID=20870

    Chris
     
  6. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    I already have tried his drivers form his homepage and tried froma ati page drivers newest.and i used driver sweeper to completly remove lod drivers.but it doesnt sovle.problem.But the funniest thing is when i delete drivers going in safe mode and than do restart videocard goes smooth without drivers no glitches and all goes fine.but like u all know i want to play games all need bigger resulation.And whenever i install drivers glitches returns so i think that problem is in drivers more than in videocard.
     
  7. mos187

    mos187 New Member

    Joined:
    Mar 30, 2007
    Messages:
    181 (0.07/day)
    Thanks Received:
    7
    ok Aricks, what PSU/Wattage r u using....
     
  8. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    Im using Tagan ITZ series 1100 PSU.
     
  9. Fastmix

    Fastmix New Member

    Joined:
    Aug 5, 2008
    Messages:
    627 (0.28/day)
    Thanks Received:
    115
    Location:
    The Kingdom of Heaven
    When you remove the drivers it's all good because the generic drivers provided from your OS don't use the advance 3d settings of your card.

    I would try the new 8.12, if that does not solve the issue you might want to look at bios update for your motherboard and if that does not solve the issue.....your card should still be under warranty.;)
     
    Jaffakeik says thanks.
  10. mos187

    mos187 New Member

    Joined:
    Mar 30, 2007
    Messages:
    181 (0.07/day)
    Thanks Received:
    7
    Definatily not the PSU, the 4870X2 requires alot of power & sometimes PSU efficiency or power shortage could cause alot of issues in 2D/3D..
    repeat the driver removing process and go with Fastmix's suggestion.....
     
  11. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    I will better wait for final release of 8.12 catalist drivers.But now i will update bios for Motherboard just in case.
     
  12. EastCoasthandle

    EastCoasthandle New Member

    Joined:
    Apr 21, 2005
    Messages:
    6,889 (2.00/day)
    Thanks Received:
    1,505
    I would like to see the inside of your PC Case. For example: Overall view of the components inside your PC Case. You can upload your photo here
     
    Jaffakeik says thanks.
  13. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    I just now upgraded bios to newest.hope it will do some good.I will try to upload overlook of my pc,ok i uploaded picture [​IMG] and i got on big side fan and one front fan. on my case.
     
    Last edited: Dec 8, 2008
  14. EastCoasthandle

    EastCoasthandle New Member

    Joined:
    Apr 21, 2005
    Messages:
    6,889 (2.00/day)
    Thanks Received:
    1,505
    Ok, IMO you need good PC case ventilation. Does your case support a fan that will intake air inside the case (IE: the other side of your hard drive cage)? I can see were a fan can be mounted at the rear of the case but that's an outlet to exhaust hot air outside of the case.
     
  15. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    Last edited: Dec 8, 2008
  16. christof139 New Member

    Joined:
    Nov 14, 2008
    Messages:
    447 (0.21/day)
    Thanks Received:
    20
    Location:
    Detroit, Motown, Michigan.
    Hope you get it going. Do you have the HDMI audio drivers disabled in Device Manager (if you installed the ATI HDMI audio drivers to begin with)?? They caused me some problems before.

    Chris
     
  17. J-Man

    J-Man New Member

    Joined:
    May 14, 2007
    Messages:
    2,248 (0.84/day)
    Thanks Received:
    81
    Location:
    Oakham, UK
    That's a lie because I hit 60c during gaming and I have better cooling then you. I was playing Crysis Warhead today and I think I may be having the same problem as you. The game just looked WEIRD. Random colours on screen, the weapon I was holding went all blurry etc. I might have to RMA also.
     
  18. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    My glitches dont appier only in games they appier even in windows when i got videocard temperature 40-50C with activated coller 60%.and full tower cooling fan speeds.so dont say to me that its a lie.Because u dont know anything about it.it has nothing to do with graphics in game the dots and squeres that appier are not game glitches they apiier overgame graphics not on them.or on weapons etc.it apiers on all screen instantly and starts to getting more and more than monitor turns off and restart goes.and its only 40-50 degrees.in first month of wideocard i didnt get such glitches.its definetly not cooling issue.
     
  19. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    I got these images from my pc.to show glitches to you. PC was not turned on for about 9hours so video card is fully cold.and when i turn pc on and all drivers are fully uninstalled/and even when they are installed i get such pictures


    [​IMG]
    [​IMG]
     
  20. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    12,419 (4.71/day)
    Thanks Received:
    1,461
    hmm looks like faulty power distribution. did you make sure to connect both power connections directly to the Vidcard from the PSU? It could also be the Monitor Itself, as i seen this type of problem occur on a laptop display (use same components) like a transformer or something is goin bad. Few Options you can try

    Different Monitor Cable
    Different Monitor
    Try card in a different machine with stated above make sure PSU can handle it
    Try Different PSU.




    btw read this for RMA.

    http://en.wikipedia.org/wiki/Return_merchandise_authorization
     
    Last edited: Dec 9, 2008
    Jaffakeik says thanks.
  21. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    i had in the begining older PSU 650w and this card had same problem than i changed PSU problem still exist. i will try different monitor or monitor cable so stay tuned for next episode of my problems.
    P.S
    yes i have correctly connected power cables to videocard.
    i dont know what is wrong but my vcard overheats.i just turned on pc it went till windows on i started install video drivers and glitches started to appier.how can i do so that vcard fun goes not on default 27% but more.but anyway in the beggining vcard didnt get glitches even with default fan speed i played all time and no glitches was.but when i instaleed drivers with fan control option the problems started to appier.
    NOpe i tried another monitor and cable no changes.
    I got now in windows with 8.12 beta drivers installed.glitches started to apier but i managet to be faster and put fan on 65% and glitches disapiered.will try game now will see what heppens.Game went for 2minits and monitor turned off and glitches apiered.and vcard temperature was only 45C.
    Ok guys i decided to buy new gainward videocard with 2fans in it.and with this i will get warranty.
     
    Last edited: Dec 9, 2008
  22. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    12,419 (4.71/day)
    Thanks Received:
    1,461
    Look at Gainward or XpertVision for Video cards
     
  23. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    Is there a difference.if i will install video drivers from videocard developers homepage or from ati homepage?
     
  24. eidairaman1

    eidairaman1

    Joined:
    Jul 2, 2007
    Messages:
    12,419 (4.71/day)
    Thanks Received:
    1,461
    Usually Drivers from the Chipmaker are compatible with all cards but if its up to you i suggest you compare the card makers drivers to the Chip makers drivers.
     
  25. Jaffakeik

    Jaffakeik

    Joined:
    Dec 6, 2008
    Messages:
    2,587 (1.22/day)
    Thanks Received:
    188
    Location:
    Northampton,UK
    yes but on makers homepage drivers are much older than on ati homepage.so i better use 8.12 than older drivers
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page