1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

How to max GPU clock for older games?

Discussion in 'Graphics Cards' started by lwgnlseven, Apr 11, 2013.

  1. lwgnlseven

    Joined:
    May 1, 2012
    Messages:
    107 (0.15/day)
    Thanks Received:
    8
    Hey guys I play an older FPS game called Warrock and am noticing frame rate drops at times and the game getting choppy on my gtx 680. I have base clock speed of 1005mhz and a boost clock of 1050mhz. During gameplay my clocks only go to like 500mhz or something. The game doesn't require a whole lot of GPU apparently, but I'd like for it to run at 1050mhz while I'm playing to maybe eliminate those times when the game gets choppy.

    In nvidia control panel i've already added the .exe in manage 3d settings, and have changed power management mode for this game to "prefer maximum performance." But still can't get 1050mhz on the clock speed. Any idea's?

    The game only uses about 50% gpu compared to metro 2033 where that uses 99% gpu and runs max clock speed all the time. This game though, will only run half the clock speed.
    Last edited: Apr 11, 2013
  2. drdeathx

    drdeathx New Member

    Joined:
    May 14, 2009
    Messages:
    2,132 (1.18/day)
    Thanks Received:
    479
    Location:
    Chicago burbs
    I would list your system specs
  3. lwgnlseven

    Joined:
    May 1, 2012
    Messages:
    107 (0.15/day)
    Thanks Received:
    8
    Turns out I was able to find it. I updated to the newest evga precision and there is a setting called kboost which maxes the clock speed for older games. Thanks :)
    newconroer says thanks.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page