1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

I lost me Bios :3

Discussion in 'Graphics Cards' started by floppers95, Sep 1, 2012.

  1. floppers95 New Member

    Joined:
    Sep 1, 2012
    Messages:
    24 (0.03/day)
    Thanks Received:
    1
    Location:
    Denmark
    ... I can't put words on how stupid I am! I have lost my backed up bios of my Club3D Radeon HD 6950 and am too scared to search on google for a BIOS... oh yeah, silly me :p I have flashed it with a 6970 bios / unlocked it :D. I just feel that my card is getting too hot and I don't feel any difference then before. so... i wounder is there ANY! way to restore my old bios... not sure of the exact model. but here's a picture of the card i have http://test.appinformatica.com/imf/...-ati-pcie-hd6950-2gb-ddr5-hdmi-dvi-2dp-1g.jpg

    If there is NO WAY! to restore it, then i just need to know, can i still get it to run in Crossfire with lets say a XFX Radeon HD 6950 ( i assume it will have to be the same BIOS)
  2. INSTG8R

    INSTG8R

    Joined:
    Nov 26, 2004
    Messages:
    2,811 (0.79/day)
    Thanks Received:
    423
    Location:
    Lost in Norway
    Well you came to the right place anyway. Start HERE Those are the Club3D's in the TPU database(If you had GPU-Z installed you could have added yours ;) )
    Good Luck and Welcome to TPU :)
    floppers95 says thanks.
  3. floppers95 New Member

    Joined:
    Sep 1, 2012
    Messages:
    24 (0.03/day)
    Thanks Received:
    1
    Location:
    Denmark
    NEATO! thanks :D i can already tell I'm going to enjoy my stay. again thanks a lot!

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page